Fix errno.
This commit is contained in:
parent
2c3b604cf0
commit
6af5047b77
10 changed files with 127 additions and 1 deletions
|
@ -1,5 +1,14 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2005/12/01 03:54:26 minskim Exp $
|
||||
$NetBSD: distinfo,v 1.2 2006/01/13 15:16:14 joerg Exp $
|
||||
|
||||
SHA1 (clex-3.14.tar.gz) = 8ed56610d2e6bb8db9af5ddbcc44b289d1b2d97c
|
||||
RMD160 (clex-3.14.tar.gz) = a23df661efa0451bd6cf1db31f9254354cee5b73
|
||||
Size (clex-3.14.tar.gz) = 178492 bytes
|
||||
SHA1 (patch-aa) = b6cd477159c3b2279f1d9d3f8dc04709115de57c
|
||||
SHA1 (patch-ab) = 0b6e36eca7ab1bc85af0a488d6d8be97f52480d5
|
||||
SHA1 (patch-ac) = 862553bf1f4a2c401e19fa8c07d24ee6a2924ca8
|
||||
SHA1 (patch-ad) = 063164741ab69827fcf95be7c70280d276b44721
|
||||
SHA1 (patch-ae) = 0c72744fde6b0315941396b0a62281cccb49e4dd
|
||||
SHA1 (patch-af) = 1532776758559542bdecc86b720ce2900c107867
|
||||
SHA1 (patch-ag) = 3791004513e333648ab95fbb8617a2d9314771ef
|
||||
SHA1 (patch-ah) = 21ed59c002e0a99df1091e04775807ad2b6b9a29
|
||||
SHA1 (patch-ai) = be0490fc358c252ef953d71f520efd641f7ac46f
|
||||
|
|
13
sysutils/clex/patches/patch-aa
Normal file
13
sysutils/clex/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
|
||||
--- src/bookmarks.c.orig 2006-01-13 14:28:29.000000000 +0000
|
||||
+++ src/bookmarks.c
|
||||
@@ -43,8 +43,6 @@ static FLAG changed = 0; /* bookmarks h
|
||||
static const char *user_bm_file; /* personal bookmarks filename */
|
||||
static time_t bm_file_mod = 0; /* last modification of the file */
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
static void
|
||||
bm_error(const char *format, ...)
|
||||
{
|
13
sysutils/clex/patches/patch-ab
Normal file
13
sysutils/clex/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
|
||||
--- src/cfg.c.orig 2006-01-13 14:43:42.000000000 +0000
|
||||
+++ src/cfg.c
|
||||
@@ -42,8 +42,6 @@
|
||||
#define CFG_LINES_LIMIT 100 /* config file size limit (in lines) */
|
||||
#define CFG_ERRORS_LIMIT 12 /* error limit */
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
static const char *user_config_file; /* personal cfg filename */
|
||||
|
||||
/* used in error handling: */
|
13
sysutils/clex/patches/patch-ac
Normal file
13
sysutils/clex/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
|
||||
--- src/completion.c.orig 2006-01-13 14:56:31.000000000 +0000
|
||||
+++ src/completion.c
|
||||
@@ -115,8 +115,6 @@ static struct {
|
||||
static int cc_alloc = 0; /* max number of candidates in CC_LIST */
|
||||
static int cc_max; /* max number of candidates to present */
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
static void
|
||||
environ_completion_init(void)
|
||||
{
|
13
sysutils/clex/patches/patch-ad
Normal file
13
sysutils/clex/patches/patch-ad
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
|
||||
--- src/exec.c.orig 2006-01-13 14:58:05.000000000 +0000
|
||||
+++ src/exec.c
|
||||
@@ -50,8 +50,6 @@
|
||||
#include "ustring.h" /* us_copy() */
|
||||
#include "xterm_title.h" /* xterm_title_set() */
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
#define MAX_SHELL_ARGS 8
|
||||
static char *shell_argv[MAX_SHELL_ARGS + 1];
|
||||
static int cmd_index; /* which parameter is the command
|
13
sysutils/clex/patches/patch-ae
Normal file
13
sysutils/clex/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
|
||||
--- src/filepanel.c.orig 2006-01-13 14:58:36.000000000 +0000
|
||||
+++ src/filepanel.c
|
||||
@@ -37,8 +37,6 @@
|
||||
#include "ustring.h" /* USTR() */
|
||||
#include "util.h" /* base_name() */
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
void
|
||||
files_initialize(void)
|
||||
{
|
13
sysutils/clex/patches/patch-af
Normal file
13
sysutils/clex/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
|
||||
--- src/help.c.orig 2006-01-13 14:58:59.000000000 +0000
|
||||
+++ src/help.c
|
||||
@@ -94,8 +94,6 @@ static int head, tail; /* circular buf
|
||||
#define MVINDEX(X,N) \
|
||||
(X = (X + HELP_HISTORY_ALLOC + N) % HELP_HISTORY_ALLOC)
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
static int
|
||||
page2num(const char *pagename)
|
||||
{
|
13
sysutils/clex/patches/patch-ag
Normal file
13
sysutils/clex/patches/patch-ag
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ag,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
|
||||
--- src/list.c.orig 2006-01-13 14:59:27.000000000 +0000
|
||||
+++ src/list.c
|
||||
@@ -80,8 +80,6 @@
|
||||
*/
|
||||
#define FE_ALLOC_UNIT 128
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
static time_t now;
|
||||
static FLAG do_a, do_d, do_i, do_l, do_L, do_m, do_M, do_o, do_p, do_s;
|
||||
static FLAG clock24, use_pathname = 0;
|
13
sysutils/clex/patches/patch-ah
Normal file
13
sysutils/clex/patches/patch-ah
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ah,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
|
||||
--- src/tty.c.orig 2006-01-13 14:59:50.000000000 +0000
|
||||
+++ src/tty.c
|
||||
@@ -25,8 +25,6 @@
|
||||
|
||||
#include "control.h" /* err_exit() */
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
static struct termios text_termios, raw_termios, *ptermios = 0;
|
||||
#ifdef _POSIX_JOB_CONTROL
|
||||
static pid_t save_pgid = 0;
|
13
sysutils/clex/patches/patch-ai
Normal file
13
sysutils/clex/patches/patch-ai
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ai,v 1.1 2006/01/13 15:16:14 joerg Exp $
|
||||
|
||||
--- src/ustring.c.orig 2006-01-13 15:00:13.000000000 +0000
|
||||
+++ src/ustring.c
|
||||
@@ -26,8 +26,6 @@
|
||||
|
||||
#include "util.h" /* emalloc() */
|
||||
|
||||
-extern int errno;
|
||||
-
|
||||
/*
|
||||
* The USTRING structure (defined in clex.h) can store a string
|
||||
* of unlimited length. The memory is allocated dynamically.
|
Loading…
Reference in a new issue