Changes 1.89:

* make it compile and test successfully with libdb 5.1, but
  do not add any new symbols or functionality.
This commit is contained in:
adam 2011-08-06 15:23:35 +00:00
parent 121228b182
commit 6af5372b2d
3 changed files with 20 additions and 37 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.4 2010/09/16 08:06:13 adam Exp $
# $NetBSD: Makefile,v 1.5 2011/08/06 15:23:35 adam Exp $
DISTNAME= BDB-1.88
DISTNAME= BDB-1.89
PKGNAME= p5-${DISTNAME}
PKGREVISION= 3
SVR4_PKGNAME= p5bdb
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=../../authors/id/M/ML/MLEHMANN/}

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2010/06/02 13:21:03 adam Exp $
$NetBSD: distinfo,v 1.3 2011/08/06 15:23:35 adam Exp $
SHA1 (BDB-1.88.tar.gz) = 75f1701d0e768755a7789e4329ac8f8dc6c6c788
RMD160 (BDB-1.88.tar.gz) = 0140f02283726f29c69cae66af5b2fe43155a55d
Size (BDB-1.88.tar.gz) = 35879 bytes
SHA1 (patch-aa) = 8f86278fa8496dc982d779293da798b5eeb0d990
SHA1 (BDB-1.89.tar.gz) = 3c217b1f186d603ada91d0621a3b174c0db04351
RMD160 (BDB-1.89.tar.gz) = 80130462b8f1e058cef9def894abfd877f29887b
Size (BDB-1.89.tar.gz) = 36333 bytes
SHA1 (patch-aa) = 65c5934b2eee5550951eb2068ddc3925e4591e70

View file

@ -1,31 +1,15 @@
$NetBSD: patch-aa,v 1.1 2010/06/02 13:21:03 adam Exp $
$NetBSD: patch-aa,v 1.2 2011/08/06 15:23:35 adam Exp $
--- BDB.xs.orig 2010-06-01 07:59:05.000000000 +0000
--- BDB.xs.orig 2011-08-06 15:21:38.000000000 +0000
+++ BDB.xs
@@ -33,7 +33,7 @@
#include <db.h>
-#if DB_VERSION_MAJOR != 4 || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR < 3)
+#if DB_VERSION_MAJOR < 4 || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR < 3)
# error you need Berkeley DB 4.3 or a newer 4.x version installed
#endif
@@ -1228,7 +1228,7 @@ BOOT:
const_iv (WRITECURSOR)
const_iv (YIELDCPU)
const_iv (ENCRYPT_AES)
-#if DB_VERSION_MINOR < 8
+#if (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR < 8)
const_iv (XA_CREATE)
#endif
const_iv (BTREE)
@@ -1382,7 +1382,7 @@ BOOT:
const_iv (PRIORITY_VERY_HIGH)
const_iv (IGNORE_LEASE)
#endif
-#if DB_VERSION_MINOR >= 7
+#if DB_VERSION_MAJOR > 4 || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 7)
//const_iv (MULTIPLE_KEY)
const_iv (LOG_DIRECT)
const_iv (LOG_DSYNC)
@@ -1313,8 +1313,10 @@ BOOT:
const_iv (LOCK_DEADLOCK)
const_iv (LOCK_NOTGRANTED)
const_iv (NOSERVER)
+#if DBVER < 520
const_iv (NOSERVER_HOME)
const_iv (NOSERVER_ID)
+#endif
const_iv (NOTFOUND)
const_iv (PAGE_NOTFOUND)
const_iv (REP_DUPMASTER)