Don't expect that inline is actually inlined.

This commit is contained in:
joerg 2020-04-20 00:47:34 +00:00
parent 882bd797a0
commit 6b0824062e
2 changed files with 18 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.22 2019/09/01 12:08:17 nia Exp $
$NetBSD: distinfo,v 1.23 2020/04/20 00:47:34 joerg Exp $
SHA1 (Eterm-0.9.6.tar.gz) = b4cb00f898ffd2de9bf7ae0ecde1cc3a5fee9f02
RMD160 (Eterm-0.9.6.tar.gz) = 96e2ebf7ee7464ffab8bbecec2976a1e5935712e
@ -12,4 +12,5 @@ SHA1 (patch-aa) = 19da5e05392994a60fdf47e9d52c82fc41cefa4c
SHA1 (patch-ab) = d019a18bb32f890d6de7c5bb0cdb43e7715a7d4d
SHA1 (patch-ai) = 1f1a050c27b042c5cccff91aae4ced7b887b68b1
SHA1 (patch-src_Makefile.in) = 3000a407bed7d7c23bfc127fd09b0723d9c0b395
SHA1 (patch-src_command.c) = 0b5b3dbde8eba16b1690155a28764ec7ea0f6bff
SHA1 (patch-src_screen.c) = f820501e3a67cfc59dedd1dd5e3eb6f06ae2be23

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_command.c,v 1.3 2020/04/20 00:47:34 joerg Exp $
--- src/command.c.orig 2020-04-19 17:56:09.198252388 +0000
+++ src/command.c
@@ -1388,9 +1388,9 @@ sco_get_pty(void)
#endif
#if defined(HAVE_POSIX_OPENPT) || defined(HAVE_DEV_PTMX)
-inline int posix_get_pty(void);
+static inline int posix_get_pty(void);
-inline int
+static inline int
posix_get_pty(void)
{