Update to version 0.12.1+1. Removed patches, as I believe autoconf

should automagically handle the features stuff (or at least other packages
that I look at don't seem to need this if they use autoconf, haven't looked
extensively, though).  This release brings lots of bug fixes.  Among
them are:


2008-01-10  Tatsuhiro Tsujikawa  <tujikawa at rednoah dot com>

	Fixed the bug that EX_TOO_LONG_PAYLOAD exception is thrown if just
	payload length(4bytes) are received. This happens because
	lenbufLength
	is not updated in this particular case and successive call of
	receiveMessage() overwrites payload length with bytes recieved which
	are payload body.

2007-12-22  Tatsuhiro Tsujikawa  <tujikawa at rednoah dot com>

	Fixed the bug that causes aria2 not to finish download. BUG#1855875.
	I could reproduce this bug in following procedure:
	1. Stop the download at the very beginning(1% or 100KB downloaded).
	2. Restart aria2.
	3. You see the download stopped around 99%.
	If timeout is reached, then _nextCommand is unused and it may
	contains
	segments and they won't be canceled. Actually, timeout is not needed
	here because if the server dropped connection, then retry is made.

2007-12-22  Tatsuhiro Tsujikawa  <tujikawa at rednoah dot com>

	Fixed the bug that returns incomplete data when it contains null
	character. A convenient constructor was also added.

2007-12-15  Tatsuhiro Tsujikawa  <tujikawa at rednoah dot com>

	Fixed the bug that prevents aria2 from loading cookie file when
	expire
	value is greater than 2^31-1. BUG#1851066

2007-12-14  Tatsuhiro Tsujikawa  <tujikawa at rednoah dot com>

	Fixed possible memory leak when an exception is thrown.

2007-12-10  Tatsuhiro Tsujikawa  <tujikawa at rednoah dot com>

	Fixed the bug: only first announce URL is tried in AnnounceTier,
	in stopped and completed event.

2007-12-09  Tatsuhiro Tsujikawa  <tujikawa at rednoah dot com>

	Removed unnecessary string copy. Updated doc and corrected
	indentation.
This commit is contained in:
bjs 2008-02-18 00:00:18 +00:00
parent 908440fd0f
commit 6b2d528243
9 changed files with 10 additions and 123 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.8 2008/01/18 05:08:39 tnn Exp $
# $NetBSD: Makefile,v 1.9 2008/02/18 00:00:18 bjs Exp $
#
DISTNAME= aria2-0.12.0
PKGREVISION= 1
DISTNAME= aria2-0.12.1+1
PKGNAME= ${DISTNAME:S/+/./}
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=aria2/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,10 +1,12 @@
@comment $NetBSD: PLIST,v 1.3 2007/12/14 12:46:21 bjs Exp $
@comment $NetBSD: PLIST,v 1.4 2008/02/18 00:00:18 bjs Exp $
bin/aria2c
man/man1/aria2c.1
share/locale/ca/LC_MESSAGES/aria2c.mo
share/locale/de/LC_MESSAGES/aria2c.mo
share/locale/es/LC_MESSAGES/aria2c.mo
share/locale/fi/LC_MESSAGES/aria2c.mo
share/locale/fr/LC_MESSAGES/aria2c.mo
share/locale/he/LC_MESSAGES/aria2c.mo
share/locale/it/LC_MESSAGES/aria2c.mo
share/locale/ja/LC_MESSAGES/aria2c.mo
share/locale/nl/LC_MESSAGES/aria2c.mo

View file

@ -1,11 +1,5 @@
$NetBSD: distinfo,v 1.6 2007/12/14 12:46:22 bjs Exp $
$NetBSD: distinfo,v 1.7 2008/02/18 00:00:18 bjs Exp $
SHA1 (aria2-0.12.0.tar.bz2) = 138380000be0e5df2e3ee4cbb39c0f872cdb195b
RMD160 (aria2-0.12.0.tar.bz2) = 4dc96ca15836a6da640940fbb3ad4f8e1c067fa3
Size (aria2-0.12.0.tar.bz2) = 627019 bytes
SHA1 (patch-aa) = 6d99c0a8a089bb827cdbb72e3df159d826b29db5
SHA1 (patch-ab) = 306c87e3ad274ed020689796c30dc0925631f371
SHA1 (patch-ac) = 83360f9d2d17ac2898a4aa2a07213afea13a5f4c
SHA1 (patch-ad) = e0d91e27a16674d5ab8c1d37e3f1cdb6564c6584
SHA1 (patch-ae) = 1395f44ed49c48e7314345469d19a49bc7aaf1ec
SHA1 (patch-af) = b1c120b3d8a284a2fa5b9483a89a6b4a830eb051
SHA1 (aria2-0.12.1+1.tar.bz2) = f8a6acc1f720aaee1d55a46aa99ddd5341d28679
RMD160 (aria2-0.12.1+1.tar.bz2) = 4eeddc52c51461d0c162ec33acfc144962ae6c6a
Size (aria2-0.12.1+1.tar.bz2) = 720951 bytes

View file

@ -1,18 +0,0 @@
$NetBSD: patch-aa,v 1.4 2007/12/14 12:46:22 bjs Exp $
--- src/Exception.h.orig 2007-11-21 11:14:40.000000000 -0500
+++ src/Exception.h
@@ -37,7 +37,13 @@
#include "common.h"
#include <string>
+#if defined(HAVE_NBCOMPAT_H)
+#include <nbcompat/cdefs.h>
+#include <nbcompat/config.h>
+#include <nbcompat/stdio.h>
+#else
#include <stdio.h>
+#endif
#include <stdarg.h>
using namespace std;

View file

@ -1,18 +0,0 @@
$NetBSD: patch-ab,v 1.4 2007/12/14 12:46:22 bjs Exp $
--- src/common.h.orig 2007-08-28 12:36:33.000000000 -0400
+++ src/common.h
@@ -49,7 +49,13 @@
#endif
#endif // __MINGW32__
+#if defined(HAVE_NBCOMPAT_H)
+#include <nbcompat/cdefs.h>
+#include <nbcompat/config.h>
+#include <nbcompat/stdio.h>
+#else
#include <stdio.h>
+#endif
#include <stdint.h>
#include <iostream>
#include <assert.h>

View file

@ -1,18 +0,0 @@
$NetBSD: patch-ac,v 1.4 2007/12/14 12:46:22 bjs Exp $
--- src/getaddrinfo.c.orig 2007-08-28 12:36:33.000000000 -0400
+++ src/getaddrinfo.c
@@ -99,7 +99,13 @@
#endif
#include <sys/types.h>
+#if defined(HAVE_NBCOMPAT_H)
+#include <nbcompat/cdefs.h>
+#include <nbcompat/config.h>
+#include <nbcompat/stdio.h>
+#else
#include <stdio.h>
+#endif
#if defined(STDC_HEADERS) || defined(HAVE_STRING_H)
#include <string.h>

View file

@ -1,19 +0,0 @@
$NetBSD: patch-ad,v 1.4 2007/12/14 12:46:22 bjs Exp $
--- src/libgen.c.orig 2007-08-28 12:36:33.000000000 -0400
+++ src/libgen.c
@@ -33,7 +33,14 @@
*/
/* copyright --> */
+#if defined(HAVE_NBCOMPAT_H)
+#include <nbcompat/cdefs.h>
+#include <nbcompat/config.h>
+#include <nbcompat/stdio.h>
+#else
#include <stdio.h>
+#endif
+
#include <string.h>
#include <libgen.h>

View file

@ -1,18 +0,0 @@
$NetBSD: patch-ae,v 1.4 2007/12/14 12:46:23 bjs Exp $
--- src/main.cc.orig 2007-12-04 06:12:56.000000000 -0500
+++ src/main.cc
@@ -69,7 +69,13 @@
#include <fstream>
extern char* optarg;
extern int optind, opterr, optopt;
+#if defined(HAVE_NBCOMPAT_H)
+#include <nbcompat/cdefs.h>
+#include <nbcompat/config.h>
+#include <nbcompat/getopt.h>
+#else
#include <getopt.h>
+#endif
#ifdef ENABLE_METALINK
# include "Metalink2RequestGroup.h"

View file

@ -1,18 +0,0 @@
$NetBSD: patch-af,v 1.4 2007/12/14 12:46:23 bjs Exp $
--- src/strptime.c.orig 2007-08-28 12:36:33.000000000 -0400
+++ src/strptime.c
@@ -43,7 +43,13 @@
#endif // HAVE_TIMEGM
#include <stddef.h>
+#if defined(HAVE_NBCOMPAT_H)
+#include <nbcompat/cdefs.h>
+#include <nbcompat/config.h>
+#include <nbcompat/stdio.h>
+#else
#include <stdio.h>
+#endif
#include <time.h>
#include <string.h>
#include <ctype.h>