php72: Do not autodetect (and get wrong) maintainer-zts.

This resulted in a mod_php that cannot be loaded, as reported in
joyent/pkgsrc#152.  Patch copied from php71.  Bump PKGREVISION.
This commit is contained in:
jperkin 2019-03-11 13:43:22 +00:00
parent 33167ac33b
commit 6b44c68f69
3 changed files with 37 additions and 8 deletions

View file

@ -1,9 +1,10 @@
# $NetBSD: Makefile,v 1.16 2019/01/12 14:59:03 taca Exp $
# $NetBSD: Makefile,v 1.17 2019/03/11 13:43:22 jperkin Exp $
#
# We can't omit PKGNAME here to handle PKG_OPTIONS.
#
PKGNAME= php-${PHP_VERSION:S/RC/rc/}
PKGREVISION= 1
HOMEPAGE= http://www.php.net/
COMMENT= PHP Hypertext Preprocessor version 7.2

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.36 2019/02/07 14:05:05 taca Exp $
$NetBSD: distinfo,v 1.37 2019/03/11 13:43:22 jperkin Exp $
SHA1 (php-7.2.15.tar.bz2) = 5aa59dffc0dc38590bbc835ab168723b8cc540e3
RMD160 (php-7.2.15.tar.bz2) = 6a48ace560fc51f05177acaa5e4d509c37c40bd3
SHA512 (php-7.2.15.tar.bz2) = 51713edeb273a808e0584453647c060599645916be19ce62ebf896ef2c24c39b3f15106c3dd6e755cea7147405bf68c9610b97c87409387127d7fd8e772fc8a6
Size (php-7.2.15.tar.bz2) = 15060588 bytes
SHA1 (patch-configure) = 47f2ede97390cc7e46d04c2769dd97459b19450a
SHA1 (patch-configure) = 6e66a79e691a84aa7ae461f8dec1752443ad6b61
SHA1 (patch-disable-filter-url) = e9e92d686ddd1d1a1ece10fe4feee4e368fe510c
SHA1 (patch-ext_gd_config.m4) = eaecfb31b18700dd642c067ed82748d4f6be2335
SHA1 (patch-ext_phar_Makefile.frag) = 558869b60f8ed6674a3ba1d595a65f010df4c426

View file

@ -1,12 +1,12 @@
$NetBSD: patch-configure,v 1.10 2018/02/09 00:01:13 jdolecek Exp $
$NetBSD: patch-configure,v 1.11 2019/03/11 13:43:22 jperkin Exp $
Don't automatically add libgcc on SunOS. Reported upstream as #75941.
Don't autodetect maintainer-zts.
The meta_ccld removal reported upstream as #75940.
--- configure.orig 2018-01-30 10:33:52.000000000 +0000
--- configure.orig 2019-02-05 15:43:47.000000000 +0000
+++ configure
@@ -5461,9 +5461,6 @@ fi
@@ -5463,9 +5463,6 @@ fi
case $host_alias in
*solaris*)
CPPFLAGS="$CPPFLAGS -D_POSIX_PTHREAD_SEMANTICS"
@ -16,7 +16,35 @@ The meta_ccld removal reported upstream as #75940.
;;
*dgux*)
CPPFLAGS="$CPPFLAGS -D_BSD_TIMEOFDAY_FLAVOR"
@@ -96116,12 +96113,7 @@ old_CC=$CC
@@ -7008,27 +7005,6 @@ EOF
;;
esac
- if test "$APACHE_VERSION" -lt 2004001; then
- APXS_MPM=`$APXS -q MPM_NAME`
- if test "$APXS_MPM" != "prefork" && test "$APXS_MPM" != "peruser" && test "$APXS_MPM" != "itk"; then
-
- enable_maintainer_zts=yes
- if test "$pthreads_working" != "yes"; then
- as_fn_error $? "ZTS currently requires working POSIX threads. We were unable to verify that your system supports Pthreads." "$LINENO" 5
- fi
-
- fi
- else
- APACHE_THREADED_MPM=`$APXS_HTTPD -V | grep 'threaded:.*yes'`
- if test -n "$APACHE_THREADED_MPM"; then
-
- enable_maintainer_zts=yes
- if test "$pthreads_working" != "yes"; then
- as_fn_error $? "ZTS currently requires working POSIX threads. We were unable to verify that your system supports Pthreads." "$LINENO" 5
- fi
-
- fi
- fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "yes" >&6; }
@@ -97130,12 +97106,7 @@ old_CC=$CC
if test "$PHP_THREAD_SAFETY" = "yes" && test -n "$ac_cv_pthreads_cflags"; then
CXXFLAGS="$CXXFLAGS $ac_cv_pthreads_cflags"
INLINE_CFLAGS="$INLINE_CFLAGS $ac_cv_pthreads_cflags"