Update to 3.1.2

Changelog:
NEWS for rsync 3.1.2 (21 Dec 2015)
Protocol: 31 (unchanged)
Changes since 3.1.1:

  SECURITY FIXES:

    - Make sure that all transferred files use only path names from inside the
      transfer.  This makes it impossible for a malicious sender to try to make
      the receiver use an unsafe destination path for a transferred file, such
      as a just-sent symlink.

  BUG FIXES:

    - Change the checksum seed order in the per-block checksums.  This prevents
      someone from trying to create checksum blocks that match in sum but not
      content.
    - Fixed a with the per-dir filter files (using -FF) that could trigger an
      assert failure.
    - Only skip set_modtime() on a transferred file if the time is exactly
      right.
    - Don't create an empty backup dir for a transferred file that doesn't
      exist yet.
    - Fixed a bug where --link-dest and --xattrs could cause rsync to exit if
      a filename had a matching dir of the same name in the alt-dest area.
    - Allow more than 32 group IDs per user in the daemon's gid=LIST config.
    - Fix the logging of %b & %c via --log-file (daemon logging was already
      correct, as was --out-format='%b/%c').
    - Fix erroneous acceptance of --info=5 & --debug=5 (an empty flag name is
      not valid).

  ENHANCEMENTS:

    - Added "(DRY RUN)" info to the --debug=exit output line.
    - Use usleep() for our msleep() function if it is available.
    - Added a few extra long-option names to rrsync script, which will make
      BackupPC happier.
    - Made configure choose to use linux xattrs on netbsd (rather than not
      supporting xattrs).
    - Added -wo (write-only) option to rrsync support script.
    - Misc. manpage tweaks.

  DEVELOPER RELATED:

    - Fixed a bug with the Makefile's use of INSTALL_STRIP.
    - Improve a test in the suite that could get an erroneous timestamp error.
    - Tweaks for newer versions of git in the packaging tools.
    - Improved the m4 generation rules and some autoconf idioms.
This commit is contained in:
ryoon 2015-12-23 19:53:24 +00:00
parent f0ff909b6a
commit 6b6ce10920
5 changed files with 7 additions and 78 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.102 2015/11/13 13:41:39 wiz Exp $
# $NetBSD: Makefile,v 1.103 2015/12/23 19:53:24 ryoon Exp $
DISTNAME= rsync-3.1.1
PKGREVISION= 2
DISTNAME= rsync-3.1.2
CATEGORIES= net
MASTER_SITES= http://rsync.samba.org/ftp/rsync/ \
http://rsync.samba.org/ftp/rsync/old-versions/ \

View file

@ -1,11 +1,8 @@
$NetBSD: distinfo,v 1.43 2015/11/13 13:41:39 wiz Exp $
$NetBSD: distinfo,v 1.44 2015/12/23 19:53:24 ryoon Exp $
SHA1 (rsync-3.1.1.tar.gz) = c84faba04f721d393feccfa0476bfeed9b5b5250
RMD160 (rsync-3.1.1.tar.gz) = de7ad955cb05d481a963aa30423790f3d82efe7b
SHA512 (rsync-3.1.1.tar.gz) = ec0e46ff532a09a711282aaa822f5f1c133593ee6c1c474acd67284619236e6a202f0f369d3e67a95ceb3a3b1c39ea7fb609d6d6fb950f3be6e0f6372e903e21
Size (rsync-3.1.1.tar.gz) = 890124 bytes
SHA1 (rsync-3.1.2.tar.gz) = 0d4c7fb7fe3fc80eeff922a7c1d81df11dbb8a1a
RMD160 (rsync-3.1.2.tar.gz) = f7d6c0c9752af8d9eb933cffc6032c1763490a04
SHA512 (rsync-3.1.2.tar.gz) = 4c55fd69f436ead0cb5a0b7c6fdfef9bb28ddb9c63534eb619e756b118d5b08cfc5e696498650932c86e865b37e06633da947e6720ca0c27ed5c034313ae208b
Size (rsync-3.1.2.tar.gz) = 892724 bytes
SHA1 (patch-Makefile.in) = df3479e93de86524a391433a3d6e6108a797835a
SHA1 (patch-ab) = 98aa07a50314e3309b48f803d6febb1138eae1f2
SHA1 (patch-config.h.in) = 81c927bc687a0194e1a227e6ff02181d638498bd
SHA1 (patch-configure.ac) = 1df4fd9a67d08790eb7d433eadbc9b5590ba1257
SHA1 (patch-configure.sh) = 49d8ddea4669d14ba77625d33255df0072f5c3e4

View file

@ -1,17 +0,0 @@
$NetBSD: patch-config.h.in,v 1.1 2015/09/14 14:00:01 manu Exp $
NetBSD extended attribute support, from upstream
--- config.h.in.orig 2015-09-03 03:45:23.000000000 +0200
+++ config.h.in 2015-09-03 03:45:36.000000000 +0200
@@ -236,9 +236,9 @@
/* Define to 1 if you have the <linux/falloc.h> header file. */
#undef HAVE_LINUX_FALLOC_H
-/* True if you have Linux xattrs */
+/* True if you have Linux xattrs (or equivalent) */
#undef HAVE_LINUX_XATTRS
/* Define to 1 if you have the `locale_charset' function. */
#undef HAVE_LOCALE_CHARSET

View file

@ -1,33 +0,0 @@
$NetBSD: patch-configure.ac,v 1.1 2015/09/14 14:00:01 manu Exp $
NetBSD extended attribute support, from upstream
From 1983198097f57cb9c2eb44ae51cbf8c2cabccbe4 Mon Sep 17 00:00:00 2001
From: Wayne Davison <wayned@samba.org>
Date: Wed, 2 Sep 2015 12:20:50 -0700
Subject: [PATCH] Add support for netbsd in xattrs case. Closes bug-suggestion
11484.
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git configure.ac configure.ac
index 3aca2a1..0478ba8 100644
--- configure.ac
+++ configure.ac
@@ -1022,9 +1022,9 @@ if test x"$enable_xattr_support" = x"no"; then
AC_MSG_RESULT(no)
else
case "$host_os" in
- *linux*)
+ *linux*|*netbsd*)
AC_MSG_RESULT(Using Linux xattrs)
- AC_DEFINE(HAVE_LINUX_XATTRS, 1, [True if you have Linux xattrs])
+ AC_DEFINE(HAVE_LINUX_XATTRS, 1, [True if you have Linux xattrs (or equivalent)])
AC_DEFINE(SUPPORT_XATTRS, 1)
AC_DEFINE(NO_SYMLINK_USER_XATTRS, 1, [True if symlinks do not support user xattrs])
AC_CHECK_LIB(attr,getxattr)
--
2.3.2

View file

@ -1,17 +0,0 @@
$NetBSD: patch-configure.sh,v 1.1 2015/09/14 14:00:01 manu Exp $
NetBSD extended attribute support, from upstream
--- configure.sh.orig 2015-09-03 03:42:33.000000000 +0200
+++ configure.sh 2015-09-03 03:44:27.000000000 +0200
@@ -8867,9 +8867,9 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
$as_echo "no" >&6; }
else
case "$host_os" in
- *linux*)
+ *linux*|*netbsd*)
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: Using Linux xattrs" >&5
$as_echo "Using Linux xattrs" >&6; }
$as_echo "#define HAVE_LINUX_XATTRS 1" >>confdefs.h