Make sure ${PREFIX}/share/emacs/site-lisp directory exists or gets created.
Fixes problem in latest pkgsrc/i386 bulk build.
This commit is contained in:
parent
9b558e5497
commit
6b6f704a49
5 changed files with 26 additions and 18 deletions
|
@ -1,11 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2000/11/02 21:51:58 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2000/12/08 21:22:14 jtb Exp $
|
||||
#
|
||||
|
||||
DISTNAME= esh-0.8
|
||||
CATEGORIES= shells
|
||||
MASTER_SITES= http://esh.netpedia.net/
|
||||
|
||||
MAINTAINER= jasontd@indigo.ie
|
||||
MAINTAINER= jtb@netbsd.org
|
||||
HOMEPAGE= http://esh.netpedia.net
|
||||
|
||||
WRKSRC= ${WRKDIR}/esh
|
||||
|
@ -14,16 +14,14 @@ INFO_FILES= esh.info
|
|||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/esh ${PREFIX}/bin
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/esh
|
||||
@(cd ${WRKSRC}/examples ; \
|
||||
for i in *.esh ; do \
|
||||
${CP} $$i ${PREFIX}/share/examples/esh; \
|
||||
done)
|
||||
${INSTALL_DATA} ${WRKSRC}/emacs/esh-mode.el \
|
||||
${PREFIX}/share/emacs/site-lisp
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/*.esh ${PREFIX}/share/examples/esh
|
||||
.if !exists(${PREFIX}/share/emacs/site-lisp)
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/emacs/site-lisp
|
||||
.endif
|
||||
${INSTALL_DATA} ${WRKSRC}/emacs/esh-mode.el ${PREFIX}/share/emacs/site-lisp
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/esh.info ${PREFIX}/info
|
||||
${MKDIR} ${PREFIX}/share/doc/esh
|
||||
@(for i in esh.html esh_toc.html; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/$$i ${PREFIX}/share/doc/esh/$$i; \
|
||||
done)
|
||||
@for i in esh.html esh_toc.html ; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/$$i ${PREFIX}/share/doc/esh/$$i; done
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2000/11/02 21:51:58 tron Exp $
|
||||
$NetBSD: md5,v 1.2 2000/12/08 21:22:14 jtb Exp $
|
||||
|
||||
MD5 (esh-0.8.tar.gz) = b59022b88bae24420156d25869b8be54
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2000/11/02 21:51:58 tron Exp $
|
||||
$NetBSD: patch-sum,v 1.2 2000/12/08 21:22:14 jtb Exp $
|
||||
|
||||
MD5 (patch-aa) = 5046da6cb1ecdcc02250deffb748851c
|
||||
MD5 (patch-aa) = f6c65a638c2366d54bd5755ae27dd64a
|
||||
|
|
|
@ -1,8 +1,15 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2000/11/02 21:51:58 tron Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2000/12/08 21:22:14 jtb Exp $
|
||||
|
||||
--- Makefile.orig Thu Apr 22 09:31:43 1999
|
||||
--- Makefile.orig Thu Apr 22 08:31:43 1999
|
||||
+++ Makefile
|
||||
@@ -7,11 +7,11 @@
|
||||
@@ -1,17 +1,17 @@
|
||||
|
||||
# Your C compiler.
|
||||
|
||||
-CC=gcc
|
||||
+#CC=gcc
|
||||
|
||||
# Where your readline library is.
|
||||
# You can compile with a hacked replacement of readline instead by
|
||||
# doing this:
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2000/11/02 21:51:58 tron Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2000/12/08 21:22:14 jtb Exp $
|
||||
bin/esh
|
||||
@unexec install-info --delete --info-dir=%D/info %D/info/esh.info
|
||||
info/esh.info
|
||||
|
@ -18,5 +18,8 @@ share/examples/esh/test4.esh
|
|||
share/examples/esh/test5.esh
|
||||
share/examples/esh/test6.esh
|
||||
share/examples/esh/test7.esh
|
||||
@unexec rmdir %D/share/emacs/site-lisp 2>/dev/null || true
|
||||
@unexec rmdir %D/share/emacs 2>/dev/null || true
|
||||
@unexec rmdir %D/share 2>/dev/null || true
|
||||
@dirrm share/examples/esh
|
||||
@dirrm share/doc/esh
|
||||
|
|
Loading…
Reference in a new issue