Pass down --mode=XXX for libtool. Mark as destdir ready.
This commit is contained in:
parent
057a84379b
commit
6b8185f235
4 changed files with 131 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.2 2009/07/17 18:00:24 adrianp Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2009/09/09 17:32:29 joerg Exp $
|
||||
#
|
||||
|
||||
DISTNAME= openvas-libraries-2.0.0
|
||||
|
@ -9,6 +9,8 @@ MAINTAINER= pkgsrc-users@NetBSD.org
|
|||
HOMEPAGE= http://www.openvas.org/
|
||||
COMMENT= Libraries for the Open Vulnerability Assessment System
|
||||
|
||||
PKG_DESTDIR_SUPPORT=user-destdir
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_LIBTOOL= YES
|
||||
MAKE_JOBS_SAFE= NO
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/01/04 01:08:52 adrianp Exp $
|
||||
$NetBSD: distinfo,v 1.2 2009/09/09 17:32:29 joerg Exp $
|
||||
|
||||
SHA1 (openvas-libraries-2.0.0.tar.gz) = e3b5614e8fa4721ad93a9eb483f4f0a23242d84b
|
||||
RMD160 (openvas-libraries-2.0.0.tar.gz) = c7365d81289bca625ae984fceab901ced0626ce0
|
||||
|
@ -9,3 +9,5 @@ SHA1 (patch-ac) = 50e33c8d9571e8c67052f3e0462d5ccd1f60eb0e
|
|||
SHA1 (patch-ad) = 9a66d6ffad12edbc09176b390325065011abafa3
|
||||
SHA1 (patch-ae) = e2d36036d2043fb0a4ad1ada281ec165ed9c08ea
|
||||
SHA1 (patch-af) = edbabcc8b5f3a3a654f52ab678c932471f2fb1a7
|
||||
SHA1 (patch-ag) = 16d1e43ec3f098b86019e54e189a4b66a87d8b64
|
||||
SHA1 (patch-ah) = 097d76cced6ef5f5b909e1b9ab9fb9e0815b876a
|
||||
|
|
105
security/openvas-libraries/patches/patch-ag
Normal file
105
security/openvas-libraries/patches/patch-ag
Normal file
|
@ -0,0 +1,105 @@
|
|||
$NetBSD: patch-ag,v 1.1 2009/09/09 17:32:29 joerg Exp $
|
||||
|
||||
--- libopenvas/Makefile.orig 2009-09-09 19:26:52.000000000 +0200
|
||||
+++ libopenvas/Makefile
|
||||
@@ -50,77 +50,77 @@ all : libopenvas.la
|
||||
plugutils.o: plugutils.c arglists.h comm.h harglists.h kb.h network.h \
|
||||
rand.h plugutils.h services.h share_fd.h store_internal.h system.h \
|
||||
scanners_utils.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c plugutils.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c plugutils.c
|
||||
|
||||
resolve.o : resolve.c resolve.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c resolve.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c resolve.c
|
||||
|
||||
share_fd.o : share_fd.c
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c share_fd.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c share_fd.c
|
||||
|
||||
system.o : system.c system_internal.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c system.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c system.c
|
||||
|
||||
arglists.o: arglists.c arglists.h system_internal.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c arglists.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c arglists.c
|
||||
|
||||
network.o: network.c resolve.h ids_send.h plugutils.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c network.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c network.c
|
||||
|
||||
scanners_utils.o: scanners_utils.c comm.h network.h services.h plugutils.h system.h scanners_utils.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c scanners_utils.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c scanners_utils.c
|
||||
|
||||
ftp_funcs.o: ftp_funcs.c network.h ftp_funcs.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ftp_funcs.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ftp_funcs.c
|
||||
|
||||
www_funcs.o: www_funcs.c kb.h plugutils.h system.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c www_funcs.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c www_funcs.c
|
||||
|
||||
pcap.o: pcap.c bpf_share.h pcap_openvas.h system_internal.h network.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c pcap.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c pcap.c
|
||||
|
||||
hlst.o: hlst.c hlst.h system.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c hlst.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c hlst.c
|
||||
|
||||
harglists.o: harglists.c hlst.h system_internal.h harglists.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c harglists.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c harglists.c
|
||||
|
||||
ids_send.o: ids_send.c arglists.h bpf_share.h resolve.h ids_send.h network.h \
|
||||
pcap_openvas.h plugutils.h system.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ids_send.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ids_send.c
|
||||
|
||||
bpf_share.o: bpf_share.c
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c bpf_share.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c bpf_share.c
|
||||
|
||||
rand.o: rand.c
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c rand.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c rand.c
|
||||
|
||||
popen.o: popen.c system.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c popen.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c popen.c
|
||||
|
||||
services.o: services.c services.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c services.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c services.c
|
||||
|
||||
services1.o: services1.c services.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -DCONF_DIR=\"$(sysconfdir)\" -c services1.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -DCONF_DIR=\"$(sysconfdir)\" -c services1.c
|
||||
|
||||
proctitle.o: proctitle.c proctitle.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c proctitle.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c proctitle.c
|
||||
|
||||
store.o: store.c store_internal.h share_fd.h system.h plugutils.h plugutils_internal.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c store.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c store.c
|
||||
|
||||
kb.o: kb.c arglists.h kb.h system_internal.h
|
||||
- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c kb.c
|
||||
+ $(LIBTOOL) --mode=compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c kb.c
|
||||
|
||||
|
||||
libopenvas.la: $(OBJS)
|
||||
- $(LIBTOOL) $(CC) $(LIBS) -o libopenvas.la $(LO_OBJS) -rpath ${libdir} \
|
||||
+ $(LIBTOOL) --mode=link $(CC) $(LIBS) -o libopenvas.la $(LO_OBJS) -rpath ${libdir} \
|
||||
-version-info ${PACKAGE_VERSION}
|
||||
|
||||
install : libopenvas.la
|
||||
test -d $(DESTDIR)${libdir} || $(INSTALL_DIR) -m 755 $(DESTDIR)${libdir}
|
||||
- $(LIBTOOL) --mode install $(INSTALL) libopenvas.la $(DESTDIR)${libdir}/libopenvas.la
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL) libopenvas.la $(DESTDIR)${libdir}/libopenvas.la
|
||||
$(LIBTOOL) --finish $(DESTDIR)${libdir}
|
||||
|
||||
distclean : clean
|
20
security/openvas-libraries/patches/patch-ah
Normal file
20
security/openvas-libraries/patches/patch-ah
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-ah,v 1.1 2009/09/09 17:32:29 joerg Exp $
|
||||
|
||||
--- libopenvas_hg/Makefile.orig 2009-09-09 19:28:21.000000000 +0200
|
||||
+++ libopenvas_hg/Makefile
|
||||
@@ -41,13 +41,13 @@ test : libopenvas_hg.la test.c
|
||||
|
||||
install : libopenvas_hg.la
|
||||
test -d $(DESTDIR)${libdir} || $(INSTALL_DIR) -m 755 $(DESTDIR)${libdir}
|
||||
- $(LIBTOOL) --mode install $(INSTALL) libopenvas_hg.la $(DESTDIR)${libdir}
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL) libopenvas_hg.la $(DESTDIR)${libdir}
|
||||
$(LIBTOOL) --finish $(DESTDIR)${libdir}
|
||||
$(INSTALL) -m 0644 hosts_gatherer.h $(DESTDIR)${includedir}/openvas
|
||||
$(INSTALL) -m 0644 hg_utils.h $(DESTDIR)${includedir}/openvas
|
||||
|
||||
libopenvas_hg.la : $(OBJS)
|
||||
- $(LIBTOOL) $(CC) $(LIBS) -o libopenvas_hg.la $(LO_OBJS) -rpath ${libdir} \
|
||||
+ $(LIBTOOL) --mode=link $(CC) $(LIBS) -o libopenvas_hg.la $(LO_OBJS) -rpath ${libdir} \
|
||||
-version-info ${PACKAGE_VERSION}
|
||||
|
||||
hg_utils.o : hg_utils.h hosts_gatherer.h hg_utils.c
|
Loading…
Reference in a new issue