Changes 1.4.8:

* rrd_graph now uses a map to lookup variable names causing graphs with many
  items to be drawn magnitudes faster as the linear search of the variable
  tables is gone now.
* the optional argument :skipscale allows for a LINE or AREA instruction to be
  excluded from having an effect on the scaling of the graph
* TRENDNAN is now working properly and als not crashing anymore
* Added a no-op string positioning combo "\." this allows to write
  COMMENT:OS\2\. which would otherwise not be possible.
* JSON output of xport is now actually json compilant by its keys
  being properly quoted now.
* The label positioner in rrd_graph is now properly ignoring the current
  state of DST.
* fixes and enhancements for Python, Ruby, TCL and Perl bindings
* improved error reporting in rrd_graph
* portability and cross compilation
This commit is contained in:
adam 2014-08-24 07:06:02 +00:00
parent fa214973e7
commit 6baf7cf6d1
4 changed files with 9 additions and 22 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.111 2014/05/29 23:35:33 wiz Exp $
# $NetBSD: Makefile,v 1.112 2014/08/24 07:06:02 adam Exp $
DISTNAME= rrdtool-1.4.7
PKGREVISION= 17
DISTNAME= rrdtool-1.4.8
CATEGORIES= databases graphics net
MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/

View file

@ -1,6 +1,8 @@
@comment $NetBSD: PLIST,v 1.13 2010/07/06 07:31:20 adam Exp $
@comment $NetBSD: PLIST,v 1.14 2014/08/24 07:06:02 adam Exp $
bin/rrdcached
bin/rrdcgi
bin/rrdcreate
bin/rrdinfo
bin/rrdtool
bin/rrdupdate
include/rrd.h

View file

@ -1,11 +1,10 @@
$NetBSD: distinfo,v 1.44 2013/10/20 18:18:52 joerg Exp $
$NetBSD: distinfo,v 1.45 2014/08/24 07:06:02 adam Exp $
SHA1 (rrdtool-1.4.7.tar.gz) = faab7df7696b69f85d6f89dd9708d7cf0c9a273b
RMD160 (rrdtool-1.4.7.tar.gz) = 3a8c1c0f3fe0d76fb7da8b712cdd19d59d5171ba
Size (rrdtool-1.4.7.tar.gz) = 1349040 bytes
SHA1 (rrdtool-1.4.8.tar.gz) = 56d68857f39e70bfa32360947614d8220702ed02
RMD160 (rrdtool-1.4.8.tar.gz) = c02412211e6e51f3c77182c08f5cdfa3426765d1
Size (rrdtool-1.4.8.tar.gz) = 1379482 bytes
SHA1 (patch-aa) = 317fc6e46e15333574d0e977d8ab34e916920f4a
SHA1 (patch-ab) = 81131a74c8e9b81edfaa4b6746d4ab8508e82ac2
SHA1 (patch-al) = abc25497a10d59b1ad2e3a263f818eef89985538
SHA1 (patch-am) = 6c0a0890b1e8e2c1a186e2015c0cf5acd719b686
SHA1 (patch-az) = 41e7f6aad5a54a0fa27744709af404b887b88602
SHA1 (patch-bindings_perl-shared_Makefile.PL) = d767dca08217a909132646216679a5d1fad4b77c

View file

@ -1,13 +0,0 @@
$NetBSD: patch-az,v 1.3 2011/01/05 18:12:39 kefren Exp $
--- src/rrd_daemon.c.orig 2010-12-21 18:06:32.000000000 +0200
+++ src/rrd_daemon.c 2011-01-05 18:10:33.000000000 +0200
@@ -113,7 +113,7 @@
#include <tcpd.h>
#endif /* HAVE_LIBWRAP */
-#include <glib-2.0/glib.h>
+#include <glib.h>
/* }}} */
#define RRDD_LOG(severity, ...) \