Changes 3.2.3:
* Longstanding bug in form_urldecode fixed * Bug in FastCGI demo fixed * Documentation formatting problems fixed * Demonstration applications updated Changes 3.2.2: * Memory leak during restoration of CGI environments fixed * New getDoubleValue and getIntegerValue methods added to allow caller to determine if value was bounded * Bug in getDoubleValue fixed * Bug in parsing of cookie names fixed Changes 3.2.1: * Bug that caused multiple cookies to be output incorrectly fixed * Better support added for Borland C++ Builder and HP aCC * Bona fide support for FastCGI added * Documentation fixes Changes 3.2: * License changed to the Lesser GNU General Public License * HTTP header classes rewritten and refactored * HTML output now more XML-compliant * Documentation rewritten in Doxygen format * Added a demo on cookie usage
This commit is contained in:
parent
aecb99dc1c
commit
6bbcabe235
4 changed files with 202 additions and 20 deletions
|
@ -1,22 +1,19 @@
|
|||
# $NetBSD: Makefile,v 1.11 2006/02/05 23:11:20 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2006/03/05 22:34:33 adam Exp $
|
||||
|
||||
DISTNAME= cgicc-3.1.5
|
||||
PKGREVISION= 2
|
||||
DISTNAME= cgicc-3.2.3
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=cgicc/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= shell@shellhung.org
|
||||
HOMEPAGE= http://www.gnu.org/software/cgicc/cgicc.html
|
||||
COMMENT= C++ compliant CGI applications libraries
|
||||
|
||||
USE_TOOLS+= gmake
|
||||
USE_LANGUAGES= c++
|
||||
USE_LIBTOOL= YES
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
INFO_FILES= cgicc.info
|
||||
|
||||
LTCONFIG_OVERRIDE= ${WRKSRC}/support/ltconfig ${WRKSRC}/example/ltconfig
|
||||
USE_LANGUAGES= c++
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --disable-demos
|
||||
|
||||
.include "../../mk/compiler.mk"
|
||||
|
||||
|
|
181
www/cgicc/PLIST
181
www/cgicc/PLIST
|
@ -1,16 +1,187 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2004/09/22 08:09:56 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2006/03/05 22:34:33 adam Exp $
|
||||
bin/cgicc-config
|
||||
include/cgicc/CgiDefs.h
|
||||
include/cgicc/CgiEnvironment.h
|
||||
include/cgicc/CgiInput.h
|
||||
include/cgicc/CgiUtils.h
|
||||
include/cgicc/Cgicc.h
|
||||
include/cgicc/FormEntry.h
|
||||
include/cgicc/FormFile.h
|
||||
include/cgicc/HTMLAttributes.h
|
||||
include/cgicc/HTMLAtomicElement.h
|
||||
include/cgicc/HTMLAttribute.h
|
||||
include/cgicc/HTMLAttributeList.h
|
||||
include/cgicc/HTMLBooleanElement.h
|
||||
include/cgicc/HTMLClasses.h
|
||||
include/cgicc/HTMLElements.h
|
||||
include/cgicc/HTMLGeneric.h
|
||||
include/cgicc/HTTPHeaders.h
|
||||
include/cgicc/HTMLDoctype.h
|
||||
include/cgicc/HTMLElement.h
|
||||
include/cgicc/HTMLElementList.h
|
||||
include/cgicc/HTTPContentHeader.h
|
||||
include/cgicc/HTTPCookie.h
|
||||
include/cgicc/HTTPHTMLHeader.h
|
||||
include/cgicc/HTTPHeader.h
|
||||
include/cgicc/HTTPPlainHeader.h
|
||||
include/cgicc/HTTPRedirectHeader.h
|
||||
include/cgicc/HTTPResponseHeader.h
|
||||
include/cgicc/HTTPStatusHeader.h
|
||||
include/cgicc/MStreamable.h
|
||||
lib/libcgicc.la
|
||||
share/doc/cgicc/COPYING-source.html
|
||||
share/doc/cgicc/COPYING_8DOC-source.html
|
||||
share/doc/cgicc/COPYING_8LIB-source.html
|
||||
share/doc/cgicc/CgiDefs_8h-source.html
|
||||
share/doc/cgicc/CgiDefs_8h.html
|
||||
share/doc/cgicc/CgiEnvironment_8h-source.html
|
||||
share/doc/cgicc/CgiEnvironment_8h.html
|
||||
share/doc/cgicc/CgiInput_8h-source.html
|
||||
share/doc/cgicc/CgiInput_8h.html
|
||||
share/doc/cgicc/CgiUtils_8h-source.html
|
||||
share/doc/cgicc/CgiUtils_8h.html
|
||||
share/doc/cgicc/Cgicc_8h-source.html
|
||||
share/doc/cgicc/Cgicc_8h.html
|
||||
share/doc/cgicc/FormEntry_8h-source.html
|
||||
share/doc/cgicc/FormEntry_8h.html
|
||||
share/doc/cgicc/FormFile_8h-source.html
|
||||
share/doc/cgicc/FormFile_8h.html
|
||||
share/doc/cgicc/HTMLAtomicElement_8h-source.html
|
||||
share/doc/cgicc/HTMLAtomicElement_8h.html
|
||||
share/doc/cgicc/HTMLAttributeList_8h-source.html
|
||||
share/doc/cgicc/HTMLAttributeList_8h.html
|
||||
share/doc/cgicc/HTMLAttribute_8h-source.html
|
||||
share/doc/cgicc/HTMLAttribute_8h.html
|
||||
share/doc/cgicc/HTMLBooleanElement_8h-source.html
|
||||
share/doc/cgicc/HTMLBooleanElement_8h.html
|
||||
share/doc/cgicc/HTMLClasses_8h-source.html
|
||||
share/doc/cgicc/HTMLClasses_8h.html
|
||||
share/doc/cgicc/HTMLDoctype_8h-source.html
|
||||
share/doc/cgicc/HTMLDoctype_8h.html
|
||||
share/doc/cgicc/HTMLElementList_8h-source.html
|
||||
share/doc/cgicc/HTMLElementList_8h.html
|
||||
share/doc/cgicc/HTMLElement_8h-source.html
|
||||
share/doc/cgicc/HTMLElement_8h.html
|
||||
share/doc/cgicc/HTTPContentHeader_8h-source.html
|
||||
share/doc/cgicc/HTTPContentHeader_8h.html
|
||||
share/doc/cgicc/HTTPCookie_8h-source.html
|
||||
share/doc/cgicc/HTTPCookie_8h.html
|
||||
share/doc/cgicc/HTTPHTMLHeader_8h-source.html
|
||||
share/doc/cgicc/HTTPHTMLHeader_8h.html
|
||||
share/doc/cgicc/HTTPHeader_8h-source.html
|
||||
share/doc/cgicc/HTTPHeader_8h.html
|
||||
share/doc/cgicc/HTTPPlainHeader_8h-source.html
|
||||
share/doc/cgicc/HTTPPlainHeader_8h.html
|
||||
share/doc/cgicc/HTTPRedirectHeader_8h-source.html
|
||||
share/doc/cgicc/HTTPRedirectHeader_8h.html
|
||||
share/doc/cgicc/HTTPResponseHeader_8h-source.html
|
||||
share/doc/cgicc/HTTPResponseHeader_8h.html
|
||||
share/doc/cgicc/HTTPStatusHeader_8h-source.html
|
||||
share/doc/cgicc/HTTPStatusHeader_8h.html
|
||||
share/doc/cgicc/MStreamable_8h-source.html
|
||||
share/doc/cgicc/MStreamable_8h.html
|
||||
share/doc/cgicc/annotated.html
|
||||
share/doc/cgicc/bugs_8tmpl-source.html
|
||||
share/doc/cgicc/cgi-overview_8tmpl-source.html
|
||||
share/doc/cgicc/cgi_overview.html
|
||||
share/doc/cgicc/cgicc-doc.css
|
||||
share/doc/cgicc/cgicc.png
|
||||
share/doc/cgicc/cgicc_bugs.html
|
||||
share/doc/cgicc/cgicc_demos.html
|
||||
share/doc/cgicc/cgicc_license.html
|
||||
share/doc/cgicc/cgicc_lists.html
|
||||
share/doc/cgicc/cgicc_tutorial.html
|
||||
share/doc/cgicc/classcgicc_1_1CgiEnvironment-members.html
|
||||
share/doc/cgicc/classcgicc_1_1CgiEnvironment.html
|
||||
share/doc/cgicc/classcgicc_1_1CgiInput-members.html
|
||||
share/doc/cgicc/classcgicc_1_1CgiInput.html
|
||||
share/doc/cgicc/classcgicc_1_1Cgicc-members.html
|
||||
share/doc/cgicc/classcgicc_1_1Cgicc.html
|
||||
share/doc/cgicc/classcgicc_1_1FormEntry-members.html
|
||||
share/doc/cgicc/classcgicc_1_1FormEntry.html
|
||||
share/doc/cgicc/classcgicc_1_1FormFile-members.html
|
||||
share/doc/cgicc/classcgicc_1_1FormFile.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLAtomicElement-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLAtomicElement.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLAtomicElement.png
|
||||
share/doc/cgicc/classcgicc_1_1HTMLAttribute-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLAttribute.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLAttribute.png
|
||||
share/doc/cgicc/classcgicc_1_1HTMLAttributeList-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLAttributeList.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLBooleanElement-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLBooleanElement.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLBooleanElement.png
|
||||
share/doc/cgicc/classcgicc_1_1HTMLDoctype-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLDoctype.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLDoctype.png
|
||||
share/doc/cgicc/classcgicc_1_1HTMLElement-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLElement.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLElement.png
|
||||
share/doc/cgicc/classcgicc_1_1HTMLElementList-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTMLElementList.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPContentHeader-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPContentHeader.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPContentHeader.png
|
||||
share/doc/cgicc/classcgicc_1_1HTTPCookie-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPCookie.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPCookie.png
|
||||
share/doc/cgicc/classcgicc_1_1HTTPHTMLHeader-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPHTMLHeader.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPHTMLHeader.png
|
||||
share/doc/cgicc/classcgicc_1_1HTTPHeader-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPHeader.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPHeader.png
|
||||
share/doc/cgicc/classcgicc_1_1HTTPPlainHeader-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPPlainHeader.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPPlainHeader.png
|
||||
share/doc/cgicc/classcgicc_1_1HTTPRedirectHeader-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPRedirectHeader.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPRedirectHeader.png
|
||||
share/doc/cgicc/classcgicc_1_1HTTPResponseHeader-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPResponseHeader.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPResponseHeader.png
|
||||
share/doc/cgicc/classcgicc_1_1HTTPStatusHeader-members.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPStatusHeader.html
|
||||
share/doc/cgicc/classcgicc_1_1HTTPStatusHeader.png
|
||||
share/doc/cgicc/classcgicc_1_1MStreamable-members.html
|
||||
share/doc/cgicc/classcgicc_1_1MStreamable.html
|
||||
share/doc/cgicc/classcgicc_1_1MStreamable.png
|
||||
share/doc/cgicc/classcgicc_1_1comment-members.html
|
||||
share/doc/cgicc/classcgicc_1_1comment.html
|
||||
share/doc/cgicc/classcgicc_1_1comment.png
|
||||
share/doc/cgicc/config_8h-source.html
|
||||
share/doc/cgicc/cookie_8cpp-source.html
|
||||
share/doc/cgicc/cookie_8cpp.html
|
||||
share/doc/cgicc/demos_8tmpl-source.html
|
||||
share/doc/cgicc/dns_8cpp-source.html
|
||||
share/doc/cgicc/dns_8cpp.html
|
||||
share/doc/cgicc/doxygen.css
|
||||
share/doc/cgicc/doxygen.png
|
||||
share/doc/cgicc/files.html
|
||||
share/doc/cgicc/functions.html
|
||||
share/doc/cgicc/functions_enum.html
|
||||
share/doc/cgicc/functions_eval.html
|
||||
share/doc/cgicc/functions_func.html
|
||||
share/doc/cgicc/functions_rela.html
|
||||
share/doc/cgicc/globals.html
|
||||
share/doc/cgicc/globals_defs.html
|
||||
share/doc/cgicc/hierarchy.html
|
||||
share/doc/cgicc/index.html
|
||||
share/doc/cgicc/index_8tmpl-source.html
|
||||
share/doc/cgicc/lib-overview_8tmpl-source.html
|
||||
share/doc/cgicc/lib_overview.html
|
||||
share/doc/cgicc/license_8tmpl-source.html
|
||||
share/doc/cgicc/license_fdl.html
|
||||
share/doc/cgicc/license_gpl.html
|
||||
share/doc/cgicc/license_lgpl.html
|
||||
share/doc/cgicc/lists_8tmpl-source.html
|
||||
share/doc/cgicc/namespacecgicc.html
|
||||
share/doc/cgicc/namespacemembers.html
|
||||
share/doc/cgicc/namespacemembers_func.html
|
||||
share/doc/cgicc/namespacemembers_type.html
|
||||
share/doc/cgicc/namespaces.html
|
||||
share/doc/cgicc/pages.html
|
||||
share/doc/cgicc/test_8cpp-source.html
|
||||
share/doc/cgicc/test_8cpp.html
|
||||
share/doc/cgicc/tutorial_8tmpl-source.html
|
||||
share/doc/cgicc/upload_8cpp-source.html
|
||||
share/doc/cgicc/upload_8cpp.html
|
||||
@dirrm share/doc/cgicc
|
||||
@dirrm include/cgicc
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2005/02/24 14:08:29 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2006/03/05 22:34:33 adam Exp $
|
||||
|
||||
SHA1 (cgicc-3.1.5.tar.gz) = ee33b6ebf2858cb729bd189e2df8bd8c5fce516e
|
||||
RMD160 (cgicc-3.1.5.tar.gz) = a3c1b8ee22a9dca4750f875d7cefc536fc70870c
|
||||
Size (cgicc-3.1.5.tar.gz) = 328747 bytes
|
||||
SHA1 (cgicc-3.2.3.tar.bz2) = 0d49c933a77d5a917ebf761f416fe1f0140e7664
|
||||
RMD160 (cgicc-3.2.3.tar.bz2) = c1da8be93801344bc4c6338e2547788eb4de217d
|
||||
Size (cgicc-3.2.3.tar.bz2) = 445393 bytes
|
||||
SHA1 (patch-aa) = 614b1cb30bebe5db76bbff5adbd0bd7b248e91da
|
||||
|
|
13
www/cgicc/patches/patch-aa
Normal file
13
www/cgicc/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1 2006/03/05 22:34:33 adam Exp $
|
||||
|
||||
--- doc/Makefile.in.orig 2006-03-05 23:20:52.000000000 +0100
|
||||
+++ doc/Makefile.in
|
||||
@@ -155,7 +155,7 @@ sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
CLEANFILES = *~
|
||||
DOXYFILE = Doxyfile
|
||||
-docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
|
||||
+docdir = $(datadir)/doc/$(PACKAGE)
|
||||
TEMPLATES = index.tmpl license.tmpl lists.tmpl bugs.tmpl demos.tmpl \
|
||||
cgi-overview.tmpl tutorial.tmpl lib-overview.tmpl COPYING COPYING.LIB \
|
||||
COPYING.DOC header.html footer.html cgicc-doc.css
|
Loading…
Reference in a new issue