Import libtomcrypt (version 1.17) into the packages collection.

LibTomCrypt is a fairly comprehensive, modular and portable
	cryptographic toolkit that provides developers with a vast array of
	well known published block ciphers, one-way hash functions, chaining
	modes, pseudo-random number generators, public key cryptography and a
	plethora of other routines.  LibTomCrypt has been designed from the
	ground up to be very simple to use.  It has a modular and standard API
	that allows new ciphers, hashes and PRNGs to be added or removed
	without change to the overall end application.  It features easy to
	use functions and a complete user manual which has many source snippet
	examples.

	* Block Ciphers
	    * Blowfish
	    * XTEA
	    * RC5
	    * RC6
	    * SAFER+
	    * Rijndael (aka AES)
	    * Twofish
	    * SAFER (K64, SK64, K128, SK128)
	    * RC2
	    * DES, 3DES
	    * CAST5
	    * Noekeon
	    * Skipjack
	    * Anubis (with optional tweak as proposed by the developers)
	    * Khazad
	    * KASUMI
	    * SEED
	* Chaining Modes
	    * ECB
	    * CBC
	    * OFB
	    * CFB
	    * CTR
	    * IEEE LRW mode
	    * F8 Chaining Mode
	* One-Way Hash Functions
	    * MD2
	    * MD4
	    * MD5
	    * SHA-1
	    * SHA-224/256/384/512
	    * TIGER-192
	    * RIPE-MD 128/160/256/320
	    * WHIRLPOOL
	* Message Authentication
	    * FIPS-198 HMAC (supports all hashes)
	    * CMAC, also known as OMAC1 (supports all ciphers)
	    * PMAC Authentication
	    * F9-MAC
	    * Pelican MAC
	* Message Encrypt+Authenticate Modes
	    * EAX Mode
	    * OCB Mode
	    * CCM Mode (NIST spec)
	    * GCM Mode (IEEE spec)
	* Pseudo-Random Number Generators
	    * Yarrow (based algorithm)
	    * RC4
	    * Support for /dev/random, /dev/urandom and the Win32 CSP RNG
	    * Fortuna
	    * SOBER-128
	* Public Key Algorithms
	    * RSA (using PKCS #1 v1.5 and v2.1)
	    * ECC (EC-DSA X9.62 signatures, X9.63 EC-DH)
		  o With fast Fixed Point ECC support as well
		  o X9.63 import/export of public keys
	    * DSA (Users make their own groups)
	    * The math routines are pluggable which means you can use your own
	      math provider if you want.
	* Other standards
	    * PKCS #1 (v1.5 and v2.1 padding)
	    * PKCS #5
	    * ASN.1 DER
This commit is contained in:
agc 2010-11-27 06:11:57 +00:00
parent bcd978cdde
commit 6befaa1caf
6 changed files with 180 additions and 0 deletions

View file

@ -0,0 +1,75 @@
LibTomCrypt is a fairly comprehensive, modular and portable
cryptographic toolkit that provides developers with a vast array of
well known published block ciphers, one-way hash functions, chaining
modes, pseudo-random number generators, public key cryptography and a
plethora of other routines. LibTomCrypt has been designed from the
ground up to be very simple to use. It has a modular and standard API
that allows new ciphers, hashes and PRNGs to be added or removed
without change to the overall end application. It features easy to
use functions and a complete user manual which has many source snippet
examples.
* Block Ciphers
* Blowfish
* XTEA
* RC5
* RC6
* SAFER+
* Rijndael (aka AES)
* Twofish
* SAFER (K64, SK64, K128, SK128)
* RC2
* DES, 3DES
* CAST5
* Noekeon
* Skipjack
* Anubis (with optional tweak as proposed by the developers)
* Khazad
* KASUMI
* SEED
* Chaining Modes
* ECB
* CBC
* OFB
* CFB
* CTR
* IEEE LRW mode
* F8 Chaining Mode
* One-Way Hash Functions
* MD2
* MD4
* MD5
* SHA-1
* SHA-224/256/384/512
* TIGER-192
* RIPE-MD 128/160/256/320
* WHIRLPOOL
* Message Authentication
* FIPS-198 HMAC (supports all hashes)
* CMAC, also known as OMAC1 (supports all ciphers)
* PMAC Authentication
* F9-MAC
* Pelican MAC
* Message Encrypt+Authenticate Modes
* EAX Mode
* OCB Mode
* CCM Mode (NIST spec)
* GCM Mode (IEEE spec)
* Pseudo-Random Number Generators
* Yarrow (based algorithm)
* RC4
* Support for /dev/random, /dev/urandom and the Win32 CSP RNG
* Fortuna
* SOBER-128
* Public Key Algorithms
* RSA (using PKCS #1 v1.5 and v2.1)
* ECC (EC-DSA X9.62 signatures, X9.63 EC-DH)
o With fast Fixed Point ECC support as well
o X9.63 import/export of public keys
* DSA (Users make their own groups)
* The math routines are pluggable which means you can use your own
math provider if you want.
* Other standards
* PKCS #1 (v1.5 and v2.1 padding)
* PKCS #5
* ASN.1 DER

View file

@ -0,0 +1,26 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/11/27 06:11:57 agc Exp $
DISTNAME= crypt-1.17
PKGNAME= libtom${DISTNAME}
CATEGORIES= security
MASTER_SITES= http://libtom.org/files/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= agc@NetBSD.org
HOMEPAGE= http://libtom.org/
COMMENT= Tom St Denis's cryptographic library
LICENSE= public-domain
PKG_INSTALLATION_TYPES= overwrite pkgviews
PKG_DESTDIR_SUPPORT= user-destdir
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
MAKE_FILE= makefile.unix
MAKE_ENV+= CFLAGS_OPTS="-DUSE_LTM -DLTM_DESC"
BUILD_TARGET= default
AUTO_MKDIRS= yes
.include "../../math/ltm/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,17 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/11/27 06:11:57 agc Exp $
include/tomcrypt.h
include/tomcrypt_argchk.h
include/tomcrypt_cfg.h
include/tomcrypt_cipher.h
include/tomcrypt_custom.h
include/tomcrypt_hash.h
include/tomcrypt_mac.h
include/tomcrypt_macros.h
include/tomcrypt_math.h
include/tomcrypt_misc.h
include/tomcrypt_pk.h
include/tomcrypt_pkcs.h
include/tomcrypt_prng.h
include/tomcrypt_test.h
lib/libtomcrypt.a
share/doc/libtomcrypt/crypt.pdf

View file

@ -0,0 +1,17 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2010/11/27 06:11:57 agc Exp $
BUILDLINK_TREE+= libtomcrypt
.if !defined(LIBTOMCRYPT_BUILDLINK3_MK)
LIBTOMCRYPT_BUILDLINK3_MK:=
BUILDLINK_DEPMETHOD.libtomcrypt?= build
BUILDLINK_API_DEPENDS.libtomcrypt+= libtomcrypt>=1.17
BUILDLINK_PKGSRCDIR.libtomcrypt?= ../../security/libtomcrypt
.include "../../math/ltm/buildlink3.mk"
.endif # LIBTOMCRYPT_BUILDLINK3_MK
BUILDLINK_TREE+= -libtomcrypt

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2010/11/27 06:11:57 agc Exp $
SHA1 (crypt-1.17.tar.bz2) = 9c746822c84e4276e432b64964f94d1d5ddd13ad
RMD160 (crypt-1.17.tar.bz2) = 742d72d82fea2e6a9865d8c682c10cbaba69ea2f
Size (crypt-1.17.tar.bz2) = 1599215 bytes
SHA1 (patch-aa) = a2385cf0543a19b1555d4370a10c012c5141b48a

View file

@ -0,0 +1,39 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/11/27 06:11:57 agc Exp $
Use pkgsrc defs to install things
Install the documentation
--- makefile.unix 2010/11/24 08:46:20 1.1
+++ makefile.unix 2010/11/24 08:53:23
@@ -29,9 +29,9 @@
#LIBPATH-The directory for libtomcrypt to be installed to.
#INCPATH-The directory to install the header files for libtomcrypt.
#DATAPATH-The directory to install the pdf docs.
-LIBPATH=/usr/local/lib
-INCPATH=/usr/local/include
-DATAPATH=/usr/local/share/doc/libtomcrypt/pdf
+LIBPATH=${PREFIX}/lib
+INCPATH=${PREFIX}/include
+DATAPATH=${PREFIX}/share/doc/libtomcrypt/
#Who do we install as?
USER=root
@@ -226,11 +226,12 @@
#as root in order to have a high enough permission to write to the correct
#directories and to set the owner and group to root.
install: library
- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(DATAPATH)
- install -g $(GROUP) -o $(USER) $(LIBNAME) $(DESTDIR)$(LIBPATH)
- install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
+ ${BSD_INSTALL_LIB_DIR} $(DESTDIR)$(LIBPATH)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(INCPATH)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(DATAPATH)
+ ${BSD_INSTALL_LIB} $(LIBNAME) $(DESTDIR)$(LIBPATH)
+ ${BSD_INSTALL_DATA} $(HEADERS) $(DESTDIR)$(INCPATH)
+ ${BSD_INSTALL_DATA} doc/crypt.pdf $(DESTDIR)$(DATAPATH)
install_test: testprof/$(LIBTEST)
install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)