Changes 1.4.4:

* Publish GCRY_MODULE_ID_USER and GCRY_MODULE_ID_USER_LAST constants.
  This functionality has been in Libgcrypt since 1.3.0.
* MD5 may now be used in non-enforced fips mode.
* Fixed HMAC for SHA-384 and SHA-512 with keys longer than 64 bytes.
* In fips mode, RSA keys are now generated using the X9.31 algorithm
  and DSA keys using the FIPS 186-2 algorithm.
* The transient-key flag is now also supported for DSA key
  generation.  DSA domain parameters may be given as well.
This commit is contained in:
adam 2009-01-31 08:53:14 +00:00
parent 0bfda3619e
commit 6c385f5ff3
4 changed files with 8 additions and 20 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.42 2008/10/14 11:33:13 adam Exp $
# $NetBSD: Makefile,v 1.43 2009/01/31 08:53:14 adam Exp $
DISTNAME= libgcrypt-1.4.3
DISTNAME= libgcrypt-1.4.4
CATEGORIES= security
MASTER_SITES= ftp://ftp.gnupg.org/gcrypt/libgcrypt/ \
http://gd.tuwien.ac.at/privacy/gnupg/libgcrypt/

View file

@ -1,12 +1,11 @@
$NetBSD: distinfo,v 1.27 2008/10/29 10:30:44 wiz Exp $
$NetBSD: distinfo,v 1.28 2009/01/31 08:53:14 adam Exp $
SHA1 (libgcrypt-1.4.3.tar.bz2) = bdc67c1fdcec464a94dca691615f2335a12db5ce
RMD160 (libgcrypt-1.4.3.tar.bz2) = 5c66365e23798289fedcd9ea837cb887fa610ff4
Size (libgcrypt-1.4.3.tar.bz2) = 1087215 bytes
SHA1 (libgcrypt-1.4.4.tar.bz2) = 3987f0efcbb7048c136d5c859e88eee1763a14f6
RMD160 (libgcrypt-1.4.4.tar.bz2) = 65fd66687bd17bc8a680c59f26a8edf3e21e7dbf
Size (libgcrypt-1.4.4.tar.bz2) = 1143139 bytes
SHA1 (patch-aa) = 27db0d01f6a95566ccf0471a12f9a16dd7f994eb
SHA1 (patch-ab) = eb6d759e98acdce7aebc9ca28fff84e07a06e11c
SHA1 (patch-ac) = b8333a4c7a4a6d34c2e6840a5dd3af070280b42a
SHA1 (patch-ad) = f32281612b51c5bb3788cf03c6f5615bdfc0d3e8
SHA1 (patch-ae) = 7199ed8fe571b8c892d6eafb868820d625c2b7fa
SHA1 (patch-af) = e6d33b3e9c25a560c1df11843c6be3c9319bd018
SHA1 (patch-ag) = a0125af19e1b1fd9533cfac4d7e4530099794f4c

View file

@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.3 2008/08/14 19:24:07 wiz Exp $
# $NetBSD: options.mk,v 1.4 2009/01/31 08:53:14 adam Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.libgcrypt
PKG_SUPPORTED_OPTIONS=
@ -19,5 +19,5 @@ PKG_SUGGESTED_OPTIONS+= via-padlock
.if empty(PKG_OPTIONS:Mvia-padlock)
# Disable VIA Padlock support.
CONFIGURE_ARGS+= --disable-padlock-support
CONFIGURE_ARGS+= --disable-padlock-support
.endif

View file

@ -1,11 +0,0 @@
$NetBSD: patch-ag,v 1.4 2008/10/29 10:24:09 shannonjr Exp $
--- random/random.c.orig 2008-09-16 12:35:22.000000000 -0600
+++ random/random.c
@@ -319,5 +319,5 @@ void
_gcry_random_deinit_external_test (void *context)
{
if (fips_mode ())
- return _gcry_rngfips_deinit_external_test (context);
+ _gcry_rngfips_deinit_external_test (context);
}