Make "php-5.2.0" build with "curl-7.16.0".

This commit is contained in:
tron 2006-11-07 17:24:39 +00:00
parent 421fab12cf
commit 6c3be0f84b
2 changed files with 24 additions and 6 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.34 2006/11/07 16:57:46 tron Exp $
$NetBSD: distinfo,v 1.35 2006/11/07 17:24:39 tron Exp $
SHA1 (php-5.2.0/php-5.2.0.tar.bz2) = 6306829b1b252156ca3a936ec809aba89a71d9e1
RMD160 (php-5.2.0/php-5.2.0.tar.bz2) = baabe854ac219935ed9f58d348ebf08fb84853de
Size (php-5.2.0/php-5.2.0.tar.bz2) = 6789838 bytes
SHA1 (patch-aa) = 20bc3831e435182d014b11ae9f1f6c537a21af20
SHA1 (patch-ac) = 4f8714134977e6cef25df23b60ceea50c2aee6d0
SHA1 (patch-ac) = 95cf7bbbf1a9ce645195854f3b176dd56c94fe47
SHA1 (patch-ag) = 4ccb67ba6f5370b1d16b087e3e714de3e5ae604e
SHA1 (patch-ah) = c7cbd4b9ea0796ea3b7491c2cffb6ddddc518587
SHA1 (patch-aj) = 54812097499c81e5cb0196ab949cc86a4f24a9cc

View file

@ -1,11 +1,15 @@
$NetBSD: patch-ac,v 1.1 2006/11/01 11:33:34 tron Exp $
$NetBSD: patch-ac,v 1.2 2006/11/07 17:24:39 tron Exp $
--- ext/curl/interface.c.orig 2006-08-10 18:16:35.000000000 +0100
+++ ext/curl/interface.c 2006-11-01 11:27:50.000000000 +0000
@@ -28,6 +28,14 @@
--- ext/curl/interface.c.orig 2006-10-11 00:12:59.000000000 +0100
+++ ext/curl/interface.c 2006-11-07 17:17:18.000000000 +0000
@@ -28,6 +28,18 @@
#if HAVE_CURL
+#ifndef CURLOPT_PASSWDDATA
+#define CURLOPT_PASSWDDATA 0
+#endif
+
+#ifndef CURLOPT_PASSWDFUNCTION
+#define CURLOPT_PASSWDFUNCTION 0
+#endif
@ -17,3 +21,17 @@ $NetBSD: patch-ac,v 1.1 2006/11/01 11:33:34 tron Exp $
#include <stdio.h>
#include <string.h>
@@ -1158,11 +1170,13 @@
dupch->handlers->read->fp = ch->handlers->read->fp;
dupch->handlers->read->fd = ch->handlers->read->fd;
+#if CURLOPT_PASSWDDATA != 0
if (ch->handlers->passwd) {
zval_add_ref(&ch->handlers->passwd);
dupch->handlers->passwd = ch->handlers->passwd;
curl_easy_setopt(ch->cp, CURLOPT_PASSWDDATA, (void *) dupch);
}
+#endif
if (ch->handlers->write->func_name) {
zval_add_ref(&ch->handlers->write->func_name);
dupch->handlers->write->func_name = ch->handlers->write->func_name;