py-weasyprint: updated to 51
Version 51 Dependencies: Pyphen 0.9.1+ is now needed New features: * Add support of element() and running() * Add HTML element to Box class * Support larger and smaller values for font-size Bug fixes: * Fix how fonts used for macOS tests are installed * Fix various crashes due to line breaking bugs * Fix typo in variable name * Don’t crash when string-set is set to none * Keep font attributes when text lines are modified * Don’t let presentational hints add decorations on tables with no borders * Don’t crash on improper var() values * Fix rendering of header and footer for empty tables * Avoid quadratic time relative to tree depth when setting page names
This commit is contained in:
parent
48d391c218
commit
6c3fee3fa8
5 changed files with 16 additions and 26 deletions
1
print/py-weasyprint/ALTERNATIVES
Normal file
1
print/py-weasyprint/ALTERNATIVES
Normal file
|
@ -0,0 +1 @@
|
|||
bin/weasyprint @PREFIX@/bin/weasyprint-@PYVERSSUFFIX@
|
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.26 2020/01/26 17:32:01 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.27 2020/04/23 18:30:30 adam Exp $
|
||||
|
||||
DISTNAME= WeasyPrint-50
|
||||
DISTNAME= WeasyPrint-51
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
|
||||
CATEGORIES= print python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=W/WeasyPrint/}
|
||||
|
@ -17,7 +17,8 @@ DEPENDS+= ${PYPKGPREFIX}-cairocffi>=0.9.0:../../graphics/py-cairocffi
|
|||
DEPENDS+= ${PYPKGPREFIX}-cffi>=0.6:../../devel/py-cffi
|
||||
DEPENDS+= ${PYPKGPREFIX}-cssselect2>=0.1:../../textproc/py-cssselect2
|
||||
DEPENDS+= ${PYPKGPREFIX}-html5lib>=0.999999999:../../textproc/py-html5lib
|
||||
DEPENDS+= ${PYPKGPREFIX}-pyphen>=0.8:../../textproc/py-pyphen
|
||||
DEPENDS+= ${PYPKGPREFIX}-pyphen>=0.9.1:../../textproc/py-pyphen
|
||||
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.2.0:../../devel/py-setuptools
|
||||
DEPENDS+= ${PYPKGPREFIX}-tinycss2>=0.5:../../textproc/py-tinycss2
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-cov-[0-9]*:../../devel/py-test-cov
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-flake8-[0-9]*:../../devel/py-test-flake8
|
||||
|
@ -33,5 +34,9 @@ SUBST_STAGE.pyversfx= pre-configure
|
|||
SUBST_FILES.pyversfx= setup.cfg
|
||||
SUBST_VARS.pyversfx= PYVERSSUFFIX
|
||||
|
||||
post-install:
|
||||
cd ${DESTDIR}${PREFIX}/bin && \
|
||||
${MV} weasyprint weasyprint-${PYVERSSUFFIX} || ${TRUE}
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2019/10/09 12:33:31 wiedi Exp $
|
||||
bin/weasyprint${PYVERSSUFFIX}
|
||||
@comment $NetBSD: PLIST,v 1.6 2020/04/23 18:30:30 adam Exp $
|
||||
bin/weasyprint-${PYVERSSUFFIX}
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.19 2019/10/09 12:33:31 wiedi Exp $
|
||||
$NetBSD: distinfo,v 1.20 2020/04/23 18:30:30 adam Exp $
|
||||
|
||||
SHA1 (WeasyPrint-50.tar.gz) = 55bdb90551a1d8dfa40cb8ee7504cb74646f553b
|
||||
RMD160 (WeasyPrint-50.tar.gz) = 02bcff4f6edfad55718be7339d896190edaf3b17
|
||||
SHA512 (WeasyPrint-50.tar.gz) = b637e97eb26318f7a12e1fecaa1c4683fcc0f6dc61c7d207c71437f322f51a17edab788f4595aa2923691e1bdde18d622073b453f08ee6eef49f9e97a55cc6af
|
||||
Size (WeasyPrint-50.tar.gz) = 305975 bytes
|
||||
SHA1 (patch-setup.cfg) = cf3936b41f7ff4674d67af81ac82a5fa02b6d39e
|
||||
SHA1 (WeasyPrint-51.tar.gz) = 3e12b36cbe86e868d7066cfdac401accb6736b52
|
||||
RMD160 (WeasyPrint-51.tar.gz) = a0a929dd367b6e1387c82e9c56edbbc6fd4be99e
|
||||
SHA512 (WeasyPrint-51.tar.gz) = 631038bece7ac0c15c6a668a7d06137e4bccc049eb80484a153ca9c4a996256de8647428b21ed1d0c1607af3893c747a1956a3d3f012b30105ba4f8613a96fcd
|
||||
Size (WeasyPrint-51.tar.gz) = 308411 bytes
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-setup.cfg,v 1.4 2019/02/21 07:54:14 kleink Exp $
|
||||
|
||||
Adjust script path to allow multiple Python version installs.
|
||||
|
||||
--- setup.cfg.orig 2019-02-20 16:36:18.000000000 +0000
|
||||
+++ setup.cfg
|
||||
@@ -57,7 +57,7 @@ tests_require =
|
||||
python_requires = >= 3.5
|
||||
|
||||
[options.entry_points]
|
||||
-console-scripts = weasyprint = weasyprint.__main__:main
|
||||
+console-scripts = weasyprint@PYVERSSUFFIX@ = weasyprint.__main__:main
|
||||
|
||||
[options.package_data]
|
||||
weasyprint = VERSION
|
Loading…
Reference in a new issue