geography/qgis: Update to 3.16.16
Upstream changes are minor. Packaging changes: Work around a new upstream bug where a test that depends on qtwebkit was not ifdefed. Start to try to adapt to the changes in py-sip.
This commit is contained in:
parent
646e700c86
commit
6c43b7139b
3 changed files with 44 additions and 8 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.135 2022/01/18 17:42:26 gdt Exp $
|
||||
# $NetBSD: Makefile,v 1.136 2022/01/18 23:33:59 gdt Exp $
|
||||
|
||||
# This is intentionally 3.16 Long Term Release. Please do not update
|
||||
# to later branches, and instead discuss whether/how we want multiple
|
||||
# versions.
|
||||
DISTNAME= qgis-3.16.15
|
||||
PKGREVISION= 1
|
||||
DISTNAME= qgis-3.16.16
|
||||
CATEGORIES= geography
|
||||
MASTER_SITES= https://qgis.org/downloads/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -53,9 +52,10 @@ SUBST_NOOP_OK.xapple= yes # since SUBST_FILES is generated
|
|||
SUBST_CLASSES+= pyqt
|
||||
SUBST_STAGE.pyqt= pre-configure
|
||||
SUBST_MESSAGE.pyqt= Use correct python version for PyQt5 programs
|
||||
SUBST_FILES.pyqt= cmake/PyQtMacros.cmake
|
||||
SUBST_FILES.pyqt= cmake/PyQtMacros.cmake cmake/FindPyQt5.py
|
||||
SUBST_SED.pyqt+= -e '/^SET/s,pyuic5,&-${PYVERSSUFFIX},'
|
||||
SUBST_SED.pyqt+= -e '/^SET/s,pyrcc5,&-${PYVERSSUFFIX},'
|
||||
SUBST_SED.pyqt+= -e '/os.path.dirname.*pyuic5/s,pyuic5,&-${PYVERSSUFFIX},'
|
||||
|
||||
CMAKE_ARGS+= -DWITH_BINDINGS:BOOL=TRUE
|
||||
CMAKE_ARGS+= -DSIP_BINARY_PATH:PATH=${BUILDLINK_PREFIX.py-sip}/bin
|
||||
|
|
|
@ -1,11 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.34 2022/01/06 00:02:04 gdt Exp $
|
||||
$NetBSD: distinfo,v 1.35 2022/01/18 23:33:59 gdt Exp $
|
||||
|
||||
BLAKE2s (qgis-3.16.15.tar.bz2) = c2337e60c8703ed80e91ef642f32e41950e89a06b9984a0daade79adee92a8db
|
||||
SHA512 (qgis-3.16.15.tar.bz2) = 3de807da1b957452d134f8c5bb41a5321ac4273e16c23ad329b269371d3630f543d5ee65b29f26f236aa4a51f9e101d1ffe63f04e43875041733b2f2b434fe9e
|
||||
Size (qgis-3.16.15.tar.bz2) = 117849766 bytes
|
||||
BLAKE2s (qgis-3.16.16.tar.bz2) = d8a298ed1a3259e5d5dec3df8e6f38073c673d3ac86588e3731fe3d3dbda6dad
|
||||
SHA512 (qgis-3.16.16.tar.bz2) = ba5e6f8165129054fb23f00def67c443b486fb8b9fc59d063fb6d65011b5bf53297e81d518f632b1b87f0ed1c3dfe59a68707f0cb16eb16304908a9a2dad29f6
|
||||
Size (qgis-3.16.16.tar.bz2) = 119123296 bytes
|
||||
SHA1 (patch-cmake_FindQwt.cmake) = c07cb250727d0d9f4abe76e1118d896552a1bd68
|
||||
SHA1 (patch-mac_CMakeLists.txt) = 8e52ca943d44392939d0fcf083ba2681a7d77c53
|
||||
SHA1 (patch-mac_cmake_1qt.cmake.in) = d74f7201849ef6dd83f39251e466eb04c791c0e6
|
||||
SHA1 (patch-src_core_CMakeLists.txt) = 818d36e9dbbd31a46471de185d489ebbdbafe71d
|
||||
SHA1 (patch-src_core_qgsapplication.cpp) = 54bba734969cd9fd90a2317d8c1531da2827d145
|
||||
SHA1 (patch-src_crssync_CMakeLists.txt) = 785d820fec76d046c87297bd71ea547a83c4ac2a
|
||||
SHA1 (patch-tests_src_gui_testqgsexternalresourcewidgetwrapper.cpp) = 1105f53864ca3f73debca74f94c52aba3ef2fd00
|
||||
|
|
|
@ -0,0 +1,35 @@
|
|||
$NetBSD: patch-tests_src_gui_testqgsexternalresourcewidgetwrapper.cpp,v 1.1 2022/01/18 23:33:59 gdt Exp $
|
||||
|
||||
Fix a test that should have been guarded based on qt5-webkit.
|
||||
|
||||
Reported upstream via email 20210118.
|
||||
|
||||
--- tests/src/gui/testqgsexternalresourcewidgetwrapper.cpp.orig 2022-01-14 12:06:23.000000000 +0000
|
||||
+++ tests/src/gui/testqgsexternalresourcewidgetwrapper.cpp
|
||||
@@ -44,7 +44,9 @@ class TestQgsExternalResourceWidgetWrapp
|
||||
void init();// will be called before each testfunction is executed.
|
||||
void cleanup();// will be called after every testfunction.
|
||||
void test_setNullValues();
|
||||
+#ifdef WITH_QTWEBKIT
|
||||
void testBlankAfterValue();
|
||||
+#endif /* WITH_QTWEBKIT */
|
||||
|
||||
private:
|
||||
std::unique_ptr<QgsVectorLayer> vl;
|
||||
@@ -115,6 +117,8 @@ void TestQgsExternalResourceWidgetWrappe
|
||||
delete widget;
|
||||
}
|
||||
|
||||
+#ifdef WITH_QTWEBKIT
|
||||
+
|
||||
void TestQgsExternalResourceWidgetWrapper::testBlankAfterValue()
|
||||
{
|
||||
// test that application doesn't crash when we set a blank page in web preview
|
||||
@@ -152,5 +156,7 @@ void TestQgsExternalResourceWidgetWrappe
|
||||
QCOMPARE( ww.mQgsWidget->mWebView->url().toString(), QStringLiteral( "about:blank" ) );
|
||||
}
|
||||
|
||||
+#endif /* WITH_QTWEBKIT */
|
||||
+
|
||||
QGSTEST_MAIN( TestQgsExternalResourceWidgetWrapper )
|
||||
#include "testqgsexternalresourcewidgetwrapper.moc"
|
Loading…
Reference in a new issue