Fix errno.

This commit is contained in:
joerg 2006-03-22 23:56:38 +00:00
parent 73c94df211
commit 6c73080bdf
8 changed files with 75 additions and 20 deletions

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.11 2005/02/27 22:49:43 wiz Exp $
$NetBSD: distinfo,v 1.12 2006/03/22 23:56:38 joerg Exp $
SHA1 (mtr-0.69.tar.gz) = 3fd0fa148b349d1966e0d79af0ffb84ecc7bed4b
RMD160 (mtr-0.69.tar.gz) = e95e0f27253d8d94587b429cbb65311035e93c2e
Size (mtr-0.69.tar.gz) = 183216 bytes
SHA1 (patch-aa) = 5eb4ab7bfa02095c2b7a110426dd4aa5738f0a2c
SHA1 (patch-ab) = 25e8711a7736d2772a17e6b6dda962d95e294c86
SHA1 (patch-ab) = f132e394a4b6b00f56e38333d3f49bf5c11965b9

View file

@ -1,8 +1,12 @@
$NetBSD: patch-ab,v 1.7 2005/02/27 22:49:43 wiz Exp $
$NetBSD: patch-ab,v 1.8 2006/03/22 23:56:38 joerg Exp $
--- dns.c.orig 2005-01-11 09:32:42.000000000 +0100
--- dns.c.orig 2005-01-11 08:32:42.000000000 +0000
+++ dns.c
@@ -32,9 +32,17 @@
@@ -28,13 +28,20 @@
#include <sys/time.h>
#include <sys/select.h>
#include <sys/stat.h>
-#include <sys/errno.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
@ -20,7 +24,17 @@ $NetBSD: patch-ab,v 1.7 2005/02/27 22:49:43 wiz Exp $
#include <unistd.h>
#include <fcntl.h>
#include <ctype.h>
@@ -294,6 +302,17 @@ char nullstring[] = "";
@@ -54,9 +61,6 @@ extern char *sys_errlist[];
#define strerror(errno) (((errno) >= 0 && (errno) < sys_nerr) ? sys_errlist[errno] : "unlisted error")
#endif
-/* Hmm, it seems Irix requires this */
-extern int errno;
-
extern int af;
/* Defines */
@@ -294,6 +298,17 @@ char nullstring[] = "";
int use_dns = 1;
@ -38,7 +52,7 @@ $NetBSD: patch-ab,v 1.7 2005/02/27 22:49:43 wiz Exp $
/* Code */
#ifdef CorruptCheck
@@ -468,14 +487,14 @@ void dns_open(void)
@@ -468,14 +483,14 @@ void dns_open(void)
{
int option,i;
@ -58,7 +72,7 @@ $NetBSD: patch-ab,v 1.7 2005/02/27 22:49:43 wiz Exp $
resfd = socket(AF_INET, SOCK_DGRAM, 0);
if (resfd == -1) {
fprintf(stderr,"Unable to allocate socket for nameserver communication: %s\n",
@@ -858,17 +877,17 @@ void dorequest(char *s,int type,word id)
@@ -858,17 +873,17 @@ void dorequest(char *s,int type,word id)
{
packetheader *hp;
int r,i;
@ -80,7 +94,7 @@ $NetBSD: patch-ab,v 1.7 2005/02/27 22:49:43 wiz Exp $
sizeof(struct sockaddr));
}
@@ -1224,18 +1243,18 @@ void dns_ack(void)
@@ -1224,18 +1239,18 @@ void dns_ack(void)
/* Check to see if this server is actually one we sent to */
if ( addrcmp( (void *) &(from4->sin_addr), (void *) &localhost,
(int) AF_INET ) == 0 ) {

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.16 2005/02/27 22:49:43 wiz Exp $
$NetBSD: distinfo,v 1.17 2006/03/22 23:57:12 joerg Exp $
SHA1 (mtr-0.69.tar.gz) = 3fd0fa148b349d1966e0d79af0ffb84ecc7bed4b
RMD160 (mtr-0.69.tar.gz) = e95e0f27253d8d94587b429cbb65311035e93c2e
Size (mtr-0.69.tar.gz) = 183216 bytes
SHA1 (patch-aa) = 5eb4ab7bfa02095c2b7a110426dd4aa5738f0a2c
SHA1 (patch-ab) = 25e8711a7736d2772a17e6b6dda962d95e294c86
SHA1 (patch-ab) = f132e394a4b6b00f56e38333d3f49bf5c11965b9
SHA1 (patch-ad) = 0565b900e45baf624866e3858ab43a2ab2c4bbfe
SHA1 (patch-ae) = 4e40b16e0416f024898eda8375b5560ae08cbfaa

View file

@ -1,8 +1,12 @@
$NetBSD: patch-ab,v 1.9 2005/02/27 22:49:43 wiz Exp $
$NetBSD: patch-ab,v 1.10 2006/03/22 23:57:12 joerg Exp $
--- dns.c.orig 2005-01-11 09:32:42.000000000 +0100
--- dns.c.orig 2005-01-11 08:32:42.000000000 +0000
+++ dns.c
@@ -32,9 +32,17 @@
@@ -28,13 +28,20 @@
#include <sys/time.h>
#include <sys/select.h>
#include <sys/stat.h>
-#include <sys/errno.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
@ -20,7 +24,17 @@ $NetBSD: patch-ab,v 1.9 2005/02/27 22:49:43 wiz Exp $
#include <unistd.h>
#include <fcntl.h>
#include <ctype.h>
@@ -294,6 +302,17 @@ char nullstring[] = "";
@@ -54,9 +61,6 @@ extern char *sys_errlist[];
#define strerror(errno) (((errno) >= 0 && (errno) < sys_nerr) ? sys_errlist[errno] : "unlisted error")
#endif
-/* Hmm, it seems Irix requires this */
-extern int errno;
-
extern int af;
/* Defines */
@@ -294,6 +298,17 @@ char nullstring[] = "";
int use_dns = 1;
@ -38,7 +52,7 @@ $NetBSD: patch-ab,v 1.9 2005/02/27 22:49:43 wiz Exp $
/* Code */
#ifdef CorruptCheck
@@ -468,14 +487,14 @@ void dns_open(void)
@@ -468,14 +483,14 @@ void dns_open(void)
{
int option,i;
@ -58,7 +72,7 @@ $NetBSD: patch-ab,v 1.9 2005/02/27 22:49:43 wiz Exp $
resfd = socket(AF_INET, SOCK_DGRAM, 0);
if (resfd == -1) {
fprintf(stderr,"Unable to allocate socket for nameserver communication: %s\n",
@@ -858,17 +877,17 @@ void dorequest(char *s,int type,word id)
@@ -858,17 +873,17 @@ void dorequest(char *s,int type,word id)
{
packetheader *hp;
int r,i;
@ -80,7 +94,7 @@ $NetBSD: patch-ab,v 1.9 2005/02/27 22:49:43 wiz Exp $
sizeof(struct sockaddr));
}
@@ -1224,18 +1243,18 @@ void dns_ack(void)
@@ -1224,18 +1239,18 @@ void dns_ack(void)
/* Check to see if this server is actually one we sent to */
if ( addrcmp( (void *) &(from4->sin_addr), (void *) &localhost,
(int) AF_INET ) == 0 ) {

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.3 2005/08/26 17:01:38 drochner Exp $
$NetBSD: distinfo,v 1.4 2006/03/23 00:06:52 joerg Exp $
SHA1 (nemesis-1.4.tar.gz) = a88e04145e5f379da4d50a9acfeaf62da68aaf94
RMD160 (nemesis-1.4.tar.gz) = b07abbdd7baf552a40056e549653b6fba1d1feca
Size (nemesis-1.4.tar.gz) = 144187 bytes
SHA1 (patch-aa) = 42465612b3369e6396051326b2ba811bd8cdd10a

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.3 2006/03/23 00:06:52 joerg Exp $
--- src/nemesis-functions.c.orig 2006-03-23 00:00:16.000000000 +0000
+++ src/nemesis-functions.c
@@ -428,7 +428,6 @@ char *nemesis_lookup_linktype(int linkty
int nemesis_seedrand(void)
{
#if !defined(WIN32)
- extern int errno;
struct timeval tv;
if (gettimeofday(&tv, NULL) == -1)

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.7 2005/02/24 12:13:54 agc Exp $
$NetBSD: distinfo,v 1.8 2006/03/23 00:12:53 joerg Exp $
SHA1 (netsaint-0.0.7.tar.gz) = 5ce4832c9cccaba0baa49fe3e222c6753a811143
RMD160 (netsaint-0.0.7.tar.gz) = 3e0a3291f5b858eaf75c51d7fed0174e24f1a53a
@ -12,3 +12,4 @@ SHA1 (patch-af) = 9df309dde76fa4d79fa0880824af425f6982ed84
SHA1 (patch-ag) = f6c8105adbdcb0ba22da1d2aa7395d7dbf8d7329
SHA1 (patch-ah) = 3e215778e529a04803f5027612578636fc91aa2d
SHA1 (patch-ai) = 7412e8430abf640e74d16d1ff18436b8b272871c
SHA1 (patch-aj) = 319b7d26db112c2ad9272fd86e4a7942e95ef4b0

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aj,v 1.1 2006/03/23 00:12:53 joerg Exp $
--- base/utils.c.orig 2006-03-23 00:04:27.000000000 +0000
+++ base/utils.c
@@ -201,8 +201,6 @@ extern char *tzname[2];
extern service_message svc_msg;
-extern int errno;
-
/******************************************************************/