Update ruby-rgl to version 0.3.1. Changes from version 0.2.3 include:

+ Install as a Ruby gem.

* All IDs for DOT objects, including names, options, and values, are
  now automatically quoted as necessary for graphviz.  Labels are
  handled specially in order to account for \l, \r, and \n sequences
  but are otherwise treated the same as other options.  Some changes
  were made in order to remove explicit quotes from labels which are
  no longer necessary.

* Removed backwards compatability method inject.

* DOTSimpleElement provides no useful function, so remove it

* Add support for the Mrecord shape to DOTNode.  Rewrite DOTNode#to_s
  to be easier to understand.  #Rewrite DOTPort to allow for nesting
  ports.

* DOTElement no longer sets the label unless the user explicitly sets
  one.

* Subgraphs must be identified by a "subgraph" header rather than a
  "graph" header

* Added equality test for graphs, added cycle locating.  Modified
  initialize to allow duplicating and merging of graphs.

* Assorted bug fixes.
This commit is contained in:
jlam 2008-04-04 15:18:28 +00:00
parent 61334e824b
commit 6ccd992495
4 changed files with 124 additions and 149 deletions

View file

@ -1,33 +1,14 @@
# $NetBSD: Makefile,v 1.2 2006/05/04 01:38:02 minskim Exp $
# $NetBSD: Makefile,v 1.3 2008/04/04 15:18:28 jlam Exp $
DISTNAME= rgl-0.2.3
DISTNAME= rgl-0.3.1
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME}
PKGREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://rubyforge.org/frs/download.php/3959/
EXTRACT_SUFX= .tgz
MAINTAINER= minskim@NetBSD.org
HOMEPAGE= http://rgl.rubyforge.org/
COMMENT= Framework for graph data structures and algorithms
DEPENDS+= ${RUBY_PKGPREFIX}-stream-[0-9]*:../../devel/ruby-stream
NO_BUILD= yes
NO_CONFIGURE= yes
USE_RUBY_INSTALL= yes
.include "../../lang/ruby/modules.mk"
post-install:
${INSTALL_DATA_DIR} ${RUBY_DOCDIR}/rgl
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/rgl
${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/rgl
${CP} -R ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/rgl
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${RUBY_EXAMPLESDIR}/rgl
${FIND} ${RUBY_EXAMPLESDIR}/rgl -type d -print | \
${XARGS} ${CHMOD} ${PKGDIRMODE}
${FIND} ${RUBY_EXAMPLESDIR}/rgl -type f -print | \
${XARGS} ${CHMOD} ${SHAREMODE}
DEPENDS+= ${RUBY_PKGPREFIX}-stream>=0.5:../../devel/ruby-stream
.include "../../misc/rubygems/rubygem.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,95 +1,116 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2006/05/03 23:11:03 minskim Exp $
${RUBY_SITELIBDIR}/rgl/adjacency.rb
${RUBY_SITELIBDIR}/rgl/base.rb
${RUBY_SITELIBDIR}/rgl/connected_components.rb
${RUBY_SITELIBDIR}/rgl/dot.rb
${RUBY_SITELIBDIR}/rgl/graphxml.rb
${RUBY_SITELIBDIR}/rgl/implicit.rb
${RUBY_SITELIBDIR}/rgl/mutable.rb
${RUBY_SITELIBDIR}/rgl/rdot.rb
${RUBY_SITELIBDIR}/rgl/topsort.rb
${RUBY_SITELIBDIR}/rgl/transitiv_closure.rb
${RUBY_SITELIBDIR}/rgl/traversal.rb
${RUBY_DOCDIR}/rgl/README
${RUBY_EXAMPLESDIR}/rgl/canvas.rb
${RUBY_EXAMPLESDIR}/rgl/codegraph
${RUBY_EXAMPLESDIR}/rgl/debgraph.rb
${RUBY_EXAMPLESDIR}/rgl/example.jpg
${RUBY_EXAMPLESDIR}/rgl/examples.rb
${RUBY_EXAMPLESDIR}/rgl/graph.dot
${RUBY_EXAMPLESDIR}/rgl/insel.rb
${RUBY_EXAMPLESDIR}/rgl/module_graph.jpg
${RUBY_EXAMPLESDIR}/rgl/north.rb
${RUBY_EXAMPLESDIR}/rgl/north/Graph.log
${RUBY_EXAMPLESDIR}/rgl/north/g.10.0.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.1.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.11.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.12.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.13.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.14.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.15.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.16.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.17.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.19.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.2.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.20.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.22.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.24.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.25.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.27.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.28.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.29.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.3.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.30.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.31.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.34.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.37.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.38.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.39.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.4.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.40.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.41.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.42.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.45.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.46.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.5.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.50.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.56.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.57.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.58.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.6.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.60.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.61.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.62.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.68.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.69.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.7.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.70.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.71.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.72.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.74.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.75.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.78.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.79.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.8.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.80.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.82.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.83.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.85.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.86.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.88.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.89.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.9.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.90.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.91.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.92.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.93.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.10.94.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.12.8.graphml
${RUBY_EXAMPLESDIR}/rgl/north/g.14.9.graphml
${RUBY_EXAMPLESDIR}/rgl/north2.rb
${RUBY_EXAMPLESDIR}/rgl/rdep-rgl.rb
@dirrm ${RUBY_EXAMPLESDIR}/rgl/north
@dirrm ${RUBY_EXAMPLESDIR}/rgl
@dirrm ${RUBY_DOCDIR}/rgl
@dirrm ${RUBY_SITELIBDIR}/rgl
@comment $NetBSD: PLIST,v 1.2 2008/04/04 15:18:28 jlam Exp $
${GEM_HOME}/cache/rgl-${PKGVERSION}.gem
${GEM_LIBDIR}/ChangeLog
${GEM_LIBDIR}/README
${GEM_LIBDIR}/Rakefile
${GEM_LIBDIR}/examples/canvas.rb
${GEM_LIBDIR}/examples/example.jpg
${GEM_LIBDIR}/examples/examples.rb
${GEM_LIBDIR}/examples/insel-der-tausend-gefahren.rb
${GEM_LIBDIR}/examples/module_graph.jpg
${GEM_LIBDIR}/examples/north.rb
${GEM_LIBDIR}/examples/north/Graph.log
${GEM_LIBDIR}/examples/north/g.10.0.graphml
${GEM_LIBDIR}/examples/north/g.10.1.graphml
${GEM_LIBDIR}/examples/north/g.10.11.graphml
${GEM_LIBDIR}/examples/north/g.10.12.graphml
${GEM_LIBDIR}/examples/north/g.10.13.graphml
${GEM_LIBDIR}/examples/north/g.10.14.graphml
${GEM_LIBDIR}/examples/north/g.10.15.graphml
${GEM_LIBDIR}/examples/north/g.10.16.graphml
${GEM_LIBDIR}/examples/north/g.10.17.graphml
${GEM_LIBDIR}/examples/north/g.10.19.graphml
${GEM_LIBDIR}/examples/north/g.10.2.graphml
${GEM_LIBDIR}/examples/north/g.10.20.graphml
${GEM_LIBDIR}/examples/north/g.10.22.graphml
${GEM_LIBDIR}/examples/north/g.10.24.graphml
${GEM_LIBDIR}/examples/north/g.10.25.graphml
${GEM_LIBDIR}/examples/north/g.10.27.graphml
${GEM_LIBDIR}/examples/north/g.10.28.graphml
${GEM_LIBDIR}/examples/north/g.10.29.graphml
${GEM_LIBDIR}/examples/north/g.10.3.graphml
${GEM_LIBDIR}/examples/north/g.10.30.graphml
${GEM_LIBDIR}/examples/north/g.10.31.graphml
${GEM_LIBDIR}/examples/north/g.10.34.graphml
${GEM_LIBDIR}/examples/north/g.10.37.graphml
${GEM_LIBDIR}/examples/north/g.10.38.graphml
${GEM_LIBDIR}/examples/north/g.10.39.graphml
${GEM_LIBDIR}/examples/north/g.10.4.graphml
${GEM_LIBDIR}/examples/north/g.10.40.graphml
${GEM_LIBDIR}/examples/north/g.10.41.graphml
${GEM_LIBDIR}/examples/north/g.10.42.graphml
${GEM_LIBDIR}/examples/north/g.10.45.graphml
${GEM_LIBDIR}/examples/north/g.10.46.graphml
${GEM_LIBDIR}/examples/north/g.10.5.graphml
${GEM_LIBDIR}/examples/north/g.10.50.graphml
${GEM_LIBDIR}/examples/north/g.10.56.graphml
${GEM_LIBDIR}/examples/north/g.10.57.graphml
${GEM_LIBDIR}/examples/north/g.10.58.graphml
${GEM_LIBDIR}/examples/north/g.10.6.graphml
${GEM_LIBDIR}/examples/north/g.10.60.graphml
${GEM_LIBDIR}/examples/north/g.10.61.graphml
${GEM_LIBDIR}/examples/north/g.10.62.graphml
${GEM_LIBDIR}/examples/north/g.10.68.graphml
${GEM_LIBDIR}/examples/north/g.10.69.graphml
${GEM_LIBDIR}/examples/north/g.10.7.graphml
${GEM_LIBDIR}/examples/north/g.10.70.graphml
${GEM_LIBDIR}/examples/north/g.10.71.graphml
${GEM_LIBDIR}/examples/north/g.10.72.graphml
${GEM_LIBDIR}/examples/north/g.10.74.graphml
${GEM_LIBDIR}/examples/north/g.10.75.graphml
${GEM_LIBDIR}/examples/north/g.10.78.graphml
${GEM_LIBDIR}/examples/north/g.10.79.graphml
${GEM_LIBDIR}/examples/north/g.10.8.graphml
${GEM_LIBDIR}/examples/north/g.10.80.graphml
${GEM_LIBDIR}/examples/north/g.10.82.graphml
${GEM_LIBDIR}/examples/north/g.10.83.graphml
${GEM_LIBDIR}/examples/north/g.10.85.graphml
${GEM_LIBDIR}/examples/north/g.10.86.graphml
${GEM_LIBDIR}/examples/north/g.10.88.graphml
${GEM_LIBDIR}/examples/north/g.10.89.graphml
${GEM_LIBDIR}/examples/north/g.10.9.graphml
${GEM_LIBDIR}/examples/north/g.10.90.graphml
${GEM_LIBDIR}/examples/north/g.10.91.graphml
${GEM_LIBDIR}/examples/north/g.10.92.graphml
${GEM_LIBDIR}/examples/north/g.10.93.graphml
${GEM_LIBDIR}/examples/north/g.10.94.graphml
${GEM_LIBDIR}/examples/north/g.12.8.graphml
${GEM_LIBDIR}/examples/north/g.14.9.graphml
${GEM_LIBDIR}/examples/north2.rb
${GEM_LIBDIR}/examples/rdep-rgl.rb
${GEM_LIBDIR}/install.rb
${GEM_LIBDIR}/lib/rgl/adjacency.rb
${GEM_LIBDIR}/lib/rgl/base.rb
${GEM_LIBDIR}/lib/rgl/bidirectional.rb
${GEM_LIBDIR}/lib/rgl/connected_components.rb
${GEM_LIBDIR}/lib/rgl/dot.rb
${GEM_LIBDIR}/lib/rgl/enumerable_ext.rb
${GEM_LIBDIR}/lib/rgl/graphxml.rb
${GEM_LIBDIR}/lib/rgl/implicit.rb
${GEM_LIBDIR}/lib/rgl/mutable.rb
${GEM_LIBDIR}/lib/rgl/rdot.rb
${GEM_LIBDIR}/lib/rgl/topsort.rb
${GEM_LIBDIR}/lib/rgl/transitiv_closure.rb
${GEM_LIBDIR}/lib/rgl/traversal.rb
${GEM_LIBDIR}/rakelib/dep_graph.rake
${GEM_LIBDIR}/tests/TestComponents.rb
${GEM_LIBDIR}/tests/TestCycles.rb
${GEM_LIBDIR}/tests/TestDirectedGraph.rb
${GEM_LIBDIR}/tests/TestDot.rb
${GEM_LIBDIR}/tests/TestEdge.rb
${GEM_LIBDIR}/tests/TestGraph.rb
${GEM_LIBDIR}/tests/TestGraphXML.rb
${GEM_LIBDIR}/tests/TestImplicit.rb
${GEM_LIBDIR}/tests/TestRdot.rb
${GEM_LIBDIR}/tests/TestTransitiveClosure.rb
${GEM_LIBDIR}/tests/TestTraversal.rb
${GEM_LIBDIR}/tests/TestUnDirectedGraph.rb
${GEM_LIBDIR}/tests/test_helper.rb
${GEM_HOME}/specifications/rgl-${PKGVERSION}.gemspec
@dirrm ${GEM_LIBDIR}/tests
@dirrm ${GEM_LIBDIR}/rakelib
@dirrm ${GEM_LIBDIR}/lib/rgl
@dirrm ${GEM_LIBDIR}/lib
@dirrm ${GEM_LIBDIR}/examples/north
@dirrm ${GEM_LIBDIR}/examples
@dirrm ${GEM_LIBDIR}

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2006/05/03 23:11:03 minskim Exp $
$NetBSD: distinfo,v 1.2 2008/04/04 15:18:28 jlam Exp $
SHA1 (rgl-0.2.3.tgz) = 375197d8961a70081e0e8c833cc60dcfa10ab0e9
RMD160 (rgl-0.2.3.tgz) = c51cac4f587e3090cbc392ce6b63340da8ecc464
Size (rgl-0.2.3.tgz) = 66055 bytes
SHA1 (patch-aa) = e93a19819a9a924da18abe6a100603a852d0c285
SHA1 (rgl-0.3.1.gem) = cbdb140e2e537f5fd983c7285661727afd496ac6
RMD160 (rgl-0.3.1.gem) = 477123460a68463c0179a7ab8866610897b92e42
Size (rgl-0.3.1.gem) = 70656 bytes

View file

@ -1,26 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2006/05/03 23:11:03 minskim Exp $
--- install.rb.orig 2004-10-08 10:13:14.000000000 -0500
+++ install.rb
@@ -8,8 +8,20 @@ require 'find'
SRC_BASE = 'lib'
SRC = 'rgl'
+include Config
-INSTDIR = File.join Config::CONFIG['sitedir']
+$sitedir = CONFIG["sitelibdir"]
+unless $sitedir
+ version = CONFIG["MAJOR"] + "." + CONFIG["MINOR"]
+ $libdir = File.join(CONFIG["libdir"], "ruby", version)
+ $sitedir = $:.find {|x| x =~ /site_ruby/ }
+ if !$sitedir
+ $sitedir = File.join($libdir, "site_ruby")
+ elsif $sitedir !~ Regexp.quote(version)
+ $sitedir = File.join($sitedir, version)
+ end
+end
+INSTDIR = $sitedir
DESTDIR = File.join INSTDIR, SRC
opts = GetoptLong.new( [ "--uninstall", "-u", GetoptLong::NO_ARGUMENT ] )