Add a patch from drochner@ to keep the selftest from crashing.
While here, fix MASTER_SITES, USE_TOOLS and build deps.
This commit is contained in:
parent
b5420ef2d0
commit
6ce19e0a90
3 changed files with 19 additions and 4 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.4 2010/11/07 09:32:07 gls Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2010/11/11 23:05:17 gls Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libgee-0.6.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/libgee/0.5/}
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/libgee/0.6/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
|
@ -15,7 +15,8 @@ PKG_DESTDIR_SUPPORT= user-destdir
|
|||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
USE_TOOLS+= pkg-config gmake
|
||||
BUILD_DEPENDS+= vala-[0-9]*:../../lang/vala
|
||||
|
||||
PKGCONFIG_OVERRIDE+= gee-1.0.pc.in
|
||||
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.3 2010/11/07 09:32:07 gls Exp $
|
||||
$NetBSD: distinfo,v 1.4 2010/11/11 23:05:17 gls Exp $
|
||||
|
||||
SHA1 (libgee-0.6.0.tar.bz2) = 37127eacecfc1090f0f91b8350a6b2456580a318
|
||||
RMD160 (libgee-0.6.0.tar.bz2) = 8cd55171fc2c8392b0cd5b1fb8cf56750a22b25a
|
||||
Size (libgee-0.6.0.tar.bz2) = 477609 bytes
|
||||
SHA1 (patch-aa) = 034f3092ac768d08a5e582d004197dc71f763bc5
|
||||
|
|
13
devel/libgee/patches/patch-aa
Normal file
13
devel/libgee/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1 2010/11/11 23:05:17 gls Exp $
|
||||
|
||||
--- gee/priorityqueue.vala.orig 2010-09-15 18:20:50.000000000 +0000
|
||||
+++ gee/priorityqueue.vala
|
||||
@@ -661,7 +661,7 @@ public class Gee.PriorityQueue<G> : Gee.
|
||||
_a[degree] = null;
|
||||
|
||||
int i = _a.length - 1;
|
||||
- while (_a[i] == null) {
|
||||
+ while (i >=0 && _a[i] == null) {
|
||||
i--;
|
||||
}
|
||||
_a.resize (i + 1);
|
Loading…
Reference in a new issue