Update to 1.1.9. The patch-a[d-j] are snippets from the patch borrowed from

Gentoo bugzilla - http://bugs.gentoo.org/show_bug.cgi?id=270372. This makes
it compile on Linux glibc-2.10 and other systems (also DragonFly).

cdrkit (1.1.9)

  * wodim: In -msinfo mode, only suggest dvd+rw-mediainfo in verbose mode.
    Thanks to Michael Karcher <debian@mkarcher.dialup.fu-berlin.de> for the
    patch.
  * genisoimage: undo a mistake in the directory permissions change in
    the last release. Fixes handling of deep directory structures.

cdrkit (1.1.8)

  * genisoimage/joliet.c: Fix a potential memory corruption bug.
  * genisoimage/md5.c: Trivial cleanup
  * genisoimage/genisoimage.[c1]: Add command-line support for
    -jigdo-template-compress
  * genisoimage/sha1.h: Fix a type issue that broke sha1 support
    on 64-bit arches.
  * genisoimage/checksum.[ch]: Added test code; changed internal
    layout slightly to make for easier debug.
  * genisoimage: Applied patch from Roman Rakus <rrakus@redhat.com> to
    preserve directory permissions.
  * genisoimage: Add a patch from Ivan Shmakov. "-o -" will now write
    to stdout, as typical for command line programs. And we will try
    not to corrupt stdout by default if it's a terminal.
  * genisoimage/genisoimage.1: Add a mention of -chrp-boot.
  * genisoimage/mac_label.c: Fix an over-keen s/mkisofs/genisoimage.

cdrkit (1.1.7.1)

  * Re-spin the 1.1.7 release with a few silly release process errors fixed.

cdrkit (1.1.7)

  * lots of fixes to prevent gcc warnings
  * Fix for Joliet directory length bug in genisoimage
  * wodim.1: small fixes.
  * genisoimage/jte.c: add support for bzip2-compressed templates
  * genisoimage/jte.c: fix bzip2-compressed template data to be
    compatible with jigdo.
  * genisoimage/jte.c: fix exclude list handling.
  * genisoimage/checksum.[ch]: Add a generic infrastructure for
    checksums so we can use sha1/<whatever> as well as just
    md5sum. Will make things much faster for generating sha1sums for
    images and jigdos.
  * genisoimage/sha1.[ch]: Add GPL-licensed SHA1 implementation.
  * s/mkisofs/genisoimage/ in ABOUT
This commit is contained in:
hasso 2009-06-07 22:02:24 +00:00
parent c67cdcbaef
commit 6d33cb6fb0
10 changed files with 166 additions and 10 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.4 2008/12/02 13:03:22 obache Exp $
# $NetBSD: Makefile,v 1.5 2009/06/07 22:02:24 hasso Exp $
#
DISTNAME= cdrkit-1.1.6
PKGREVISION= 1
DISTNAME= cdrkit-1.1.9
CATEGORIES= sysutils
MASTER_SITES= http://cdrkit.org/releases/

View file

@ -1,8 +1,15 @@
$NetBSD: distinfo,v 1.1.1.1 2007/07/01 00:26:14 wiz Exp $
$NetBSD: distinfo,v 1.2 2009/06/07 22:02:24 hasso Exp $
SHA1 (cdrkit-1.1.6.tar.gz) = 39fd5f9c500f4f084bd112bc103bed2785a8eb8b
RMD160 (cdrkit-1.1.6.tar.gz) = e8d322cdef9770c0cdce3fbb9b45a5e904f20d23
Size (cdrkit-1.1.6.tar.gz) = 1407346 bytes
SHA1 (cdrkit-1.1.9.tar.gz) = 44c9d85c300803e6b9a415e79f3f0c9ddf1a65ee
RMD160 (cdrkit-1.1.9.tar.gz) = ce3c62b98c82f3d524a345a6360d24e1d7ac73d7
Size (cdrkit-1.1.9.tar.gz) = 1430065 bytes
SHA1 (patch-aa) = b83c5b64b957db9f2c0b003b2c6088ca9d17aa9a
SHA1 (patch-ab) = 07e110ec3165c697f80f8fc2dbb104863f2bac97
SHA1 (patch-ac) = 21d3b2cce56dadd2195897ed0e4c8ab34e9ac884
SHA1 (patch-ac) = c8d1387ececa092b2e652711228fba9aef612ad5
SHA1 (patch-ad) = 07329be04bef1570c0777d8169b76077ab192794
SHA1 (patch-ae) = b54038cf3dcd3e93d7115c8c6f590d8944d66254
SHA1 (patch-af) = ee12df06d9ca023820d0f2fecbb205b03ae64ccb
SHA1 (patch-ag) = 4107264722dc7985d31a1e4ad49196ca01a6f8a1
SHA1 (patch-ah) = af9379e9690808fe7a3adc59c16a9548b9941b9f
SHA1 (patch-ai) = f4c2c6e52e29c3fb8b00150504c58f82ce9dc161
SHA1 (patch-aj) = bba9ac440f040bab9b12c25cffd80e07493d4011

View file

@ -1,9 +1,9 @@
$NetBSD: patch-ac,v 1.1.1.1 2007/07/01 00:26:14 wiz Exp $
$NetBSD: patch-ac,v 1.2 2009/06/07 22:02:24 hasso Exp $
--- 3rd-party/dirsplit/CMakeLists.txt.orig 2006-08-24 17:36:32.000000000 +0000
+++ 3rd-party/dirsplit/CMakeLists.txt
@@ -1,3 +1,3 @@
PROJECT (DIRSPLIT)
PROJECT (DIRSPLIT C)
INSTALL(PROGRAMS dirsplit DESTINATION bin)
-INSTALL(FILES dirsplit.1 DESTINATION share/man/man1)
+INSTALL(FILES dirsplit.1 DESTINATION ${MANSUBDIR}/man1)

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ad,v 1.1 2009/06/07 22:02:24 hasso Exp $
--- include/schily.h.orig
+++ include/schily.h
@@ -116,7 +116,7 @@ extern int fexecl(const char *, FILE *,
extern int fexecle(const char *, FILE *, FILE *, FILE *, const char *, ...);
/* 6th arg not const, fexecv forces av[ac] = NULL */
extern int fexecv(const char *, FILE *, FILE *, FILE *, int, char **);
-extern int fexecve(const char *, FILE *, FILE *, FILE *, char * const *,
+extern int f_execve(const char *, FILE *, FILE *, FILE *, char * const *,
char * const *);
extern int fspawnv(FILE *, FILE *, FILE *, int, char * const *);
extern int fspawnl(FILE *, FILE *, FILE *, const char *, const char *, ...);
@@ -190,7 +190,7 @@ extern int schily_error(const char *, ..
extern char *fillbytes(void *, int, char);
extern char *findbytes(const void *, int, char);
extern int findline(const char *, char, const char *, int, char **, int);
-extern int getline(char *, int);
+extern int get_line(char *, int);
extern int getstr(char *, int);
extern int breakline(char *, char, char **, int);
extern int getallargs(int *, char * const**, const char *, ...);

View file

@ -0,0 +1,27 @@
$NetBSD: patch-ae,v 1.1 2009/06/07 22:02:24 hasso Exp $
--- librols/fexec.c.orig
+++ librols/fexec.c
@@ -170,7 +170,7 @@ fexecle(name, in, out, err, va_alist)
} while (p != NULL);
va_end(args);
- ret = fexecve(name, in, out, err, av, env);
+ ret = f_execve(name, in, out, err, av, env);
if (av != xav)
free(av);
return (ret);
@@ -184,11 +184,11 @@ fexecv(name, in, out, err, ac, av)
char *av[];
{
av[ac] = NULL; /* force list to be null terminated */
- return (fexecve(name, in, out, err, av, environ));
+ return (f_execve(name, in, out, err, av, environ));
}
EXPORT int
-fexecve(name, in, out, err, av, env)
+f_execve(name, in, out, err, av, env)
const char *name;
FILE *in, *out, *err;
char * const av[], * const env[];

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1 2009/06/07 22:02:24 hasso Exp $
--- librols/stdio/fgetline.c.orig
+++ librols/stdio/fgetline.c
@@ -76,7 +76,7 @@ fgetline(f, buf, len)
}
EXPORT int
-getline(buf, len)
+get_line(buf, len)
char *buf;
int len;
{

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ag,v 1.1 2009/06/07 22:02:24 hasso Exp $
--- libusal/scsitransp.c.orig
+++ libusal/scsitransp.c
@@ -301,7 +301,7 @@ usal_yes(char *msg)
printf("%s", msg);
flush();
- if (getline(okbuf, sizeof (okbuf)) == EOF)
+ if (get_line(okbuf, sizeof (okbuf)) == EOF)
exit(EX_BAD);
if (streql(okbuf, "y") || streql(okbuf, "yes") ||
streql(okbuf, "Y") || streql(okbuf, "YES"))

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ah,v 1.1 2009/06/07 22:02:24 hasso Exp $
--- readom/io.c.orig
+++ readom/io.c
@@ -130,7 +130,7 @@ BOOL getvalue(char *s, long *lp, long mi
(*prt)(s, *lp, mini, maxi, dp);
flush();
line[0] = '\0';
- if (getline(line, 80) == EOF)
+ if (get_line(line, 80) == EOF)
exit(EX_BAD);
linep = skipwhite(line);
@@ -178,7 +178,7 @@ again:
vprintf(form, args);
va_end(args);
flush();
- if (getline(okbuf, sizeof(okbuf)) == EOF)
+ if (get_line(okbuf, sizeof(okbuf)) == EOF)
exit(EX_BAD);
if (okbuf[0] == '?') {
printf("Enter 'y', 'Y', 'yes' or 'YES' if you agree with the previous asked question.\n");

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ai,v 1.1 2009/06/07 22:02:24 hasso Exp $
--- readom/readom.c.orig
+++ readom/readom.c
@@ -1605,7 +1605,7 @@ read_generic(SCSI *usalp, parm_t *parmp,
fprintf(stderr, "Copy from SCSI (%d,%d,%d) disk to file\n",
usal_scsibus(usalp), usal_target(usalp), usal_lun(usalp));
fprintf(stderr, "Enter filename [%s]: ", defname); flush();
- (void) getline(filename, sizeof (filename));
+ (void) get_line(filename, sizeof (filename));
}
if (askrange) {
@@ -1772,7 +1772,7 @@ write_disk(SCSI *usalp, parm_t *parmp)
fprintf(stderr, "Copy from file to SCSI (%d,%d,%d) disk\n",
usal_scsibus(usalp), usal_target(usalp), usal_lun(usalp));
fprintf(stderr, "Enter filename [%s]: ", defname); flush();
- (void) getline(filename, sizeof (filename));
+ (void) get_line(filename, sizeof (filename));
fprintf(stderr, "Notice: reading from file always starts at file offset 0.\n");
getlong("Enter starting sector for copy:", &addr, 0L, end-1);

View file

@ -0,0 +1,31 @@
$NetBSD: patch-aj,v 1.1 2009/06/07 22:02:24 hasso Exp $
--- wodim/cue.c.orig
+++ wodim/cue.c
@@ -253,7 +253,7 @@ static char *skipwhite(const char *s);
static char *peekword(void);
static char *lineend(void);
static char *markword(char *delim);
-static char getdelim(void);
+static char get_delim(void);
static char *getnextitem(char *delim);
static char *neednextitem(char *delim);
static char *nextword(void);
@@ -746,7 +746,7 @@ parse_track(track_t trackp[], state_t *s
if (kp == NULL)
cueabort("Unknown filetype '%s'", word);
- if (getdelim() == '/') {
+ if (get_delim() == '/') {
word = needitem();
if (*astol(++word, &secsize) != '\0')
cueabort("Not a number '%s'", word);
@@ -1128,7 +1128,7 @@ linelen--;
}
static char
-getdelim()
+get_delim()
{
return (wordendc);
}