PR pkg/38617: Hasso Tepper: Don't call pthread_create() with NULL as the

first argument in configure. Fixes hang on DragonFlyBSD.
This commit is contained in:
tnn 2008-05-09 10:51:45 +00:00
parent 0b60ce7b5d
commit 6d73eec9ea
2 changed files with 16 additions and 6 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.26 2007/10/10 11:21:52 rillig Exp $
$NetBSD: distinfo,v 1.27 2008/05/09 10:51:45 tnn Exp $
SHA1 (Python-2.1.3.tgz) = 7042a5c5fd60d334c0ac227885d68a4c305713b4
RMD160 (Python-2.1.3.tgz) = d7216480cf884507d97bf7932767871977fc1ccc
@ -18,7 +18,7 @@ SHA1 (patch-bc) = 6566f6cc3394d597ea3d588459f5208f7439df0c
SHA1 (patch-bd) = 1fcff14864fbd52f350f63bec57e2952a4715ca4
SHA1 (patch-be) = e1e5675e8b1059bd7836f8f23382a8305382a91b
SHA1 (patch-bf) = 5a4f05c563d46c66485780c8dd8badac624c4f49
SHA1 (patch-bg) = 2e0733e66681582d36b1470dce50c8e8b43cd083
SHA1 (patch-bg) = 2860e51d5a37ab1850a751b5f86726054d3776d0
SHA1 (patch-bh) = fa0d154bc5e1ccb1d59b2902aa61df8c91d52b2d
SHA1 (patch-bi) = 19e9e7ecba296b6fd955087f0dad85c52dfee058
SHA1 (patch-bj) = 6b860ee6fca483f7360930935d4759fe6c93bdee

View file

@ -1,7 +1,5 @@
$NetBSD: patch-bg,v 1.1 2005/11/08 18:14:49 joerg Exp $
--- configure.orig 2001-12-27 21:55:46.000000000 +0000
+++ configure
--- configure.orig 2001-12-27 23:55:46 +0200
+++ configure 2008-05-09 12:21:21 +0300
@@ -2966,6 +2966,7 @@ then
else
LDSHARED="ld -Bshareable"
@ -55,3 +53,15 @@ $NetBSD: patch-bg,v 1.1 2005/11/08 18:14:49 joerg Exp $
LIBOBJS="$LIBOBJS thread.o"
else
echo "$ac_t""no" 1>&6
@@ -3957,9 +3958,10 @@ else
}
main() {
pthread_attr_t attr;
+ pthread_t thread;
if (pthread_attr_init(&attr)) exit(-1);
if (pthread_attr_setscope(&attr, PTHREAD_SCOPE_SYSTEM)) exit(-1);
- if (pthread_create(NULL, &attr, foo, NULL)) exit(-1);
+ if (pthread_create(&thread, &attr, foo, NULL)) exit(-1);
exit(0);
}
EOF