Use pkginstall framework. Bump PKGREVISION.
This commit is contained in:
parent
0d43c2ae73
commit
6d798fad85
6 changed files with 26 additions and 31 deletions
|
@ -1,9 +0,0 @@
|
|||
# $NetBSD: DEINSTALL,v 1.1.1.1 2004/10/11 16:51:54 abs Exp $
|
||||
|
||||
CHROOTDIR="@CHROOTDIR@"
|
||||
|
||||
case ${STAGE} in
|
||||
DEINSTALL)
|
||||
${RMDIR} ${CHROOTDIR}
|
||||
;;
|
||||
esac
|
|
@ -1,10 +0,0 @@
|
|||
# $NetBSD: INSTALL,v 1.1.1.1 2004/10/11 16:51:54 abs Exp $
|
||||
|
||||
CHROOTDIR="@CHROOTDIR@"
|
||||
|
||||
case ${STAGE} in
|
||||
POST-INSTALL)
|
||||
${MKDIR} ${CHROOTDIR}
|
||||
${CHMOD} 555 ${CHROOTDIR}
|
||||
;;
|
||||
esac
|
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.5 2005/12/29 06:22:04 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2006/02/19 23:08:48 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= whoson-2.03
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= net security
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=whoson/}
|
||||
|
||||
|
@ -10,21 +10,16 @@ MAINTAINER= abs@NetBSD.org
|
|||
HOMEPAGE= http://whoson.sf.net/
|
||||
COMMENT= Check if (dynamic) IP address is connected
|
||||
|
||||
EXDIR= ${PREFIX}/share/examples/whoson
|
||||
CONF_FILES= ${EXDIR}/whoson.conf ${PKG_SYSCONFDIR}/whoson.conf
|
||||
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_LIBTOOL= yes
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
GNU_CONFIGURE= yes
|
||||
WHOSOND_CHROOT?= ${VARBASE}/chroot/whosond
|
||||
CONFIGURE_ARGS+= --with-config="${PKG_SYSCONFDIR}/whoson.conf"
|
||||
|
||||
FILES_SUBST+= CHROOTDIR=${WHOSOND_CHROOT:Q}
|
||||
DEINSTALL_EXTRA_TMPL+= ${.CURDIR}/DEINSTALL
|
||||
INSTALL_EXTRA_TMPL+= ${.CURDIR}/INSTALL
|
||||
|
||||
RCD_SCRIPTS= whosond
|
||||
OWN_DIRS+= ${WHOSOND_CHROOT}
|
||||
EXDIR= ${PREFIX}/share/examples/whoson
|
||||
CONF_FILES= ${EXDIR}/whoson.conf ${PKG_SYSCONFDIR}/whoson.conf
|
||||
|
||||
# Run this here as whoson's 'install' target will install if not present
|
||||
pre-build:
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2005/05/02 20:34:04 reed Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2006/02/19 23:08:48 wiz Exp $
|
||||
include/whoson.h
|
||||
lib/libwhoson.la
|
||||
man/man3/whoson.3
|
||||
|
@ -12,3 +12,5 @@ man/man8/whosond.8
|
|||
sbin/whoson
|
||||
sbin/whosond
|
||||
share/examples/rc.d/whosond
|
||||
share/examples/whoson/whoson.conf
|
||||
@dirrm share/examples/whoson
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2005/02/24 12:14:07 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2006/02/19 23:08:48 wiz Exp $
|
||||
|
||||
SHA1 (whoson-2.03.tar.gz) = 72fbec1d85f9622028fe9d16be4b262da05ca8f1
|
||||
RMD160 (whoson-2.03.tar.gz) = e1bcbf52533e85808ee09f1d8dacb64ba536f123
|
||||
Size (whoson-2.03.tar.gz) = 238133 bytes
|
||||
SHA1 (patch-aa) = 9cc000e2632b1e86393b8678bb241b5d07868c73
|
||||
|
|
16
net/whoson/patches/patch-aa
Normal file
16
net/whoson/patches/patch-aa
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-aa,v 1.1 2006/02/19 23:08:48 wiz Exp $
|
||||
|
||||
--- Makefile.in.orig 2003-08-19 07:22:30.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -898,11 +898,6 @@ uninstall-man: uninstall-man3 uninstall-
|
||||
|
||||
|
||||
install-data-hook:
|
||||
- if test -f $(DEFAULT_CONFIG); then \
|
||||
- $(ECHO) "$(DEFAULT_CONFIG) exists, not overwritten"; \
|
||||
- else \
|
||||
- $(INSTALL_DATA) $(srcdir)/whoson.conf $(DEFAULT_CONFIG); \
|
||||
- fi; \
|
||||
for f in $(MAN3XTRA); do \
|
||||
rm -f $(DESTDIR)$(man3dir)/$$f; \
|
||||
$(LN) $(DESTDIR)$(man3dir)/whoson.3 $(DESTDIR)$(man3dir)/$$f; \
|
Loading…
Reference in a new issue