Changes 3.3.2:
Docs: document ConnOpener::swanSong() better Bug 3329: Quieten orphan Comm::Connection messages Sync TESTDIR names used by testCoss and testUfs with testRock changes. MacOS: reduce the testRock unit test UDS path Bug 3720: SourceLayout: shuffle fd_table definition into fde.h Bug 3794: MacOS: workaround compiler errors and case-insensitivity Polish debugs in cacheability test Bug 3753: Removes the domain from the cache_peer server pconn key Bug 3781: Proxy Authentication not sent to cache_peer Bug 3763: diskd Error: no filename in shm buffer Solaris: Fix xstrto*() function linkages Mentioned creation of diskers in cache_dir rock documentation. Fix coverity scan issue 740457: unsecure temporary file creation Bug 3686: cache_dir max-size default fails Bug 3752: objects that cannot be cached in memory are not cached on disk if cache_dir max-size is used.
This commit is contained in:
parent
3ca0214c05
commit
6e00ac6e97
5 changed files with 6 additions and 76 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.2 2013/02/19 19:22:45 markd Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2013/03/08 17:24:34 adam Exp $
|
||||
|
||||
DISTNAME= squid-3.3.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= squid-3.3.2
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.squid-cache.org/Versions/v3/${PKGVERSION_NOREV:R}/ \
|
||||
${SQUID_MASTER_SITES}
|
||||
|
|
|
@ -1,15 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.2 2013/02/19 19:22:45 markd Exp $
|
||||
$NetBSD: distinfo,v 1.3 2013/03/08 17:24:34 adam Exp $
|
||||
|
||||
SHA1 (squid-3.3.1.tar.xz) = d996c5b49bb244aad69e45c85499c8cb1f2c4716
|
||||
RMD160 (squid-3.3.1.tar.xz) = 1419cc29351a5a784456fb0f447fced59f42f0fd
|
||||
Size (squid-3.3.1.tar.xz) = 2173060 bytes
|
||||
SHA1 (squid-3.3.2.tar.xz) = 52d33662ce64a335f8e0ac4122f85e5163f8613e
|
||||
RMD160 (squid-3.3.2.tar.xz) = 0daa76dcb1f9a1eee2b8609f04e051a4286fbd20
|
||||
Size (squid-3.3.2.tar.xz) = 2174048 bytes
|
||||
SHA1 (patch-configure) = 8e5eb49a8d04c77f3cf9de9390a8992268421cb6
|
||||
SHA1 (patch-errors_Makefile.in) = afbac822ac84d5e1734d55fc625e949ae0b85289
|
||||
SHA1 (patch-helpers_basic_auth_MSNT_Makefile.in) = 74a0379d3ec0c2601dbb62b16df889bf4edcaedf
|
||||
SHA1 (patch-src_DiskIO_DiskDaemon_diskd.cc) = f815c33ba6b11aae2b0e661605e3fd7fc291cbf1
|
||||
SHA1 (patch-src_Makefile.in) = 919797e74c378daad88b5ac1ee7efe6f5f580a33
|
||||
SHA1 (patch-src_acl_DomainData.cc) = 19b223e4c976179f40343074d531434c1ed78b9b
|
||||
SHA1 (patch-src_acl_Url.cc) = 418a4d8bf9600601363c5353e063a5eeced81088
|
||||
SHA1 (patch-src_base_TidyPointer.h) = 93428d26bb2479fc845764a324658eaacd26588e
|
||||
SHA1 (patch-src_ip_Intercept.cc) = 972ad12063bcf3d24704976960f1a71452d0aa87
|
||||
SHA1 (patch-src_store.cc) = 055d98a59103b02a51876a5c8ffed9514954beb4
|
||||
|
|
|
@ -1,36 +0,0 @@
|
|||
$NetBSD: patch-src_DiskIO_DiskDaemon_diskd.cc,v 1.1 2013/02/19 19:22:45 markd Exp $
|
||||
|
||||
------------------------------------------------------------
|
||||
revno: 12497
|
||||
revision-id: squid3@treenet.co.nz-20130214091437-0kf8k09qf1sg8ker
|
||||
parent: squid3@treenet.co.nz-20130214091347-nkfdacfkt0urnwq4
|
||||
fixes bug(s): http://bugs.squid-cache.org/show_bug.cgi?id=3763
|
||||
committer: Amos Jeffries <squid3@treenet.co.nz>
|
||||
branch nick: 3.3
|
||||
timestamp: Thu 2013-02-14 02:14:37 -0700
|
||||
message:
|
||||
Bug 3763: diskd Error: no filename in shm buffer
|
||||
------------------------------------------------------------
|
||||
# Bazaar merge directive format 2 (Bazaar 0.90)
|
||||
# revision_id: squid3@treenet.co.nz-20130214091437-0kf8k09qf1sg8ker
|
||||
# target_branch: http://bzr.squid-cache.org/bzr/squid3/3.3
|
||||
# testament_sha1: 6098b2dbc1bcd0230017a40b0ebd75e375148fec
|
||||
# timestamp: 2013-02-14 09:15:28 +0000
|
||||
# source_branch: http://bzr.squid-cache.org/bzr/squid3/3.3
|
||||
# base_revision_id: squid3@treenet.co.nz-20130214091347-\
|
||||
# nkfdacfkt0urnwq4
|
||||
#
|
||||
# Begin patch
|
||||
=== modified file 'src/DiskIO/DiskDaemon/diskd.cc'
|
||||
--- src/DiskIO/DiskDaemon/diskd.cc 2013-01-02 10:09:54 +0000
|
||||
+++ src/DiskIO/DiskDaemon/diskd.cc 2013-02-14 09:14:37 +0000
|
||||
@@ -264,7 +264,7 @@
|
||||
|
||||
if (s->shm_offset > -1)
|
||||
buf = shmbuf + s->shm_offset;
|
||||
- else {
|
||||
+ else if (r->mtype != _MQD_CLOSE) {
|
||||
fprintf(stderr, "%d UNLNK id(%u) Error: no filename in shm buffer\n", (int) mypid, s->id);
|
||||
return;
|
||||
}
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_acl_DomainData.cc,v 1.1 2013/02/10 18:16:53 adam Exp $
|
||||
|
||||
On case-insensitive file systems acl/Url.h might get included.
|
||||
|
||||
--- src/acl/DomainData.cc.orig 2013-02-10 13:30:18.000000000 +0000
|
||||
+++ src/acl/DomainData.cc
|
||||
@@ -38,7 +38,7 @@
|
||||
#include "cache_cf.h"
|
||||
#include "Debug.h"
|
||||
#include "wordlist.h"
|
||||
-#include "URL.h"
|
||||
+#include "../URL.h"
|
||||
|
||||
template<class T>
|
||||
inline void
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_acl_Url.cc,v 1.1 2013/02/10 18:16:53 adam Exp $
|
||||
|
||||
On case-insensitive file systems acl/Url.h might get included.
|
||||
|
||||
--- src/acl/Url.cc.orig 2013-02-10 13:41:53.000000000 +0000
|
||||
+++ src/acl/Url.cc
|
||||
@@ -37,7 +37,7 @@
|
||||
#include "acl/Checklist.h"
|
||||
#include "acl/RegexData.h"
|
||||
#include "rfc1738.h"
|
||||
-#include "URL.h"
|
||||
+#include "../URL.h"
|
||||
|
||||
int
|
||||
ACLUrlStrategy::match (ACLData<char const *> * &data, ACLFilledChecklist *checklist)
|
Loading…
Reference in a new issue