fixes destdir installation on Cygwin.

This commit is contained in:
obache 2013-03-03 11:02:56 +00:00
parent 369827c875
commit 6e42559d9e
2 changed files with 42 additions and 4 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.92 2013/01/24 18:23:51 apb Exp $
$NetBSD: distinfo,v 1.93 2013/03/03 11:02:56 obache Exp $
SHA1 (perl-5.16.2.tar.gz) = 9e20e38e3460ebbac895341fd70a02189d03a490
RMD160 (perl-5.16.2.tar.gz) = 84f0233ac48059b4636661b023dd8a3389f9ae64
Size (perl-5.16.2.tar.gz) = 16933974 bytes
SHA1 (patch-aa) = 9066746c6e6ed0d58962f52de1ae773e210cfcb5
SHA1 (patch-ab) = a9c674c5b09700d13fa885f11a3525d6d54899b5
SHA1 (patch-ab) = 05a01a31bad4735d44e09dd5760bb89bce26aa1f
SHA1 (patch-ac) = cd918ae7aedddfcd3d555a1d1388c4c8719ccd12
SHA1 (patch-ah) = f66b496ba8f7b7d3e5a1f0c6f03d051a652f426e
SHA1 (patch-aq) = 4bf5a76f0277b0939b2ca7720f4bb045a788b5cc

View file

@ -1,7 +1,19 @@
$NetBSD: patch-ab,v 1.17 2012/10/03 19:59:47 adam Exp $
$NetBSD: patch-ab,v 1.18 2013/03/03 11:02:56 obache Exp $
--- installperl.orig 2012-08-03 17:35:26.000000000 +0000
* fixes packlist with destdir installation on Cygwin.
* XXX
--- installperl.orig 2012-10-26 02:44:15.000000000 +0000
+++ installperl
@@ -275,7 +275,7 @@ if (($Is_W32 and ! $Is_NetWare) or $Is_C
safe_unlink("$installbin/$perldll");
copy("$perldll", "$installbin/$perldll");
chmod(0755, "$installbin/$perldll");
- $packlist->{"$installbin/$perldll"} = { type => 'file' };
+ $packlist->{"$Config{installbin}/$perldll"} = { type => 'file' };
} # if (($Is_W32 and ! $Is_NetWare) or $Is_Cygwin)
# First we install the version-numbered executables.
@@ -346,7 +346,6 @@ $do_installprivlib = 0 if $versiononly &
mkpath($installprivlib, $opts{verbose}, 0777);
mkpath($installarchlib, $opts{verbose}, 0777);
@ -10,3 +22,29 @@ $NetBSD: patch-ab,v 1.17 2012/10/03 19:59:47 adam Exp $
if (-d 'lib') {
find({no_chdir => 1, wanted => \&installlib}, 'lib')
@@ -367,21 +366,22 @@ if ($Is_VMS) { # We did core file selec
elsif ($Is_Cygwin) { # On Cygwin symlink it to CORE to make Makefile happy
@corefiles = <*.h libperl*.* perl*$Config{lib_ext}>;
my $coredll = "$installarchlib/CORE/$libperl";
+ my $instcoredll = "$Config{installarchlib}/CORE/$libperl";
safe_unlink($coredll);
( $Config{'d_link'} eq 'define' &&
eval {
CORE::link("$installbin/$libperl", $coredll);
- $packlist->{$coredll} = { from => "$installbin/$libperl",
+ $packlist->{$instcoredll} = { from => "$Config{installbin}/$libperl",
type => 'link' };
}
) ||
eval {
symlink("$installbin/$libperl", $coredll);
- $packlist->{$coredll} = { from => "$installbin/$libperl",
+ $packlist->{$instcoredll} = { from => "$Config{installbin}/$libperl",
type => 'link' };
} ||
( copy("$installbin/$libperl", $coredll) &&
- push(@corefiles, $coredll)
+ push(@corefiles, $instcoredll)
)
} else {
# [als] hard-coded 'libperl' name... not good!