Fix build on linux with gcc4.5

This commit is contained in:
markd 2011-01-30 01:59:59 +00:00
parent 1c99381ff9
commit 6e56a369fc
3 changed files with 17 additions and 9 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.30 2010/01/24 17:11:19 heinz Exp $
# $NetBSD: Makefile,v 1.31 2011/01/30 01:59:59 markd Exp $
#
DISTNAME= dvd+rw-tools-7.1
@ -17,7 +17,7 @@ DEPENDS+= {cdrtools-[1-9]*,cdrtools-ossdvd-[0-9]*}:../../sysutils/cdrtools
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
USE_LANGUAGES= c c++
USE_TOOLS+= m4
USE_TOOLS+= m4 gmake
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.18 2008/04/23 15:35:50 wiz Exp $
$NetBSD: distinfo,v 1.19 2011/01/30 01:59:59 markd Exp $
SHA1 (dvd+rw-tools-7.1.tar.gz) = 6400e013934ff589b4b224eced03fd9f42ed719b
RMD160 (dvd+rw-tools-7.1.tar.gz) = a98367861335ecf9acea86a6b44ad68636bfb5c4
Size (dvd+rw-tools-7.1.tar.gz) = 140846 bytes
SHA1 (patch-aa) = fe1382ff484651bc54b0729f182ec31c6e0b84b9
SHA1 (patch-aa) = 6b50e4ed73a1617b5bc25d05d313d0c24fa7162d
SHA1 (patch-ab) = aa138938229a5c6f899fbbfe04242cda415b4e4b
SHA1 (patch-ac) = d2a3b223ce4398ebb47a7daee365e162839c7997
SHA1 (patch-ad) = d1dadb58b1e6e51f0833aa6f82e3e9d62c5daeb8

View file

@ -1,6 +1,6 @@
$NetBSD: patch-aa,v 1.7 2007/06/08 08:07:05 wiz Exp $
$NetBSD: patch-aa,v 1.8 2011/01/30 01:59:59 markd Exp $
--- transport.hxx.orig 2006-09-23 11:29:07.000000000 +0000
--- transport.hxx.orig 2008-03-01 10:34:43.000000000 +0000
+++ transport.hxx
@@ -6,7 +6,7 @@
// For further details see http://fy.chalmers.se/~appro/linux/DVD+RW/
@ -21,7 +21,15 @@ $NetBSD: patch-aa,v 1.7 2007/06/08 08:07:05 wiz Exp $
inline long getmsecs()
{ struct timeval tv;
@@ -446,7 +449,11 @@ public:
@@ -140,6 +143,7 @@ extern "C" char *plusminus_locale()
#if defined(__linux)
#include <sys/ioctl.h>
+#include <limits.h>
#include <linux/cdrom.h>
#include <mntent.h>
#include <sys/wait.h>
@@ -454,7 +458,11 @@ public:
// mounted, so that it could as well just return 0;
int umount(int f=-1)
{ struct stat fsb,msb;
@ -33,7 +41,7 @@ $NetBSD: patch-aa,v 1.7 2007/06/08 08:07:05 wiz Exp $
int ret=0,mntsize,i;
if (f==-1) f=fd;
@@ -475,7 +482,7 @@ public:
@@ -483,7 +491,7 @@ public:
{ return 1; }
};
@ -42,7 +50,7 @@ $NetBSD: patch-aa,v 1.7 2007/06/08 08:07:05 wiz Exp $
#include <sys/ioctl.h>
#include <camlib.h>
@@ -642,7 +649,11 @@ public:
@@ -650,7 +658,11 @@ public:
}
int umount(int f=-1)
{ struct stat fsb,msb;