Interix uses WinSock, which does not provide SO_RCVTIMEO nor SO_SNDTIMEO.

Skip these options when building on Interix.
This commit is contained in:
ben 2006-01-01 17:02:21 +00:00
parent e5403873c3
commit 6e62055809
3 changed files with 21 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.12 2005/08/16 10:59:08 adam Exp $
# $NetBSD: Makefile,v 1.13 2006/01/01 17:02:21 ben Exp $
DISTNAME= msmtp-1.4.4
CATEGORIES= mail
@ -15,6 +15,11 @@ EGDIR= ${PREFIX}/share/examples/msmtp
INFO_FILES= msmtp.info
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "Interix"
CPPFLAGS+= -D__WINSOCK
.endif
.include "options.mk"
post-install:

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.9 2005/08/16 10:59:08 adam Exp $
$NetBSD: distinfo,v 1.10 2006/01/01 17:02:21 ben Exp $
SHA1 (msmtp-1.4.4.tar.bz2) = 2b8437bb613a4054f51e94f4a6a4784b2abe3458
RMD160 (msmtp-1.4.4.tar.bz2) = c83018a31815e031cd1b34bceb71862fb7a5399f
Size (msmtp-1.4.4.tar.bz2) = 480904 bytes
SHA1 (patch-aa) = bd0cb9fe4282b6a8193b38c883d7f7b1b46cd222

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.3 2006/01/01 17:02:21 ben Exp $
--- src/net.c.orig Sun Aug 14 13:13:06 2005
+++ src/net.c
@@ -325,7 +325,7 @@ void net_set_io_timeout(int socket, int
* en-us/winsock/winsock/setsockopt_2.asp
* We activate these timeouts only for Windows systems that also have
* getaddrinfo(), which means XP or newer, to work around this problem. */
-#if defined __MINGW32__ && !defined HAVE_GETADDRINFO
+#if (defined __MINGW32__ && !defined HAVE_GETADDRINFO) || defined __WINSOCK
/* do nothing */
#else
struct timeval tv;