add fix for SA36037, bump PKGREVISION. XXX: not tested
This commit is contained in:
parent
f362c79fa9
commit
6e84cc7e91
3 changed files with 15 additions and 3 deletions
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.21 2009/07/22 09:01:39 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.22 2009/08/09 12:33:14 kefren Exp $
|
||||
#
|
||||
|
||||
DISTNAME= vlc-${VLC_VER}
|
||||
PKGNAME= vlc08-${VLC_VER}
|
||||
VLC_VER= 0.8.6i
|
||||
PKGREVISION= 4
|
||||
PKGREVISION= 5
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://download.videolan.org/pub/videolan/vlc/${VLC_VER}/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,9 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.8 2009/07/02 10:15:47 sborrill Exp $
|
||||
$NetBSD: distinfo,v 1.9 2009/08/09 12:33:14 kefren Exp $
|
||||
|
||||
SHA1 (vlc-0.8.6i.tar.bz2) = 4c6f45dffe3a8309ce201897040dc1f82b9cde99
|
||||
RMD160 (vlc-0.8.6i.tar.bz2) = a5da4e1e0980594c678c04016491c8a373df4017
|
||||
Size (vlc-0.8.6i.tar.bz2) = 11786172 bytes
|
||||
SHA1 (patch-aa) = 497a83bb0f1e2c095a81aa84115e66b56dd47e2c
|
||||
SHA1 (patch-ab) = df3a58d361ad0767dab78f7fae7891aee6143c6c
|
||||
SHA1 (patch-mmstu.c) = ef4bed6fb5871790bb9198dad4961384f3e38d16
|
||||
SHA1 (patch-mmstu.h) = a11be24360948bcd8ca32bd7d01020e34c0801ad
|
||||
SHA1 (patch-tta.c) = 923852b9aedeb75eed052e532ce5ddf50ab19951
|
||||
|
|
11
multimedia/vlc08/patches/patch-ab
Normal file
11
multimedia/vlc08/patches/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- modules/access/rtsp/real.c.orig 2009-08-09 15:28:43.000000000 +0300
|
||||
+++ modules/access/rtsp/real.c 2009-08-09 15:29:26.000000000 +0300
|
||||
@@ -598,6 +598,8 @@ int real_get_rdt_chunk(rtsp_client_t *rt
|
||||
|
||||
int n;
|
||||
rmff_dump_pheader(ph, *buffer);
|
||||
+ if (ph->length < 12)
|
||||
+ return 0;
|
||||
n=rtsp_read_data(rtsp_session, *buffer + 12, ph->length - 12);
|
||||
return (n <= 0) ? 0 : n+12;
|
||||
}
|
Loading…
Reference in a new issue