disable some linux specific hack which tries to import "libc.so.6"

and "libmpcdec.so.3" - this is going to fail on other platforms
obviously, bump PKGREVISION
This commit is contained in:
drochner 2009-02-11 18:35:19 +00:00
parent 6bc62118eb
commit 6e86650787
3 changed files with 16 additions and 3 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.13 2009/02/09 22:56:21 joerg Exp $
# $NetBSD: Makefile,v 1.14 2009/02/11 18:35:19 drochner Exp $
#
DISTNAME= exaile_0.2.14
PKGNAME= exaile-0.2.14
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.exaile.org/files/

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.9 2009/01/20 21:49:23 drochner Exp $
$NetBSD: distinfo,v 1.10 2009/02/11 18:35:19 drochner Exp $
SHA1 (exaile_0.2.14.tar.gz) = 3442867ae6f5116f87eb2488da73cf6d23442f52
RMD160 (exaile_0.2.14.tar.gz) = 04919b4109a50e3e93d14492f3810694e6a07c4d
Size (exaile_0.2.14.tar.gz) = 1527168 bytes
SHA1 (patch-aa) = 168a55605cbd98baf8294d2e9661f4d24be31349
SHA1 (patch-ab) = 46d55fb1e5175aafc9d414bf17b045f1eaf3b3bb
SHA1 (patch-ac) = e771f8617eef89300594bce09826de27393dbb46

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ac,v 1.3 2009/02/11 18:35:19 drochner Exp $
--- xl/media/mpc.py.orig 2008-10-06 18:25:24.000000000 +0200
+++ xl/media/mpc.py
@@ -16,6 +16,7 @@ TAG_TRANSLATION = {
# this code taken from quodlibet
try:
+ raise ImportError
import ctypes
_libc = ctypes.cdll.LoadLibrary("libc.so.6")
_mpcdec = ctypes.cdll.LoadLibrary("libmpcdec.so.3")