Update to 1.1.0:
Changes in 1.1.0 since 1.0.2: * Fixed crash with invalid <Name> tag in a menu. * Added new API menu_cache_app_get_generic_name() to get generic name for application. * Fixed potential access violation, use runtime user dir instead of tmp dir. It limits libmenu-cache compatibility to menu-cached >= 0.7.0. * Directory $XDG_DATA_HOME/applications will be created if it does not exist so it will be monitored in any case. * Fixed issue when subdirectories added would be skipped in monitoring. * Fixed potential file descriptors leak. * Reduced inactivity timer to 6 seconds (from 600 seconds). * Fixed an issue with multiple daemons started: test if daemon is already running on socket before killing old socket file. * Fixed 100% CPU load by menu-cached due to invalid dup2() call. Changes in 1.0.2 since 1.0.1: * Fixed crash in menu-cached if cache regeneration fails. * Fixed 100% CPU load by menu-cached in some rare conditions. * Invalid empty <DefaultLayout> should be ignored, see specification. * Fixed crash in menu-cache-gen on <MergeFile type="parent"/> if no file to merge found. * Fixed showing empty Other menu in some cases. * The option --disable-debug is now default, instead of --enable-debug.
This commit is contained in:
parent
4872d45761
commit
6e90578fff
3 changed files with 12 additions and 13 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.3 2016/05/22 22:12:40 youri Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2018/05/22 16:03:00 youri Exp $
|
||||
#
|
||||
|
||||
DISTNAME= menu-cache-1.0.1
|
||||
DISTNAME= menu-cache-1.1.0
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=lxde/}
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
@ -9,7 +9,6 @@ EXTRACT_SUFX= .tar.xz
|
|||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://lxde.sourceforge.net/
|
||||
COMMENT= Cache for freedesktop.org menu spec
|
||||
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.4 2016/05/22 22:11:43 youri Exp $
|
||||
$NetBSD: distinfo,v 1.5 2018/05/22 16:03:00 youri Exp $
|
||||
|
||||
SHA1 (menu-cache-1.0.1.tar.xz) = 58862c665f2ae56870a9937cdcd643674b2ac8ba
|
||||
RMD160 (menu-cache-1.0.1.tar.xz) = 6cd157b86f30869cc95477e9d163d446a4a88abe
|
||||
SHA512 (menu-cache-1.0.1.tar.xz) = 5de4bf99ab5a511da6781d54b03349cc0232b379a73f9f9c328fb9aed6ec03558a9adda85be1fbbe53d94669d07a5196929ab67cd3291de7aae59f587afda3a3
|
||||
Size (menu-cache-1.0.1.tar.xz) = 262508 bytes
|
||||
SHA1 (patch-menu-cache-daemon_menu-cached.c) = 57c082221d72e9f7a0f59e873ae1ec78be68b293
|
||||
SHA1 (menu-cache-1.1.0.tar.xz) = 01e6035aa1fe76d7047bdec235254aa5ce17394a
|
||||
RMD160 (menu-cache-1.1.0.tar.xz) = 0cf2f2b41847087189102373f496b63aa7841b9d
|
||||
SHA512 (menu-cache-1.1.0.tar.xz) = e4c6619ade7b9a1b97c1366bb94dffb9975be5664b193cf0c69cf9470ef7ae19bda3390d04d98ee9a5b1658ec48aa5c83508c26c347af689161ee67c076b3c9e
|
||||
Size (menu-cache-1.1.0.tar.xz) = 265524 bytes
|
||||
SHA1 (patch-menu-cache-daemon_menu-cached.c) = b7a9f80313c2265906bcf98ff369c595b141a53f
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
$NetBSD: patch-menu-cache-daemon_menu-cached.c,v 1.1 2016/04/28 14:57:46 youri Exp $
|
||||
$NetBSD: patch-menu-cache-daemon_menu-cached.c,v 1.2 2018/05/22 16:03:00 youri Exp $
|
||||
|
||||
Fix SunOS build.
|
||||
|
||||
--- menu-cache-daemon/menu-cached.c.orig 2012-11-14 08:07:36.000000000 +0000
|
||||
--- menu-cache-daemon/menu-cached.c.orig 2017-11-02 18:57:27.000000000 +0000
|
||||
+++ menu-cache-daemon/menu-cached.c
|
||||
@@ -28,6 +28,7 @@
|
||||
@@ -33,6 +33,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <fcntl.h>
|
||||
#include <glib.h>
|
||||
#include <glib/gstdio.h>
|
||||
#include <gio/gio.h>
|
||||
#include <sys/types.h>
|
||||
|
|
Loading…
Reference in a new issue