Import rsyslog-8.4.0 as sysutils/rsyslog* (based on wip/rsyslog8).
Rsyslog is an enhanced syslogd supporting, among others, MySQL, PostgreSQL, failover log destinations, syslog/tcp, fine grain output format control, high precision timestamps, queued operations and the ability to filter on any message part. It is quite compatible to stock sysklogd and can be used as a drop-in replacement.
This commit is contained in:
parent
f34d77450f
commit
6ecf8e9bd8
39 changed files with 583 additions and 0 deletions
1
sysutils/rsyslog-dbi/DESCR
Normal file
1
sysutils/rsyslog-dbi/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
rsyslog module for logging into DBI supported databases.
|
16
sysutils/rsyslog-dbi/Makefile
Normal file
16
sysutils/rsyslog-dbi/Makefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: Makefile,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
#
|
||||
|
||||
RSYSLOG_MOD= dbi
|
||||
PKGNAME= ${DISTNAME:S/rsyslog/rsyslog-${RSYSLOG_MOD}/}
|
||||
|
||||
DEPENDS+= rsyslog>=${PKGVERSION_NOREV}:../../sysutils/rsyslog
|
||||
|
||||
.include "../../sysutils/rsyslog/Makefile.common"
|
||||
|
||||
CONFIGURE_ARGS+= --enable-libdbi
|
||||
|
||||
BUILD_DIRS= plugins/omlibdbi
|
||||
|
||||
.include "../../databases/libdbi/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
sysutils/rsyslog-dbi/PLIST
Normal file
2
sysutils/rsyslog-dbi/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
lib/rsyslog/omlibdbi.la
|
2
sysutils/rsyslog-gnutls/DESCR
Normal file
2
sysutils/rsyslog-gnutls/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
rsyslog module for TLS encrypted TCP logging (based on current
|
||||
syslog-transport-tls internet drafts).
|
26
sysutils/rsyslog-gnutls/Makefile
Normal file
26
sysutils/rsyslog-gnutls/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# $NetBSD: Makefile,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
#
|
||||
|
||||
RSYSLOG_MOD= gnutls
|
||||
PKGNAME= ${DISTNAME:S/rsyslog/rsyslog-${RSYSLOG_MOD}/}
|
||||
|
||||
DEPENDS+= rsyslog>=${PKGVERSION_NOREV}:../../sysutils/rsyslog
|
||||
|
||||
.include "../../sysutils/rsyslog/Makefile.common"
|
||||
|
||||
CONFIGURE_ARGS+= --enable-gnutls
|
||||
|
||||
BUILD_DIRS= compat runtime
|
||||
|
||||
INSTALLATION_DIRS+= lib/rsyslog
|
||||
|
||||
do-install:
|
||||
${INSTALL_LIB} ${WRKSRC}/runtime/.libs/lmnsd_gtls.so \
|
||||
${DESTDIR}${PREFIX}/lib/rsyslog/
|
||||
${INSTALL_LIB} ${WRKSRC}/runtime/.libs/lmnsd_gtls.lai \
|
||||
${DESTDIR}${PREFIX}/lib/rsyslog/lmnsd_gtls.la
|
||||
${INSTALL_DATA} ${WRKSRC}/runtime/.libs/lmnsd_gtls.a \
|
||||
${DESTDIR}${PREFIX}/lib/rsyslog/
|
||||
|
||||
.include "../../security/gnutls/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
sysutils/rsyslog-gnutls/PLIST
Normal file
2
sysutils/rsyslog-gnutls/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
lib/rsyslog/lmnsd_gtls.la
|
2
sysutils/rsyslog-gssapi/DESCR
Normal file
2
sysutils/rsyslog-gssapi/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
rsyslog module with support to receive syslog messages from the
|
||||
network protected via Kerberos 5 encryption and authentication.
|
27
sysutils/rsyslog-gssapi/Makefile
Normal file
27
sysutils/rsyslog-gssapi/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# $NetBSD: Makefile,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
#
|
||||
|
||||
RSYSLOG_MOD= gssapi
|
||||
PKGNAME= ${DISTNAME:S/rsyslog/rsyslog-${RSYSLOG_MOD}/}
|
||||
|
||||
DEPENDS+= rsyslog>=${PKGVERSION_NOREV}:../../sysutils/rsyslog
|
||||
|
||||
KRB5_ACCEPTED= mit-krb5
|
||||
|
||||
.include "../../sysutils/rsyslog/Makefile.common"
|
||||
|
||||
CONFIGURE_ARGS+= --enable-gssapi-krb5
|
||||
|
||||
BUILD_DIRS= . plugins/imgssapi plugins/omgssapi
|
||||
INSTALL_DIRS= plugins/imgssapi plugins/omgssapi
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/.libs/lmgssutil.a \
|
||||
${DESTDIR}${PREFIX}/lib/rsyslog/
|
||||
${INSTALL_LIB} ${WRKSRC}/.libs/lmgssutil.so \
|
||||
${DESTDIR}${PREFIX}/lib/rsyslog/
|
||||
${INSTALL_LIB} ${WRKSRC}/.libs/lmgssutil.lai \
|
||||
${DESTDIR}${PREFIX}/lib/rsyslog/lmgssutil.la
|
||||
|
||||
.include "../../mk/krb5.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
4
sysutils/rsyslog-gssapi/PLIST
Normal file
4
sysutils/rsyslog-gssapi/PLIST
Normal file
|
@ -0,0 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
lib/rsyslog/imgssapi.la
|
||||
lib/rsyslog/lmgssutil.la
|
||||
lib/rsyslog/omgssapi.la
|
2
sysutils/rsyslog-libgcrypt/DESCR
Normal file
2
sysutils/rsyslog-libgcrypt/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
rsyslog module for log file encryption using libgcrypt and
|
||||
a rsgtutil utility to manage the files.
|
30
sysutils/rsyslog-libgcrypt/Makefile
Normal file
30
sysutils/rsyslog-libgcrypt/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# $NetBSD: Makefile,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
#
|
||||
|
||||
RSYSLOG_MOD= libgcrypt
|
||||
PKGNAME= ${DISTNAME:S/rsyslog/rsyslog-${RSYSLOG_MOD}/}
|
||||
|
||||
DEPENDS+= rsyslog>=${PKGVERSION_NOREV}:../../sysutils/rsyslog
|
||||
|
||||
.include "../../sysutils/rsyslog/Makefile.common"
|
||||
|
||||
CONFIGURE_ARGS+= --enable-libgcrypt
|
||||
|
||||
BUILD_DIRS= compat grammar runtime tools
|
||||
|
||||
INSTALLATION_DIRS+= bin lib/rsyslog ${PKGMANDIR}/man1
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/runtime/.libs/lmcry_gcry.a \
|
||||
${DESTDIR}${PREFIX}/lib/rsyslog/
|
||||
${INSTALL_LIB} ${WRKSRC}/runtime/.libs/lmcry_gcry.so \
|
||||
${DESTDIR}${PREFIX}/lib/rsyslog/
|
||||
${INSTALL_LIB} ${WRKSRC}/runtime/.libs/lmcry_gcry.lai \
|
||||
${DESTDIR}${PREFIX}/lib/rsyslog/lmcry_gcry.la
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/tools/rscryutil \
|
||||
${DESTDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/tools/rscryutil.1 \
|
||||
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
|
||||
|
||||
.include "../../security/libgcrypt/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
4
sysutils/rsyslog-libgcrypt/PLIST
Normal file
4
sysutils/rsyslog-libgcrypt/PLIST
Normal file
|
@ -0,0 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
bin/rscryutil
|
||||
lib/rsyslog/lmcry_gcry.la
|
||||
man/man1/rscryutil.1
|
1
sysutils/rsyslog-mysql/DESCR
Normal file
1
sysutils/rsyslog-mysql/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
rsyslog module for logging into MySQL databases.
|
21
sysutils/rsyslog-mysql/Makefile
Normal file
21
sysutils/rsyslog-mysql/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: Makefile,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
#
|
||||
|
||||
RSYSLOG_MOD= mysql
|
||||
PKGNAME= ${DISTNAME:S/rsyslog/rsyslog-${RSYSLOG_MOD}/}
|
||||
|
||||
DEPENDS+= rsyslog>=${PKGVERSION_NOREV}:../../sysutils/rsyslog
|
||||
|
||||
.include "../../sysutils/rsyslog/Makefile.common"
|
||||
|
||||
CONFIGURE_ARGS+= --enable-mysql
|
||||
|
||||
BUILD_DIRS= plugins/ommysql
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${DESTDIR}${EGDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/plugins/ommysql/createDB.sql \
|
||||
${DESTDIR}${EGDIR}/createDB-mysql.sql
|
||||
|
||||
.include "../../mk/mysql.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
sysutils/rsyslog-mysql/PLIST
Normal file
3
sysutils/rsyslog-mysql/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
lib/rsyslog/ommysql.la
|
||||
share/examples/rsyslog/createDB-mysql.sql
|
1
sysutils/rsyslog-pgsql/DESCR
Normal file
1
sysutils/rsyslog-pgsql/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
rsyslog module for logging into PostgreSQL databases.
|
21
sysutils/rsyslog-pgsql/Makefile
Normal file
21
sysutils/rsyslog-pgsql/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: Makefile,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
#
|
||||
|
||||
RSYSLOG_MOD= pgsql
|
||||
PKGNAME= ${DISTNAME:S/rsyslog/rsyslog-${RSYSLOG_MOD}/}
|
||||
|
||||
DEPENDS+= rsyslog>=${PKGVERSION_NOREV}:../../sysutils/rsyslog
|
||||
|
||||
.include "../../sysutils/rsyslog/Makefile.common"
|
||||
|
||||
CONFIGURE_ARGS+= --enable-pgsql
|
||||
|
||||
BUILD_DIRS+= plugins/ompgsql
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${DESTDIR}${EGDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/plugins/ompgsql/createDB.sql \
|
||||
${DESTDIR}${EGDIR}/createDB-pgsql.sql
|
||||
|
||||
.include "../../mk/pgsql.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
sysutils/rsyslog-pgsql/PLIST
Normal file
3
sysutils/rsyslog-pgsql/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
lib/rsyslog/ompgsql.la
|
||||
share/examples/rsyslog/createDB-pgsql.sql
|
1
sysutils/rsyslog-rabbitmq/DESCR
Normal file
1
sysutils/rsyslog-rabbitmq/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
rsyslog module for sending syslog messages into RabbitMQ server.
|
16
sysutils/rsyslog-rabbitmq/Makefile
Normal file
16
sysutils/rsyslog-rabbitmq/Makefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: Makefile,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
#
|
||||
|
||||
RSYSLOG_MOD= rabbitmq
|
||||
PKGNAME= ${DISTNAME:S/rsyslog/rsyslog-${RSYSLOG_MOD}/}
|
||||
|
||||
DEPENDS+= rsyslog>=${PKGVERSION_NOREV}:../../sysutils/rsyslog
|
||||
|
||||
.include "../../sysutils/rsyslog/Makefile.common"
|
||||
|
||||
CONFIGURE_ARGS+= --enable-omrabbitmq
|
||||
|
||||
BUILD_DIRS= plugins/omrabbitmq
|
||||
|
||||
.include "../../net/rabbitmq-c/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
sysutils/rsyslog-rabbitmq/PLIST
Normal file
2
sysutils/rsyslog-rabbitmq/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
lib/rsyslog/omrabbitmq.la
|
1
sysutils/rsyslog-snmp/DESCR
Normal file
1
sysutils/rsyslog-snmp/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
rsyslog module for sending syslog messages as SNMPv1 & v2c traps.
|
16
sysutils/rsyslog-snmp/Makefile
Normal file
16
sysutils/rsyslog-snmp/Makefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: Makefile,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
#
|
||||
|
||||
RSYSLOG_MOD= snmp
|
||||
PKGNAME= ${DISTNAME:S/rsyslog/rsyslog-${RSYSLOG_MOD}/}
|
||||
|
||||
DEPENDS+= rsyslog>=${PKGVERSION_NOREV}:../../sysutils/rsyslog
|
||||
|
||||
.include "../../sysutils/rsyslog/Makefile.common"
|
||||
|
||||
CONFIGURE_ARGS+= --enable-snmp
|
||||
|
||||
BUILD_DIRS= plugins/mmsnmptrapd plugins/omsnmp
|
||||
|
||||
.include "../../net/net-snmp/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
sysutils/rsyslog-snmp/PLIST
Normal file
3
sysutils/rsyslog-snmp/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
lib/rsyslog/mmsnmptrapd.la
|
||||
lib/rsyslog/omsnmp.la
|
6
sysutils/rsyslog/DESCR
Normal file
6
sysutils/rsyslog/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
Rsyslog is an enhanced syslogd supporting, among others, MySQL,
|
||||
PostgreSQL, failover log destinations, syslog/tcp, fine grain
|
||||
output format control, high precision timestamps, queued operations
|
||||
and the ability to filter on any message part. It is quite
|
||||
compatible to stock sysklogd and can be used as a drop-in
|
||||
replacement.
|
57
sysutils/rsyslog/Makefile
Normal file
57
sysutils/rsyslog/Makefile
Normal file
|
@ -0,0 +1,57 @@
|
|||
# $NetBSD: Makefile,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
#
|
||||
|
||||
BUILDLINK_DEPMETHOD.libestr= full
|
||||
BUILDLINK_DEPMETHOD.liblogging= full
|
||||
BUILDLINK_DEPMETHOD.libuuid= full
|
||||
|
||||
.include "../../sysutils/rsyslog/Makefile.common"
|
||||
|
||||
COMMENT= The enhanced syslogd for Unix
|
||||
|
||||
#.include "options.mk"
|
||||
|
||||
CONFIGURE_ARGS+= --disable-testbench --enable-cached-man-pages \
|
||||
--enable-diagtools --enable-usertools --enable-uuid \
|
||||
--enable-imdiag --enable-imfile --enable-impstats \
|
||||
--enable-mail --enable-mmjsonparse --enable-mmnormalize \
|
||||
--enable-omstdout
|
||||
|
||||
PLIST_VARS+= klog solaris
|
||||
|
||||
.if ${OPSYS} == "SunOS"
|
||||
CONFIGURE_ARGS+= --enable-imsolaris --disable-klog
|
||||
PLIST.solaris= yes
|
||||
RSYSLOG_SYSMOD= imsolaris
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-imsolaris --enable-klog
|
||||
PLIST.klog= yes
|
||||
RSYSLOG_SYSMOD= imklog
|
||||
.endif
|
||||
|
||||
BUILD_DEFS+= VARBASE RSYSLOG_PIDDIR RSYSLOG_WRKDIR
|
||||
RSYSLOG_PIDDIR?= ${VARBASE}/run
|
||||
RSYSLOG_WRKDIR?= ${VARBASE}/lib/rsyslog
|
||||
OWN_DIRS+= ${RSYSLOG_PIDDIR} ${RSYSLOG_WRKDIR}
|
||||
|
||||
SUBST_CLASSES+= paths
|
||||
SUBST_STAGE.paths= pre-configure
|
||||
SUBST_FILES.paths= platform/redhat/rsyslog.conf tools/rsyslog.conf.5
|
||||
SUBST_FILES.paths+= tools/rsyslogd.8 tools/rsyslogd.c tools/syslogd.c
|
||||
SUBST_VARS.paths= RSYSLOG_PIDDIR RSYSLOG_SYSMOD
|
||||
SUBST_SED.paths= -e "s|/etc|${PKG_SYSCONFDIR}|g"
|
||||
SUBST_MESSAGE.paths= Setting default paths and options.
|
||||
|
||||
RCD_SCRIPTS= rsyslogd
|
||||
|
||||
CONF_FILES+= share/examples/rsyslog/rsyslog.conf \
|
||||
${PKG_SYSCONFDIR}/rsyslog.conf
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${DESTDIR}${EGDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/platform/redhat/rsyslog.conf \
|
||||
${DESTDIR}${EGDIR}/rsyslog.conf
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../sysutils/liblognorm/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
47
sysutils/rsyslog/Makefile.common
Normal file
47
sysutils/rsyslog/Makefile.common
Normal file
|
@ -0,0 +1,47 @@
|
|||
# $NetBSD: Makefile.common,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
# used by sysutils/rsyslog/Makefile
|
||||
# used by sysutils/rsyslog-dbi/Makefile
|
||||
# used by sysutils/rsyslog-gnutls/Makefile
|
||||
# used by sysutils/rsyslog-gssapi/Makefile
|
||||
# used by sysutils/rsyslog-libgcrypt/Makefile
|
||||
# used by sysutils/rsyslog-mysql/Makefile
|
||||
# used by sysutils/rsyslog-pgsql/Makefile
|
||||
# used by sysutils/rsyslog-rabbitmq/Makefile
|
||||
# used by sysutils/rsyslog-snmp/Makefile
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
DISTNAME= rsyslog-8.4.0
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.rsyslog.com/files/download/rsyslog/
|
||||
|
||||
MAINTAINER?= filip@joyent.com
|
||||
HOMEPAGE= http://www.rsyslog.com/
|
||||
LICENSE= gnu-gpl-v3
|
||||
COMMENT?= Enhanced syslogd for Unix - the ${RSYSLOG_MOD} module
|
||||
|
||||
DISTINFO_FILE= ${.CURDIR}/../../sysutils/rsyslog/distinfo
|
||||
PATCHDIR= ${.CURDIR}/../../sysutils/rsyslog/patches
|
||||
|
||||
BUILD_DEPENDS+= ${PYPKGPREFIX}-docutils-[0-9]*:../../textproc/py-docutils
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= bison flex pkg-config
|
||||
PYTHON_FOR_BUILD_ONLY= yes
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/rsyslog
|
||||
|
||||
CONFIGURE_ARGS+= --disable-libgcrypt --disable-testbench \
|
||||
--enable-diagtools --enable-usertools
|
||||
|
||||
BUILDLINK_DEPMETHOD.libestr+= build
|
||||
BUILDLINK_DEPMETHOD.liblogging+= build
|
||||
BUILDLINK_DEPMETHOD.libuuid+= build
|
||||
|
||||
.include "../../devel/libestr/buildlink3.mk"
|
||||
.include "../../devel/libuuid/buildlink3.mk"
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
.include "../../sysutils/liblogging/buildlink3.mk"
|
||||
.include "../../textproc/json-c/buildlink3.mk"
|
32
sysutils/rsyslog/PLIST
Normal file
32
sysutils/rsyslog/PLIST
Normal file
|
@ -0,0 +1,32 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
lib/rsyslog/imdiag.la
|
||||
lib/rsyslog/imfile.la
|
||||
${PLIST.klog}lib/rsyslog/imklog.la
|
||||
lib/rsyslog/immark.la
|
||||
lib/rsyslog/impstats.la
|
||||
${PLIST.solaris}lib/rsyslog/imsolaris.la
|
||||
lib/rsyslog/imtcp.la
|
||||
lib/rsyslog/imudp.la
|
||||
lib/rsyslog/imuxsock.la
|
||||
lib/rsyslog/lmnet.la
|
||||
lib/rsyslog/lmnetstrms.la
|
||||
lib/rsyslog/lmnsd_ptcp.la
|
||||
lib/rsyslog/lmregexp.la
|
||||
lib/rsyslog/lmstrmsrv.la
|
||||
lib/rsyslog/lmtcpclt.la
|
||||
lib/rsyslog/lmtcpsrv.la
|
||||
lib/rsyslog/lmzlibw.la
|
||||
lib/rsyslog/mmexternal.la
|
||||
lib/rsyslog/mmjsonparse.la
|
||||
lib/rsyslog/mmnormalize.la
|
||||
lib/rsyslog/ommail.la
|
||||
lib/rsyslog/omstdout.la
|
||||
lib/rsyslog/omtesting.la
|
||||
man/man5/rsyslog.conf.5
|
||||
man/man8/rsyslogd.8
|
||||
sbin/msggen
|
||||
sbin/rsyslog_diag_hostname
|
||||
sbin/rsyslogd
|
||||
sbin/zpipe
|
||||
share/examples/rc.d/rsyslogd
|
||||
share/examples/rsyslog/rsyslog.conf
|
13
sysutils/rsyslog/distinfo
Normal file
13
sysutils/rsyslog/distinfo
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: distinfo,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
|
||||
SHA1 (rsyslog-8.4.0.tar.gz) = 2e0e9f0f53be4abb5587c48d0d93cb2d35d71150
|
||||
RMD160 (rsyslog-8.4.0.tar.gz) = fdced7c26066432f299e763cdaa46b96feef5e8c
|
||||
Size (rsyslog-8.4.0.tar.gz) = 1955549 bytes
|
||||
SHA1 (patch-grammar_lexer.l) = 6c4314b340449af3fce1acecbdfd4e2b4c0328f5
|
||||
SHA1 (patch-platform_redhat_rsyslog.conf) = 775c523e3eae6641b30cc09c4044e46ae87fa7a4
|
||||
SHA1 (patch-plugins_imfile_imfile.c) = 390aa8febed6693bf69bc1c1764521eae0250477
|
||||
SHA1 (patch-plugins_imuxsock_imuxsock.c) = 2516941970ac1b4c42d7a326a2bd824052bc9b0b
|
||||
SHA1 (patch-plugins_mmexternal_mmexternal.c) = 4f5d13c1206f0c5d00458ee93cb0791ac150fc30
|
||||
SHA1 (patch-runtime_msg.c) = e41ab9e291822f44bcc3c420332d2b33fc786f78
|
||||
SHA1 (patch-tools_rsyslogd.c) = 99f63b04195ca7fb753d2900a4d68918a54914f5
|
||||
SHA1 (patch-tools_syslogd.c) = 9244710cd24377d7a36c24148250935f58dee5da
|
23
sysutils/rsyslog/files/rsyslogd.sh
Normal file
23
sysutils/rsyslog/files/rsyslogd.sh
Normal file
|
@ -0,0 +1,23 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: rsyslogd.sh,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
# NetBSD: syslogd,v 1.15 2004/10/11 13:29:52 lukem Exp
|
||||
#
|
||||
|
||||
# PROVIDE: rsyslogd
|
||||
# REQUIRE: mountcritremote sysdb wscons
|
||||
# BEFORE: SERVERS
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="rsyslogd"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/sbin/${name}"
|
||||
pidfile="/var/run/${name}.pid"
|
||||
required_files="@PKG_SYSCONFDIR@/rsyslog.conf"
|
||||
extra_commands="reload"
|
||||
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
33
sysutils/rsyslog/files/smf/manifest.xml
Normal file
33
sysutils/rsyslog/files/smf/manifest.xml
Normal file
|
@ -0,0 +1,33 @@
|
|||
<?xml version="1.0"?>
|
||||
<!DOCTYPE service_bundle SYSTEM "/usr/share/lib/xml/dtd/service_bundle.dtd.1">
|
||||
<service_bundle type="manifest" name="rsyslog">
|
||||
<service name="@SMF_PREFIX@/@SMF_NAME@" type="service" version="1">
|
||||
<create_default_instance enabled="false" />
|
||||
<single_instance />
|
||||
<dependency name="network" grouping="require_all" restart_on="error" type="service">
|
||||
<service_fmri value="svc:/milestone/network:default" />
|
||||
</dependency>
|
||||
<dependency name="filesystem" grouping="require_all" restart_on="error" type="service">
|
||||
<service_fmri value="svc:/system/filesystem/local" />
|
||||
</dependency>
|
||||
<dependency name="system_log" grouping="exclude_all" restart_on="refresh" type="service">
|
||||
<service_fmri value="svc:/system/system-log:default" />
|
||||
</dependency>
|
||||
<exec_method type="method" name="start" exec="@PREFIX@/sbin/rsyslogd" timeout_seconds="60" />
|
||||
<exec_method type="method" name="refresh" exec=":kill -HUP" timeout_seconds="60" />
|
||||
<exec_method type="method" name="stop" exec=":kill" timeout_seconds="60" />
|
||||
<property_group name="startd" type="framework">
|
||||
<propval name="duration" type="astring" value="contract" />
|
||||
<propval name="ignore_error" type="astring" value="core,signal" />
|
||||
</property_group>
|
||||
<property_group name="application" type="application">
|
||||
<propval name="config_file" type="astring" value="@PKG_SYSCONFDIR@/rsyslog.conf" />
|
||||
</property_group>
|
||||
<stability value="Evolving" />
|
||||
<template>
|
||||
<common_name>
|
||||
<loctext xml:lang="C">rsyslog daemon</loctext>
|
||||
</common_name>
|
||||
</template>
|
||||
</service>
|
||||
</service_bundle>
|
23
sysutils/rsyslog/patches/patch-grammar_lexer.l
Normal file
23
sysutils/rsyslog/patches/patch-grammar_lexer.l
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-grammar_lexer.l,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
|
||||
Fix build on BSD.
|
||||
--- grammar/lexer.l.orig 2014-08-18 09:14:06.000000000 +0000
|
||||
+++ grammar/lexer.l
|
||||
@@ -31,7 +31,7 @@
|
||||
%{
|
||||
#include "config.h"
|
||||
#include "parserif.h"
|
||||
-extern char *strdup(char*); /* somehow we do not get this from string.h... */
|
||||
+// extern char *strdup(char*); /* somehow we do not get this from string.h... */
|
||||
%}
|
||||
|
||||
%option noyywrap nodefault case-insensitive yylineno
|
||||
@@ -92,7 +92,7 @@ extern int yydebug;
|
||||
/* somehow, I need these prototype even though the headers are
|
||||
* included. I guess that's some autotools magic I don't understand...
|
||||
*/
|
||||
-#if !defined(__FreeBSD__)
|
||||
+#if !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__OpenBSD__) && !defined(__DragonflyBSD__)
|
||||
int fileno(FILE *stream);
|
||||
#endif
|
||||
|
23
sysutils/rsyslog/patches/patch-platform_redhat_rsyslog.conf
Normal file
23
sysutils/rsyslog/patches/patch-platform_redhat_rsyslog.conf
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-platform_redhat_rsyslog.conf,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
|
||||
Fix sample config file. Auto-select kernel logging module.
|
||||
--- platform/redhat/rsyslog.conf.orig 2014-07-14 12:54:54.000000000 +0000
|
||||
+++ platform/redhat/rsyslog.conf
|
||||
@@ -4,15 +4,14 @@
|
||||
* like we have with the default config. For more advanced
|
||||
* things, RainerScript configuration is suggested.
|
||||
*
|
||||
- * For more information see /usr/share/doc/rsyslog-*/rsyslog_conf.html
|
||||
- * or latest version online at http://www.rsyslog.com/doc/rsyslog_conf.html
|
||||
+ * For more information see http://www.rsyslog.com/doc/rsyslog_conf.html
|
||||
* If you experience problems, see http://www.rsyslog.com/doc/troubleshoot.html
|
||||
*/
|
||||
|
||||
#### MODULES ####
|
||||
|
||||
module(load="imuxsock") # provides support for local system logging (e.g. via logger command)
|
||||
-module(load="imklog") # provides kernel logging support (previously done by rklogd)
|
||||
+module(load="@RSYSLOG_SYSMOD@") # provides kernel logging support
|
||||
#module(load"immark") # provides --MARK-- message capability
|
||||
|
||||
# Provides UDP syslog reception
|
21
sysutils/rsyslog/patches/patch-plugins_imfile_imfile.c
Normal file
21
sysutils/rsyslog/patches/patch-plugins_imfile_imfile.c
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-plugins_imfile_imfile.c,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
|
||||
Avoid unresolved symbol on inotify-less platforms.
|
||||
--- plugins/imfile/imfile.c.orig 2014-07-15 13:34:03.000000000 +0000
|
||||
+++ plugins/imfile/imfile.c
|
||||
@@ -1348,11 +1348,14 @@ BEGINrunInput
|
||||
CODESTARTrunInput
|
||||
DBGPRINTF("imfile: working in %s mode\n",
|
||||
(runModConf->opMode == OPMODE_POLLING) ? "polling" : "inotify");
|
||||
+#if HAVE_INOTIFY_INIT
|
||||
if(runModConf->opMode == OPMODE_POLLING)
|
||||
iRet = doPolling();
|
||||
else
|
||||
iRet = do_inotify();
|
||||
-
|
||||
+#else
|
||||
+ iRet = doPolling();
|
||||
+#endif
|
||||
DBGPRINTF("imfile: terminating upon request of rsyslog core\n");
|
||||
ENDrunInput
|
||||
|
16
sysutils/rsyslog/patches/patch-plugins_imuxsock_imuxsock.c
Normal file
16
sysutils/rsyslog/patches/patch-plugins_imuxsock_imuxsock.c
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-plugins_imuxsock_imuxsock.c,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
|
||||
Define _XPG4_2 on SunOS to pick up CMSG_* macros.
|
||||
|
||||
--- plugins/imuxsock/imuxsock.c.orig 2014-08-18 09:14:06.000000000 +0000
|
||||
+++ plugins/imuxsock/imuxsock.c
|
||||
@@ -25,6 +25,9 @@
|
||||
*
|
||||
* A copy of the GPL can be found in the file "COPYING" in this distribution.
|
||||
*/
|
||||
+#ifdef __sun
|
||||
+#define _XPG4_2
|
||||
+#endif
|
||||
#include "config.h"
|
||||
#include "rsyslog.h"
|
||||
#include <stdlib.h>
|
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-plugins_mmexternal_mmexternal.c,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
|
||||
Fix build on BSD.
|
||||
--- plugins/mmexternal/mmexternal.c.orig 2014-08-18 09:14:06.000000000 +0000
|
||||
+++ plugins/mmexternal/mmexternal.c
|
||||
@@ -31,7 +31,7 @@
|
||||
#include <errno.h>
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
-#include <wait.h>
|
||||
+#include <sys/wait.h>
|
||||
#include <sys/uio.h>
|
||||
#include "conf.h"
|
||||
#include "syslogd-types.h"
|
18
sysutils/rsyslog/patches/patch-runtime_msg.c
Normal file
18
sysutils/rsyslog/patches/patch-runtime_msg.c
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-runtime_msg.c,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
|
||||
Fix build with newer json-c.
|
||||
--- runtime/msg.c.orig 2014-08-18 09:14:06.000000000 +0000
|
||||
+++ runtime/msg.c
|
||||
@@ -4074,7 +4074,11 @@ MsgSetPropsViaJSON(msg_t *__restrict__ c
|
||||
|
||||
err = tokener->err;
|
||||
if(err != json_tokener_continue)
|
||||
- errMsg = json_tokener_errors[err];
|
||||
+#if HAVE_JSON_TOKENER_ERROR_DESC
|
||||
+ errMsg = json_tokener_error_desc(err);
|
||||
+# else
|
||||
+ errMsg = json_tokener_errors[err];
|
||||
+# endif
|
||||
else
|
||||
errMsg = "Unterminated input";
|
||||
} else if(!json_object_is_type(json, json_type_object))
|
14
sysutils/rsyslog/patches/patch-tools_rsyslogd.c
Normal file
14
sysutils/rsyslog/patches/patch-tools_rsyslogd.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-tools_rsyslogd.c,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
|
||||
Need errno.h on NetBSD.
|
||||
--- tools/rsyslogd.c.orig 2014-08-18 09:14:06.000000000 +0000
|
||||
+++ tools/rsyslogd.c
|
||||
@@ -26,7 +26,7 @@
|
||||
|
||||
#include <signal.h>
|
||||
#include <liblogging/stdlog.h>
|
||||
-#ifdef OS_SOLARIS
|
||||
+#if defined(OS_SOLARIS) || defined(__NetBSD__)
|
||||
# include <errno.h>
|
||||
#else
|
||||
# include <sys/errno.h>
|
36
sysutils/rsyslog/patches/patch-tools_syslogd.c
Normal file
36
sysutils/rsyslog/patches/patch-tools_syslogd.c
Normal file
|
@ -0,0 +1,36 @@
|
|||
$NetBSD: patch-tools_syslogd.c,v 1.1 2014/09/05 07:15:41 fhajny Exp $
|
||||
|
||||
Need errno.h on NetBSD. Fix default PID path.
|
||||
--- tools/syslogd.c.orig 2014-07-15 13:34:03.000000000 +0000
|
||||
+++ tools/syslogd.c
|
||||
@@ -58,15 +58,19 @@
|
||||
#include <time.h>
|
||||
#include <assert.h>
|
||||
|
||||
-#ifdef OS_SOLARIS
|
||||
+#if defined(OS_SOLARIS) || defined(__NetBSD__)
|
||||
# include <errno.h>
|
||||
+#else
|
||||
+# include <sys/errno.h>
|
||||
+#endif
|
||||
+
|
||||
+#ifdef OS_SOLARIS
|
||||
# include <fcntl.h>
|
||||
# include <stropts.h>
|
||||
# include <sys/termios.h>
|
||||
# include <sys/types.h>
|
||||
#else
|
||||
# include <libgen.h>
|
||||
-# include <sys/errno.h>
|
||||
#endif
|
||||
|
||||
#include <sys/ioctl.h>
|
||||
@@ -135,7 +139,7 @@ void rsyslogdDoDie(int sig);
|
||||
|
||||
|
||||
#ifndef _PATH_LOGPID
|
||||
-# define _PATH_LOGPID "/var/run/rsyslogd.pid"
|
||||
+# define _PATH_LOGPID "@RSYSLOG_PIDDIR@/rsyslogd.pid"
|
||||
#endif
|
||||
|
||||
#ifndef _PATH_TTY
|
Loading…
Reference in a new issue