Pull in hal and policykit
This commit is contained in:
parent
df8948b46c
commit
6edc38854d
4 changed files with 37 additions and 5 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.102 2008/10/24 22:49:53 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.103 2008/11/23 17:32:12 jmcneill Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gnome-panel-2.24.1
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= x11 gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnome-panel/2.24/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -12,6 +13,10 @@ COMMENT= GNOME2 panel application
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/gnome-panel
|
||||
CONF_FILES+= ${PREFIX}/share/examples/gnome-panel/org.gnome.ClockApplet.Mechanism.conf \
|
||||
${PKG_SYSCONFDIR}/dbus-1/system.d/org.gnome.ClockApplet.Mechanism.conf
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_DIRS+= gnome2-1.5
|
||||
USE_TOOLS+= gmake intltool msgfmt perl:run pkg-config
|
||||
|
@ -37,10 +42,18 @@ BUILDLINK_API_DEPENDS.libglade+= libglade>=2.5.0
|
|||
BUILDLINK_API_DEPENDS.libgnome+= libgnome>=2.13.0
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.gnome-panel
|
||||
PKG_SUPPORTED_OPTIONS= evolution
|
||||
PKG_SUGGESTED_OPTIONS= evolution
|
||||
PKG_SUPPORTED_OPTIONS= evolution hal
|
||||
PKG_SUGGESTED_OPTIONS= evolution hal
|
||||
PLIST_VARS+= hal
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mhal)
|
||||
.include "../../security/policykit/buildlink3.mk"
|
||||
.include "../../security/policykit-gnome/buildlink3.mk"
|
||||
.include "../../sysutils/hal/buildlink3.mk"
|
||||
PLIST.hal= yes
|
||||
.endif
|
||||
|
||||
BUILDLINK_DEPMETHOD.libXt?= build
|
||||
|
||||
.include "../../devel/GConf/schemas.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.40 2008/10/24 22:49:53 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.41 2008/11/23 17:32:12 jmcneill Exp $
|
||||
bin/gnome-desktop-item-edit
|
||||
bin/gnome-panel
|
||||
bin/panel-test-applets
|
||||
|
@ -15,10 +15,14 @@ lib/libpanel-applet-2.la
|
|||
lib/pkgconfig/libpanelapplet-2.0.pc
|
||||
libexec/clock-applet
|
||||
libexec/fish-applet-2
|
||||
${PLIST.hal}libexec/gnome-clock-applet-mechanism
|
||||
libexec/notification-area-applet
|
||||
libexec/wnck-applet
|
||||
man/man1/gnome-panel.1
|
||||
${PLIST.hal}share/PolicyKit/policy/org.gnome.clockapplet.mechanism.policy
|
||||
share/applications/gnome-panel.desktop
|
||||
${PLIST.hal}share/dbus-1/system-services/org.gnome.ClockApplet.Mechanism.service
|
||||
${PLIST.hal}share/examples/gnome-panel/org.gnome.ClockApplet.Mechanism.conf
|
||||
share/gconf/schemas/clock.schemas
|
||||
share/gconf/schemas/fish.schemas
|
||||
share/gconf/schemas/panel-compatibility.schemas
|
||||
|
@ -505,6 +509,7 @@ share/omf/workspace-switcher/workspace-switcher-ru.omf
|
|||
share/omf/workspace-switcher/workspace-switcher-sv.omf
|
||||
share/omf/workspace-switcher/workspace-switcher-uk.omf
|
||||
share/omf/workspace-switcher/workspace-switcher-vi.omf
|
||||
${PLIST.hal}@dirrm share/examples/gnome-panel
|
||||
@dirrm share/omf/workspace-switcher
|
||||
@dirrm share/omf/window-list
|
||||
@dirrm share/omf/gnome-panel
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.47 2008/10/24 22:49:53 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.48 2008/11/23 17:32:12 jmcneill Exp $
|
||||
|
||||
SHA1 (gnome-panel-2.24.1.tar.bz2) = 01a2376582ba81b006511279767cb74ecb3332af
|
||||
RMD160 (gnome-panel-2.24.1.tar.bz2) = 84e7ccd0425c567c9b800cdfecb653f206cdf768
|
||||
Size (gnome-panel-2.24.1.tar.bz2) = 3354268 bytes
|
||||
SHA1 (patch-aa) = e19be3cb14a38e1ea98f368a1fd1f53e1a7d6513
|
||||
SHA1 (patch-ab) = 961186c5db258557294fae4a280d13efdcfe1de1
|
||||
SHA1 (patch-ad) = c24a5d0a8c1c88d46edfa3e8fc3e4528637a8d31
|
||||
SHA1 (patch-ae) = d85575dc403c67a4fcb0818904ab9b0517f7b8e0
|
||||
|
|
13
x11/gnome-panel/patches/patch-aa
Normal file
13
x11/gnome-panel/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.9 2008/11/23 17:32:12 jmcneill Exp $
|
||||
|
||||
--- applets/clock/Makefile.in.orig 2008-11-23 11:58:54.000000000 -0500
|
||||
+++ applets/clock/Makefile.in
|
||||
@@ -511,7 +511,7 @@ schemasdir = $(GCONF_SCHEMA_FILE_DIR)
|
||||
schemas_in_files = clock.schemas.in
|
||||
schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)
|
||||
dbus_servicesdir = $(datadir)/dbus-1/system-services
|
||||
-dbus_confdir = $(sysconfdir)/dbus-1/system.d
|
||||
+dbus_confdir = $(datadir)/examples/gnome-panel
|
||||
polkitdir = $(datadir)/PolicyKit/policy
|
||||
dbus_services_in_files = org.gnome.ClockApplet.Mechanism.service.in
|
||||
polkit_in_files = org.gnome.clockapplet.mechanism.policy.in
|
Loading…
Reference in a new issue