* no need to buildlink with zlib, just require python built with zlib support.

* no compiler languages is required to build.
* `/usr/bin/env python' shebang are also be handled with REPLACE_PYTHON.
* distutils pkg, register egg-info.
* add an patch for python27, from upstream repo.

Bump PKGREVISION.
This commit is contained in:
obache 2012-01-27 05:52:40 +00:00
parent 24c3d678c4
commit 6eddafbcbe
4 changed files with 25 additions and 13 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.16 2011/03/07 20:51:40 gls Exp $
# $NetBSD: Makefile,v 1.17 2012/01/27 05:52:40 obache Exp $
#
VER= 1.9.3
DISTNAME= moin-${VER}
PKGNAME= ${PYPKGPREFIX}-moin-${VER}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= www python
MASTER_SITES= http://static.moinmo.in/files/
@ -18,23 +18,18 @@ PKG_DESTDIR_SUPPORT= user-destdir
#Only for Python 2.4, which isn't recommended anyway
#DEPENDS+= ${PYPKGPREFIX}-xml-[0-9]*:../../textproc/py-xml
PYTHON_VERSIONS_ACCEPTED= 27 26 25 24
PYDISTUTILSPKG= # empty
USE_LANGUAGES= # none
REPLACE_INTERPRETER+= env_python
REPLACE.env_python.old= /usr/bin/env python
REPLACE.env_python.new= ${PYTHONBIN}
REPLACE_FILES.env_python= wiki/server/moin*
PYTHON_VERSIONS_ACCEPTED= 27 26 25 24
REPLACE_PYTHON= MoinMoin/i18n/tools/markup15to16.py \
MoinMoin/i18n/tools/po2wiki.py \
MoinMoin/i18n/tools/prepend.py \
MoinMoin/i18n/tools/wiki2po.py \
wiki/server/moin.fcgi
wiki/server/moin*
REPLACE_PERL= MoinMoin/web/static/htdocs/applets/FCKeditor/editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.pl
.include "../../devel/zlib/buildlink3.mk"
.include "../../lang/python/extension.mk"
.include "../../lang/python/distutils.mk"
.include "../../lang/python/application.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.7 2010/07/09 11:38:36 obache Exp $
@comment $NetBSD: PLIST,v 1.8 2012/01/27 05:52:40 obache Exp $
bin/moin
${PYSITELIB}/MoinMoin/Page.py
${PYSITELIB}/MoinMoin/Page.pyc
@ -2508,6 +2508,7 @@ ${PYSITELIB}/jabberbot/xmlrpcbot.pyo
${PYSITELIB}/jabberbot/xmppbot.py
${PYSITELIB}/jabberbot/xmppbot.pyc
${PYSITELIB}/jabberbot/xmppbot.pyo
${PLIST.eggfile}${PYSITELIB}/${EGG_FILE}
share/moin/config/logging/README
share/moin/config/logging/logfile
share/moin/config/logging/logfile_debug_auth

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.7 2011/03/07 20:51:40 gls Exp $
$NetBSD: distinfo,v 1.8 2012/01/27 05:52:40 obache Exp $
SHA1 (moin-1.9.3.tar.gz) = e019c2742f42d4d1f32b0f86f985ce938b821f1b
RMD160 (moin-1.9.3.tar.gz) = c8679c9440768906c47048f2544a26b77b1ca061
Size (moin-1.9.3.tar.gz) = 30514897 bytes
SHA1 (patch-MoinMoin_parser_text__rst.py) = 21876302d8ecef85295cc6c24ef4e3823f578556
SHA1 (patch-MoinMoin_support_werkzeug_templates.py) = d0baba8d2d01f9757e0702786828e2f4d6716c1b

View file

@ -0,0 +1,15 @@
$NetBSD: patch-MoinMoin_support_werkzeug_templates.py,v 1.1 2012/01/27 05:52:40 obache Exp $
fix for python 2.7
* http://hg.moinmo.in/moin/1.9/rev/a4a7f275b7b3
--- MoinMoin/support/werkzeug/templates.py.orig 2010-06-26 21:46:44.000000000 +0000
+++ MoinMoin/support/werkzeug/templates.py
@@ -12,7 +12,6 @@ import sys
import re
import __builtin__ as builtins
from compiler import ast, parse
-from compiler.consts import SC_LOCAL, SC_GLOBAL, SC_FREE, SC_CELL
from compiler.pycodegen import ModuleCodeGenerator
from tokenize import PseudoToken
from werkzeug import utils