add py-libmtag-0.3.0, Python bindings for libmtag
This commit is contained in:
parent
f775f1afc4
commit
6f4785fe51
5 changed files with 41 additions and 0 deletions
1
audio/py-libmtag/DESCR
Normal file
1
audio/py-libmtag/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
Python binding for libmtag
|
18
audio/py-libmtag/Makefile
Normal file
18
audio/py-libmtag/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2009/07/07 19:04:05 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libmtag-python-0.3.0
|
||||
PKGNAME= ${PYPKGPREFIX}-libmtag-0.3.0
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://libmtag.googlecode.com/files/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://code.google.com/p/libmtag/
|
||||
COMMENT= Python binding for libmtag
|
||||
|
||||
USE_TOOLS+= pkg-config
|
||||
PYDISTUTILSPKG= yes
|
||||
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../audio/libmtag/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
audio/py-libmtag/PLIST
Normal file
2
audio/py-libmtag/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/07/07 19:04:05 drochner Exp $
|
||||
${PYSITELIB}/libmtag.so
|
6
audio/py-libmtag/distinfo
Normal file
6
audio/py-libmtag/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/07/07 19:04:05 drochner Exp $
|
||||
|
||||
SHA1 (libmtag-python-0.3.0.tar.gz) = 948ebd93338a8939c0e584c6d7661f4a28167b5f
|
||||
RMD160 (libmtag-python-0.3.0.tar.gz) = 9b041a0850903b6eb3f7d3fe44eb901895e6ac8e
|
||||
Size (libmtag-python-0.3.0.tar.gz) = 2362 bytes
|
||||
SHA1 (patch-aa) = 6eeecbbe3641fc88dcf72e6419db402eb923971e
|
14
audio/py-libmtag/patches/patch-aa
Normal file
14
audio/py-libmtag/patches/patch-aa
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/07/07 19:04:05 drochner Exp $
|
||||
|
||||
--- setup.py.orig 2009-07-03 15:29:57.000000000 +0200
|
||||
+++ setup.py
|
||||
@@ -5,7 +5,8 @@ import commands
|
||||
def pkgconfig(*packages, **kw):
|
||||
flag_map = {'-I': 'include_dirs', '-L': 'library_dirs', '-l': 'libraries'}
|
||||
for token in commands.getoutput("pkg-config --libs --cflags %s" % ' '.join(packages)).split():
|
||||
- kw.setdefault(flag_map.get(token[:2]), []).append(token[2:])
|
||||
+ if flag_map.has_key(token[:2]):
|
||||
+ kw.setdefault(flag_map.get(token[:2]), []).append(token[2:])
|
||||
return kw
|
||||
|
||||
module1 = Extension('libmtag', ['libmtagmodule.c'], **pkgconfig('libmtag'))
|
Loading…
Reference in a new issue