update to pcb-20060321
======================================================================== Release Notes for PCB snapshot 20060321 ======================================================================== - Add internal support for more than 8 layers. By default PCB is still compiled for 8 copper layers. - Fixed several minor bugs in the GTK user interface including fixing scrolling of the log window, fixed up some of the DRC reporting and mm/mil units. - Fixed several key bindings. - Updated refcard.tex to reflect the current set of key bindings. - Fixed some minor bugs which caused compilation problems on some systems. - Converted the QFN footprints to hi-res. - Added documentation to the manual for the centroid file format and the algorithm used for finding the centroid and rotation. - Fixed a bug so that the initial layer named 'component' is actually on the component side of the board and 'solder' is actually on the solder side of the board. - Fixed the pin order in the bourns trim pots (~bourns library) - Added actions and a script to allow command line printing. - Added IPC-7351 recommended footprints for 0201, 0402, etc passives. - Fixed SME5 package. - Fixed a bug which prevented disabling nets from the ratsnest - Fixed a bug where clearances could be set 1 below the spacing - Fixed clearline flag so that arcs also have this property. - Speed up rtree searches and other autorouter speedups. - Fixed a bug in computation of the closest polygon point. - Use rtrees for polygon handling for speed improvements. - Add a ChangePinName() action. - Fix a bug which caused duplicate rats names when manually adding rats lines. - Added DRC checks for minimum drill diameter and minimum annular ring. - Add a minimal glossary to the manual - Fix the author name in the fab drawing - Cause the crosshair to snap to pad ends instead of center for rat drawing. - Add "join" to SetFlag, ClrFlag and ChangeFlag. - Added inline documentation for the pcb file syntax. The manual now is up to date and correctly documents the file format. In addition the inline documentation will make it much easier to maintain the documentation. - Remove some broken m4lib footprints - Put the correct setting for the gschem footprint= attribute in [] in the library window for the m4 libraries.
This commit is contained in:
parent
4e79d1d874
commit
6f6ce315f2
5 changed files with 9 additions and 50 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.31 2006/03/30 03:44:41 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.32 2006/04/04 22:20:27 dmcmahill Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pcb-${SNAPDATE}
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pcb/}
|
||||
|
||||
|
@ -14,7 +13,7 @@ PKG_INSTALLATION_TYPES= overwrite pkgviews
|
|||
|
||||
CONFLICTS+= pcb-current-[0-9]*
|
||||
|
||||
SNAPDATE= 20050609
|
||||
SNAPDATE= 20060321
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= WISH=${TOOLS_PATH.wish}
|
||||
USE_TOOLS+= bison gm4:run gmake lex wish:run
|
||||
|
@ -23,5 +22,6 @@ INFO_FILES= # PLIST
|
|||
# needed for XWarpPointer in action.c
|
||||
LIBS+= -lX11
|
||||
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2006/03/30 03:44:41 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.8 2006/04/04 22:20:27 dmcmahill Exp $
|
||||
bin/MergePCBPS
|
||||
bin/Merge_dimPCBPS
|
||||
bin/pcb
|
||||
bin/pcb-bin
|
||||
bin/pcb-print
|
||||
info/pcb.info
|
||||
man/man1/pcb.1
|
||||
share/pcb/CreateLibrary.sh
|
||||
|
@ -44,9 +45,6 @@ share/pcb/m4/geda.list
|
|||
share/pcb/m4/geda.m4
|
||||
share/pcb/m4/generic.list
|
||||
share/pcb/m4/generic.m4
|
||||
share/pcb/m4/genericsmt.inc
|
||||
share/pcb/m4/genericsmt.list
|
||||
share/pcb/m4/genericsmt.m4
|
||||
share/pcb/m4/gtag.list
|
||||
share/pcb/m4/gtag.m4
|
||||
share/pcb/m4/jerry.list
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.9 2006/01/05 15:55:26 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.10 2006/04/04 22:20:27 dmcmahill Exp $
|
||||
|
||||
SHA1 (pcb-20050609.tar.gz) = 5c6c47d36c6c3398c1410a8c5cf0c008b294e4c5
|
||||
RMD160 (pcb-20050609.tar.gz) = 4296b437a46e8a331cf773f29749b2bb8f8cb6ad
|
||||
Size (pcb-20050609.tar.gz) = 2371793 bytes
|
||||
SHA1 (patch-aa) = 3d31486ff101a2ab7698209e325ee85c9630a399
|
||||
SHA1 (patch-ab) = 1cdced6e0b60dc3e15ed571564c935c39ebde4a4
|
||||
SHA1 (pcb-20060321.tar.gz) = 8c8d332296eb6d55737c6e3909fc1ebed8bb7143
|
||||
RMD160 (pcb-20060321.tar.gz) = 1d73e61bb00d1a993dad4e3aa716e7708ac80db9
|
||||
Size (pcb-20060321.tar.gz) = 2520122 bytes
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2005/12/03 04:18:59 dmcmahill Exp $
|
||||
|
||||
A double semicolon counts as an empty statement, after which ISO C90
|
||||
does not allow any further variable declarations.
|
||||
|
||||
--- src/gui-netlist-window.c.orig Tue Mar 1 06:33:01 2005
|
||||
+++ src/gui-netlist-window.c Thu Aug 4 18:06:36 2005
|
||||
@@ -692,7 +692,7 @@ gui_netlist_highlight_node(gchar *node_n
|
||||
{
|
||||
GtkTreePath *path;
|
||||
GtkTreeIter iter;
|
||||
- LibraryMenuType *net;;
|
||||
+ LibraryMenuType *net;
|
||||
gchar *name;
|
||||
|
||||
if (!node_name)
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.5 2006/01/05 15:55:26 joerg Exp $
|
||||
|
||||
--- src/error.c.orig 2006-01-05 15:49:45.000000000 +0000
|
||||
+++ src/error.c
|
||||
@@ -66,7 +66,6 @@ RCSID("$Id: error.c,v 1.8 2005/03/12 02:
|
||||
/* ----------------------------------------------------------------------
|
||||
* some external identifiers
|
||||
*/
|
||||
-extern int errno; /* system error code */
|
||||
|
||||
#if !defined(HAVE_STRERROR)
|
||||
extern int sys_nerr; /* number of messages available from array */
|
||||
@@ -74,7 +73,7 @@ extern int sys_nerr; /* number of messa
|
||||
#endif
|
||||
|
||||
/* the list is already defined for some OS */
|
||||
-#if !defined(__NetBSD__) && !defined(__FreeBSD__) && !defined(__linux__)
|
||||
+#if !defined(__NetBSD__) && !defined(__FreeBSD__) && !defined(__linux__) && !defined(__DragonFly__)
|
||||
#ifdef USE_SYS_ERRLIST
|
||||
extern char *sys_errlist[]; /* array of error messages */
|
||||
#endif
|
Loading…
Reference in a new issue