Add patches that unbreak Python 2.5 build.
This commit is contained in:
parent
a0a4f55e07
commit
6f9a334c92
5 changed files with 65 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.9 2009/02/11 21:19:34 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.10 2009/02/11 21:20:43 joerg Exp $
|
||||
|
||||
SHA1 (SOAPpy-0.11.6.tar.gz) = 59c91688f23de3b738bf504351bca89aab5cc203
|
||||
RMD160 (SOAPpy-0.11.6.tar.gz) = ba0c90f0229aa077976face8d5e50147b034f30c
|
||||
|
@ -7,4 +7,3 @@ SHA1 (patch-aa) = 3a788d6ad83948132dbc71ea3b2588d17ae89595
|
|||
SHA1 (patch-ab) = 55846e093dcd73f8f46aa0d76eb3f5d5309c94d7
|
||||
SHA1 (patch-ac) = 8b3a392b6d55eff15538f638bec502a2e654c5c8
|
||||
SHA1 (patch-ad) = 78391ed27f97fffdbb6cc945bc27ad012dff60af
|
||||
SHA1 (patch-ae) = da39a3ee5e6b4b0d3255bfef95601890afd80709
|
||||
|
|
16
net/py-soappy/patches/patch-aa
Normal file
16
net/py-soappy/patches/patch-aa
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-aa,v 1.3 2009/02/11 21:20:43 joerg Exp $
|
||||
|
||||
--- SOAPpy/Client.py.orig 2009-02-11 22:13:44.000000000 +0100
|
||||
+++ SOAPpy/Client.py
|
||||
@@ -1,2 +1,4 @@
|
||||
+from __future__ import nested_scopes
|
||||
+
|
||||
"""
|
||||
################################################################################
|
||||
@@ -44,6 +46,4 @@ ident = '$Id: Client.py,v 1.20 2004/04/1
|
||||
from version import __version__
|
||||
|
||||
-from __future__ import nested_scopes
|
||||
-
|
||||
#import xml.sax
|
||||
import urllib
|
16
net/py-soappy/patches/patch-ab
Normal file
16
net/py-soappy/patches/patch-ab
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ab,v 1.1 2009/02/11 21:20:43 joerg Exp $
|
||||
|
||||
--- SOAPpy/Types.py.orig 2009-02-11 22:14:21.000000000 +0100
|
||||
+++ SOAPpy/Types.py
|
||||
@@ -1,2 +1,4 @@
|
||||
+from __future__ import nested_scopes
|
||||
+
|
||||
"""
|
||||
################################################################################
|
||||
@@ -37,6 +39,4 @@ ident = '$Id: Types.py,v 1.17 2004/09/11
|
||||
from version import __version__
|
||||
|
||||
-from __future__ import nested_scopes
|
||||
-
|
||||
import UserList
|
||||
import base64
|
16
net/py-soappy/patches/patch-ac
Normal file
16
net/py-soappy/patches/patch-ac
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ac,v 1.1 2009/02/11 21:20:43 joerg Exp $
|
||||
|
||||
--- SOAPpy/Server.py.orig 2009-02-11 22:15:23.000000000 +0100
|
||||
+++ SOAPpy/Server.py
|
||||
@@ -1,2 +1,4 @@
|
||||
+from __future__ import nested_scopes
|
||||
+
|
||||
"""
|
||||
################################################################################
|
||||
@@ -44,6 +46,4 @@ ident = '$Id: Server.py,v 1.20 2004/04/2
|
||||
from version import __version__
|
||||
|
||||
-from __future__ import nested_scopes
|
||||
-
|
||||
#import xml.sax
|
||||
import re
|
16
net/py-soappy/patches/patch-ad
Normal file
16
net/py-soappy/patches/patch-ad
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ad,v 1.1 2009/02/11 21:20:43 joerg Exp $
|
||||
|
||||
--- SOAPpy/GSIServer.py.orig 2009-02-11 22:16:29.000000000 +0100
|
||||
+++ SOAPpy/GSIServer.py
|
||||
@@ -1,2 +1,4 @@
|
||||
+from __future__ import nested_scopes
|
||||
+
|
||||
"""
|
||||
GSIServer - Contributed by Ivan R. Judson <judson@mcs.anl.gov>
|
||||
@@ -47,6 +49,4 @@ ident = '$Id: GSIServer.py,v 1.4 2004/02
|
||||
from version import __version__
|
||||
|
||||
-from __future__ import nested_scopes
|
||||
-
|
||||
#import xml.sax
|
||||
import re
|
Loading…
Reference in a new issue