-explicitely disable kerberos support to avoid PLIST fluctuations

(seen in bulk build)
-fix obvious typo in asm code (fixes i386 build)
-don't install nettle library to avoid conflict with pkgsrc/nettle
bump PKGREV
This commit is contained in:
drochner 2011-12-16 12:54:41 +00:00
parent d2840a353f
commit 6fb5de7923
5 changed files with 38 additions and 46 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.19 2010/03/24 19:43:28 asau Exp $
# $NetBSD: Makefile,v 1.20 2011/12/16 12:54:41 drochner Exp $
#
DISTNAME= lsh-2.0.4
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.lysator.liu.se/~nisse/archive/ \
ftp://ftp.lysator.liu.se/pub/security/lsh/
@ -17,7 +17,7 @@ PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
USE_TOOLS+= gmake gm4 bash:run
REPLACE_BASH+= src/lcp
CONFIGURE_ARGS+= --disable-openssl --disable-pam
CONFIGURE_ARGS+= --disable-openssl --disable-pam --disable-kerberos
INFO_FILES= yes
# lcp test depends on /bin/bash and thus fails, others work

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.6 2009/06/14 18:13:32 joerg Exp $
@comment $NetBSD: PLIST,v 1.7 2011/12/16 12:54:41 drochner Exp $
bin/lcp
bin/lsftp
bin/lsh
@ -12,50 +12,9 @@ bin/lsh-upgrade
bin/lsh-upgrade-key
bin/lsh-writekey
bin/lshg
bin/nettle-lfib-stream
bin/pkcs1-conv
bin/sexp-conv
bin/srp-gen
bin/ssh-conv
include/nettle/aes.h
include/nettle/arcfour.h
include/nettle/arctwo.h
include/nettle/asn1.h
include/nettle/base16.h
include/nettle/base64.h
include/nettle/bignum.h
include/nettle/blowfish.h
include/nettle/buffer.h
include/nettle/cast128.h
include/nettle/cbc.h
include/nettle/ctr.h
include/nettle/des-compat.h
include/nettle/des.h
include/nettle/dsa.h
include/nettle/hmac.h
include/nettle/knuth-lfib.h
include/nettle/macros.h
include/nettle/md2.h
include/nettle/md4.h
include/nettle/md5-compat.h
include/nettle/md5.h
include/nettle/memxor.h
include/nettle/nettle-meta.h
include/nettle/nettle-stdint.h
include/nettle/nettle-types.h
include/nettle/pgp.h
include/nettle/pkcs1.h
include/nettle/realloc.h
include/nettle/rsa-compat.h
include/nettle/rsa.h
include/nettle/serpent.h
include/nettle/sexp.h
include/nettle/sha.h
include/nettle/twofish.h
include/nettle/yarrow.h
info/lsh.info
info/nettle.info
lib/libnettle.a
man/man1/lsftp.1
man/man1/lsh-authorize.1
man/man1/lsh-decode-key.1

View file

@ -1,7 +1,9 @@
$NetBSD: distinfo,v 1.8 2010/03/13 04:40:12 obache Exp $
$NetBSD: distinfo,v 1.9 2011/12/16 12:54:41 drochner Exp $
SHA1 (lsh-2.0.4.tar.gz) = c4e2a0b6a0e20dcba7fe02a0d5605bc00960106a
RMD160 (lsh-2.0.4.tar.gz) = 24f16d6945f7c801aac190fd0109cad608a317de
Size (lsh-2.0.4.tar.gz) = 2183843 bytes
SHA1 (patch-aa) = ae43022c180e9f8ee2bb95fe424f371e834fdf07
SHA1 (patch-ab) = e241831267630ffcf0b7079627e91c58482427c3
SHA1 (patch-ac) = a47ceb727fba55ab914d08cb440627a38965edcd
SHA1 (patch-ad) = 6b20cfebe3b83aad399bd0a1c772d94328be7247

View file

@ -0,0 +1,10 @@
$NetBSD: patch-ac,v 1.3 2011/12/16 12:54:41 drochner Exp $
--- src/nettle/x86/md5-compress.asm.orig 2007-09-05 18:38:24.000000000 +0000
+++ src/nettle/x86/md5-compress.asm
@@ -171,4 +171,4 @@ PROLOGUE(_nettle_md5_compress)
popl %ebp
popl %ebx
ret
-EPILOGUE(_nettle_sha1_compress)
+EPILOGUE(_nettle_md5_compress)

View file

@ -0,0 +1,21 @@
$NetBSD: patch-ad,v 1.3 2011/12/16 12:54:41 drochner Exp $
don't install nettle files to avoid conflict with pkgsrc/nettle
--- src/nettle/Makefile.in.orig 2007-09-05 18:38:24.000000000 +0000
+++ src/nettle/Makefile.in
@@ -24,11 +24,13 @@ TARGETS = aesdata$(EXEEXT) desdata$(EXEE
DOCTARGETS = nettle.info nettle.html nettle.pdf
-all check install uninstall:
+all check uninstall:
$(MAKE) $@-here
set -e; for d in $(SUBDIRS); do \
echo "Making $@ in $$d" ; (cd $$d && $(MAKE) $@); done
+install:
+
clean distclean mostlyclean maintainer-clean:
set -e; for d in $(SUBDIRS); do \
echo "Making $@ in $$d" ; (cd $$d && $(MAKE) $@); done