Add patch to not call RAND_seed. Works around problem where firefox3
crashes when opening the printing dialog. Fix based on concept from Yorick Hardy, but bugs are my fault.
This commit is contained in:
parent
a017346ab7
commit
6fc0507a5f
3 changed files with 26 additions and 3 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.136 2008/10/22 21:48:15 tonnerre Exp $
|
||||
# $NetBSD: Makefile,v 1.137 2009/01/29 15:28:31 gdt Exp $
|
||||
#
|
||||
# The CUPS author is very good about taking back changes into the main
|
||||
# CUPS distribution. The correct place to send patches or bug-fixes is:
|
||||
|
@ -9,6 +9,7 @@ PKGNAME= cups-${VERS}
|
|||
BASE_VERS= 1.3.9
|
||||
DIST_VERS= ${BASE_VERS}
|
||||
VERS= ${DIST_VERS:S/-/./g}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://ftp.easysw.com/pub/cups/${BASE_VERS}/ \
|
||||
ftp://ftp.ntua.gr/pub/gnu/cups/${BASE_VERS}/ \
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.57 2008/10/22 21:48:16 tonnerre Exp $
|
||||
$NetBSD: distinfo,v 1.58 2009/01/29 15:28:31 gdt Exp $
|
||||
|
||||
SHA1 (cups-1.3.9-source.tar.bz2) = c1a596b355201320456b393446286fe3947bce16
|
||||
RMD160 (cups-1.3.9-source.tar.bz2) = ec8bd9fc6ee45648b6eb22949f44fc4cf2defd4e
|
||||
|
@ -7,7 +7,7 @@ SHA1 (patch-aa) = 51ff6e66f881e445adca768d4cf2f6bd18fc36dd
|
|||
SHA1 (patch-ab) = 11936b2512fc4480a45a8efb01de0c5a29a7a6e8
|
||||
SHA1 (patch-ac) = 02fab706563f7ba01d66530f9462759689c09f04
|
||||
SHA1 (patch-ad) = 6695c344453495cd960460733a80d50654786c60
|
||||
SHA1 (patch-ae) = 87b19c14bb2365630d1857c32b71236f0aab787b
|
||||
SHA1 (patch-an) = 5c12e6de5d83659011c6050786049756e4aa4b49
|
||||
SHA1 (patch-ao) = 4fc204e312bf8752f3f3b4fd73ec1e4f166ae2d3
|
||||
SHA1 (patch-at) = eea32b989402c353f5f1644348c1042a3d4ddfa1
|
||||
SHA1 (patch-au) = 0c32755a4979e5a44b1773c9fd1fb75bcf919cef
|
||||
|
|
22
print/cups/patches/patch-ae
Normal file
22
print/cups/patches/patch-ae
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ae,v 1.20 2009/01/29 15:28:31 gdt Exp $
|
||||
|
||||
Should be pushed upstream and the real problem identified.
|
||||
|
||||
--- cups/http.c.orig 2008-08-01 14:33:16.000000000 -0400
|
||||
+++ cups/http.c
|
||||
@@ -1175,7 +1175,14 @@ httpInitialize(void)
|
||||
for (i = 0; i < sizeof(data); i ++)
|
||||
data[i] = rand(); /* Yes, this is a poor source of random data... */
|
||||
|
||||
- RAND_seed(&data, sizeof(data));
|
||||
+#if 0
|
||||
+ /*
|
||||
+ * For reasons not entirely clear, this call results in segfaults
|
||||
+ * when firefox3 tries to print. Upstream has a spurious & in front
|
||||
+ * of data, but removing that is not enough to avoid the crash.
|
||||
+ */
|
||||
+ RAND_seed(data, sizeof(data));
|
||||
+#endif
|
||||
#endif /* HAVE_LIBSSL */
|
||||
}
|
||||
|
Loading…
Reference in a new issue