Update net/netatalk to v2.2.5
Changes in 2.2.5 ================ * FIX: Fix errors searching volumes * NEW: Configurable symlink handling with a new volume option 'followsymlinks'. Setting the option causes afpd to follow symlinks on the server side. * UPD: Reload groups when reloading volumes. FR #71. * FIX: Fix a possible crash in cname() where cname_mtouname calls dirlookup() where the curdir is freed because the dircache detected a dev/inode cache difference and evicted the object from the cache. Fixes bug #498. * FIX: Change default FinderInfo for directories to be all 0, fixes bug 514.
This commit is contained in:
parent
c0399f6f30
commit
6fc26b0443
4 changed files with 34 additions and 7 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.100 2013/05/31 12:41:35 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.101 2013/07/23 13:28:17 hauke Exp $
|
||||
|
||||
DISTNAME= netatalk-2.2.4
|
||||
DISTNAME= netatalk-2.2.5
|
||||
#PKGREVISION= 1
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= net print
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=netatalk/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.51 2013/07/16 22:38:32 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.52 2013/07/23 13:28:17 hauke Exp $
|
||||
|
||||
SHA1 (netatalk-2.2.4.tar.bz2) = da2d59634a6bf3cb2e21e339b2acd0b8da3885d1
|
||||
RMD160 (netatalk-2.2.4.tar.bz2) = ba94a55d2d6338b52ffaa3ee3c306549f34fec51
|
||||
Size (netatalk-2.2.4.tar.bz2) = 1289663 bytes
|
||||
SHA1 (netatalk-2.2.5.tar.bz2) = 4367421213d68b8396cf35743e347e9c01bdf3b0
|
||||
RMD160 (netatalk-2.2.5.tar.bz2) = ff0165806973b19db906406fd4b37dd49d505a27
|
||||
Size (netatalk-2.2.5.tar.bz2) = 1290761 bytes
|
||||
SHA1 (patch-ac) = 605e87479202cbf093dfbadb25f2972595246d97
|
||||
SHA1 (patch-ae) = e114085fbe2abf2fb821f2d2737e877c53e7c151
|
||||
SHA1 (patch-af) = 649be7e50210e6e4156aeff74d3fc0effb90f9f2
|
||||
|
@ -17,7 +17,9 @@ SHA1 (patch-bin_ad_ad__cp.c) = 0a9e93f6149ff53f0f0d8c36ea4c5e635b5b624c
|
|||
SHA1 (patch-configure) = 5beb3677965c0a98297f6c7ce5ad6b598bfd9e8b
|
||||
SHA1 (patch-distrib_initscripts_Makefile.in) = 3dc520f998b2b35ea60cd8f1a2a96d465a9e474a
|
||||
SHA1 (patch-etc_afpd_afp_mdns.c) = ab87bf511466ef183de1ee8f8a9ad1fbb8776066
|
||||
SHA1 (patch-etc_afpd_filedir.c) = 13df7e1332d5a49e3071145a7573ef11bd586397
|
||||
SHA1 (patch-etc_afpd_quota_c) = 5005abb6528c0b3160a587fbe9fb285f485e6759
|
||||
SHA1 (patch-etc_uams_uams_gss.c) = b9ff59c368e01d3f269e95f5eaeb239dc17e701c
|
||||
SHA1 (patch-include_atalk_acl.h) = 62d67eaf089126b2c0bff0871b23f7a6707e119c
|
||||
SHA1 (patch-include_atalk_ldapconfig.h) = d0bb4a1bf520b18228de6ab87b646f4496852fce
|
||||
SHA1 (patch-macros_quota-check.m4) = b1484f83a2a6ba5bd50623ab525d5366bb71abaa
|
||||
|
|
13
net/netatalk/patches/patch-etc_afpd_filedir.c
Normal file
13
net/netatalk/patches/patch-etc_afpd_filedir.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-etc_afpd_filedir.c,v 1.1 2013/07/23 13:28:17 hauke Exp $
|
||||
|
||||
--- etc/afpd/filedir.c.orig 2013-07-23 09:10:55.000000000 +0000
|
||||
+++ etc/afpd/filedir.c
|
||||
@@ -372,7 +372,7 @@ static int moveandrename(const struct vo
|
||||
#ifdef HAVE_ATFUNCS
|
||||
opened = of_findnameat(sdir_fd, &path);
|
||||
#else
|
||||
- opened = of_findname(&path);
|
||||
+ opened = of_findname(sdir_fd, &path);
|
||||
#endif /* HAVE_ATFUNCS */
|
||||
|
||||
if (opened) {
|
13
net/netatalk/patches/patch-include_atalk_acl.h
Normal file
13
net/netatalk/patches/patch-include_atalk_acl.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-include_atalk_acl.h,v 1.1 2013/07/23 13:28:17 hauke Exp $
|
||||
|
||||
--- include/atalk/acl.h.orig 2013-07-23 09:10:55.000000000 +0000
|
||||
+++ include/atalk/acl.h
|
||||
@@ -53,7 +53,7 @@ extern int remove_acl_vfs(const char *na
|
||||
|
||||
#else /* HAVE_ACLS=no */
|
||||
|
||||
-#define O_NETATALK_ACL
|
||||
+#define O_NETATALK_ACL 0
|
||||
#define chmod_acl chmod
|
||||
|
||||
#endif /* HAVE_ACLS */
|
Loading…
Reference in a new issue