Probe a potentially different cpp for preprocessing makefiles. For

now, wire it down; this will probably fail on clang and I'll fix it
better later.
This commit is contained in:
dholland 2013-07-07 06:29:48 +00:00
parent 9c86175b12
commit 6ff21ed0cd
2 changed files with 62 additions and 6 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.29 2013/07/07 05:30:13 dholland Exp $
$NetBSD: distinfo,v 1.30 2013/07/07 06:29:48 dholland Exp $
SHA1 (emacs-20.7-mule-4.1b-elc.tar.gz) = 3894fb2b81bb326545f6ccc3bf0a8405c23004ff
RMD160 (emacs-20.7-mule-4.1b-elc.tar.gz) = c675b31dafaa4321a453af9d87eddf051ee71b1f
@ -16,7 +16,7 @@ SHA1 (emacs20-xim-20000713.diff) = 5bed39e7b8a52941f77088529566aaa3bcf06670
RMD160 (emacs20-xim-20000713.diff) = 5887a4d43ee92e8cad65d6412c9ecbce08e781da
Size (emacs20-xim-20000713.diff) = 21296 bytes
SHA1 (patch-aa) = 3b3fd76c058a0a46e0458338ce4c2327a238fb3d
SHA1 (patch-ab) = a43192a506df129784153008f8bd08b4c0559fa1
SHA1 (patch-ab) = afce3627e25f360ca111abf1afcf5702167c2157
SHA1 (patch-ac) = abf5971279a8d875504be4c17b8d36cb8cc24885
SHA1 (patch-ad) = dd21028a6360ccfb442ecced4c67717f60ea78a6
SHA1 (patch-ae) = 465c7aff1fbb23d08ff8100993041291a9502f34

View file

@ -1,4 +1,9 @@
$NetBSD: patch-ab,v 1.9 2013/07/07 05:30:13 dholland Exp $
$NetBSD: patch-ab,v 1.10 2013/07/07 06:29:48 dholland Exp $
Caution: the changes for using a different cpp for munging the
makefiles (search for MAKEFILECPP) are *not* reflected in the pkgsrc
patch for configure.in; don't accidentally lose them by regenerating
with autoconf without thinking.
--- configure.orig 2000-06-12 20:05:56.000000000 +0000
+++ configure
@ -55,7 +60,32 @@ $NetBSD: patch-ab,v 1.9 2013/07/07 05:30:13 dholland Exp $
*-nextstep* ) opsys=nextstep ;;
## Otherwise, we'll fall through to the generic opsys code at the bottom.
esac
@@ -3823,6 +3837,53 @@ else
@@ -1981,6 +1995,24 @@ else
fi
echo "$ac_t""$CPP" 1>&6
+echo $ac_n "checking how to preprocess makefiles""... $ac_c" 1>&6
+echo "configure:1999: checking how to preprocess makefiles" >&5
+# If we were doing this for real we could test for various alternatives
+# (note the now-dead version 1.4 of patch-ab for some things to check)
+# but for pkgsrc purposes the following is currently sufficient.
+
+
+
+
+
+
+
+
+MAKEFILECPP="$CPP -traditional-cpp"
+
+
+echo "$ac_t""$MAKEFILECPP" 1>&6
+
# Find a good install program. We prefer a C program (faster),
# so one script is as good as another. But avoid the broken or
# incompatible versions:
@@ -3823,6 +3855,53 @@ else
echo "$ac_t""no" 1>&6
fi
@ -109,7 +139,7 @@ $NetBSD: patch-ab,v 1.9 2013/07/07 05:30:13 dholland Exp $
LIBS="$OLDLIBS"
fi
@@ -4906,6 +4967,64 @@ EOF
@@ -4906,6 +4985,64 @@ EOF
fi
@ -174,7 +204,7 @@ $NetBSD: patch-ab,v 1.9 2013/07/07 05:30:13 dholland Exp $
# Set up the CFLAGS for real compilation, so we can substitute it.
CFLAGS="$REAL_CFLAGS"
@@ -5211,6 +5330,7 @@ s%@INSTALL_SCRIPT@%$INSTALL_SCRIPT%g
@@ -5211,6 +5350,7 @@ s%@INSTALL_SCRIPT@%$INSTALL_SCRIPT%g
s%@INSTALL_DATA@%$INSTALL_DATA%g
s%@YACC@%$YACC%g
s%@SET_MAKE@%$SET_MAKE%g
@ -182,3 +212,29 @@ $NetBSD: patch-ab,v 1.9 2013/07/07 05:30:13 dholland Exp $
s%@ALLOCA@%$ALLOCA%g
s%@version@%$version%g
s%@configuration@%$configuration%g
@@ -5445,6 +5585,7 @@ fi; done
EOF
cat >> $CONFIG_STATUS <<EOF
CPP="$CPP" CPPFLAGS="$CPPFLAGS"
+MAKEFILECPP="$MAKEFILECPP"
EOF
cat >> $CONFIG_STATUS <<\EOF
@@ -5480,7 +5621,7 @@ echo creating lib-src/Makefile
sed -e '1,/start of cpp stuff/d'\
-e 's@/\*\*/#\(.*\)$@/* \1 */@' \
< Makefile.c > junk.c
- $CPP $undefs -I. -I$top_srcdir/src $CPPFLAGS junk.c | \
+ $MAKEFILECPP $undefs -I. -I$top_srcdir/src $CPPFLAGS junk.c | \
sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
cat junk1.c junk2.c > Makefile.new
rm -f junk.c junk1.c junk2.c
@@ -5496,7 +5637,7 @@ echo creating src/Makefile
sed -e '1,/start of cpp stuff/d'\
-e 's@/\*\*/#\(.*\)$@/* \1 */@' \
< Makefile.c > junk.c
- $CPP $undefs -I. -I$top_srcdir/src $CPPFLAGS junk.c | \
+ $MAKEFILECPP $undefs -I. -I$top_srcdir/src $CPPFLAGS junk.c | \
sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
cat junk1.c junk2.c > Makefile.new
rm -f junk.c junk1.c junk2.c