lua-http: update to 0.4

0.4 - 2021-02-06

  - Support multiple elliptic curves under OpenSSL 1.1.1+ (#150)
  - Improve support for Lua 5.4 (not longer require bit library to be installed) (#180)
  - Ignore delayed RST_STREAM frames in HTTP 2 (#145)
This commit is contained in:
nia 2021-04-08 11:37:25 +00:00
parent cf3d76da3d
commit 6ff3fc5082
3 changed files with 7 additions and 24 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.3 2020/09/03 07:39:40 nia Exp $
# $NetBSD: Makefile,v 1.4 2021/04/08 11:37:25 nia Exp $
DISTNAME= lua-http-0.3
DISTNAME= lua-http-0.4
PKGNAME= ${LUA_PKGPREFIX}-${DISTNAME:S/lua-//1}
PKGREVISION= 1
CATEGORIES= www lua
MASTER_SITES= ${MASTER_SITE_GITHUB:=daurnimator/}
GITHUB_PROJECT= lua-http

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.2 2020/09/17 06:56:03 wiz Exp $
$NetBSD: distinfo,v 1.3 2021/04/08 11:37:25 nia Exp $
SHA1 (lua-http-0.3.tar.gz) = d658cb7fdeed670455ed69583f9cef529851ffa7
RMD160 (lua-http-0.3.tar.gz) = 10916716de6adbd388e7fdab8e94a21941075461
SHA512 (lua-http-0.3.tar.gz) = 5728848849e8d3e99328abdc6aff3034a708f0e5884e8718a9266900a561a37850e2bf911e9cbd0d4d538799e1fd8bb4fd66008f4787011f5802b259d51f8281
Size (lua-http-0.3.tar.gz) = 141882 bytes
SHA1 (patch-http_bit.lua) = f8fb9be435e0392aec4c29cdde01da7c33f6be64
SHA1 (lua-http-0.4.tar.gz) = 9a6f6999924900e86ef4f07d1bbfb4c4031b9e6b
RMD160 (lua-http-0.4.tar.gz) = 49e4ba9f7c60633f875297bebffc4c7edc80d405
SHA512 (lua-http-0.4.tar.gz) = 3933c36e2d439c81ba4506d3ab1dd53a85ba3cd641abbd945210bdc6b6edb3e01516adb473cf59c5c194d9f45e7de9196e31265318d01c5b7684bb5e87dbd26a
Size (lua-http-0.4.tar.gz) = 142623 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-http_bit.lua,v 1.1 2020/09/03 07:39:40 nia Exp $
Recognize Lua 5.4.
--- http/bit.lua.orig 2019-02-13 11:43:45.000000000 +0000
+++ http/bit.lua
@@ -8,7 +8,7 @@ This means we can ignore the differences
]]
-- Lua 5.3 has built-in bit operators, wrap them in a function.
-if _VERSION == "Lua 5.3" then
+if _VERSION == "Lua 5.3" or _VERSION == "Lua 5.4" then
-- Use debug.getinfo to get correct file+line numbers for loaded snippet
local info = debug.getinfo(1, "Sl")
return assert(load(("\n"):rep(info.currentline+1)..[[return {