Update patches for the previous commit.
This commit is contained in:
parent
78796546c3
commit
6ff8ef4a53
3 changed files with 98 additions and 63 deletions
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2006/01/09 11:59:55 tron Exp $
|
||||
|
||||
--- texk/tetex/texconfig-dialog.orig 2005-02-01 21:00:42.000000000 +0000
|
||||
+++ texk/tetex/texconfig-dialog 2006-01-09 11:47:52.000000000 +0000
|
||||
@@ -82,14 +82,7 @@
|
||||
runDialog()
|
||||
{
|
||||
termCtl clear
|
||||
- if test -n "$DIALOG_PROG"; then
|
||||
- $DIALOG_PROG --title "TeX setup utility" ${1+"$@"}
|
||||
- runDialogRc=$?
|
||||
- else
|
||||
- TERM=$DIALOG_TERM TERMINFO=$DIALOG_TERMINFO \
|
||||
- tcdialog --title "TeX setup utility" ${1+"$@"}
|
||||
- runDialogRc=$?
|
||||
- fi
|
||||
+ dialog --title "TeX setup utility" ${1+"$@"}
|
||||
termCtl clear
|
||||
(exit $runDialogRc)
|
||||
return $runDialogRc
|
|
@ -1,43 +0,0 @@
|
|||
$NetBSD: patch-ap,v 1.1.1.1 2005/03/31 22:09:18 hubertf Exp $
|
||||
|
||||
--- texk/tetex/texconfig.orig 2005-02-06 18:20:53.000000000 +0000
|
||||
+++ texk/tetex/texconfig
|
||||
@@ -157,36 +157,13 @@ checkForBinary()
|
||||
}
|
||||
|
||||
###############################################################################
|
||||
-# findDialogProg(void)
|
||||
-# Some systems have their own dialog. Use it then and do not use
|
||||
-# faked TERM and TERMINFO variables when calling that dialog.
|
||||
-###############################################################################
|
||||
-findDialogProg()
|
||||
-{
|
||||
- { u=`uname -s`; } 2>/dev/null
|
||||
- case "$u" in
|
||||
- FreeBSD|Linux|cygwin*|CYGWIN*)
|
||||
- test -f /usr/bin/whiptail && DIALOG_PROG=/usr/bin/whiptail
|
||||
- test -f /usr/bin/dialog && DIALOG_PROG=/usr/bin/dialog
|
||||
- test -f /bin/dialog && DIALOG_PROG=/bin/dialog
|
||||
- ;;
|
||||
- esac
|
||||
-}
|
||||
-
|
||||
-###############################################################################
|
||||
# runDialog(args)
|
||||
-# call either tcdialog or $DIALOG_PROG
|
||||
+# call dialog
|
||||
###############################################################################
|
||||
runDialog()
|
||||
{
|
||||
test -z "$NO_CLEAR" && tty -s && clear
|
||||
- case "$DIALOG_PROG" in
|
||||
- "")
|
||||
- TERM=$DIALOG_TERM TERMINFO=$DIALOG_TERMINFO \
|
||||
- tcdialog --title "$progname setup utility" ${1+"$@"};;
|
||||
- *)
|
||||
- $DIALOG_PROG --title "$progname setup utility" ${1+"$@"};;
|
||||
- esac
|
||||
+ dialog --title "$progname setup utility" ${1+"$@"}
|
||||
}
|
||||
|
||||
|
98
print/teTeX3-bin/patches/patch-as
Normal file
98
print/teTeX3-bin/patches/patch-as
Normal file
|
@ -0,0 +1,98 @@
|
|||
$NetBSD: patch-as,v 1.3 2009/01/26 21:18:04 minskim Exp $
|
||||
|
||||
--- texk/tetex/Makefile.in.orig 2005-02-04 14:20:54.000000000 -0800
|
||||
+++ texk/tetex/Makefile.in
|
||||
@@ -8,10 +8,7 @@ ac_include ../make/programs.mk
|
||||
man5dir = $(mandir)/man5
|
||||
|
||||
SCRIPTS = \
|
||||
- allcm allneeded dvi2fax dvired fmtutil fontinst \
|
||||
- kpsetool kpsewhere ps2frag pslatex rubibtex rumakeindex \
|
||||
- texconfig texconfig-dialog texdoc texdoctk texexec texlinks updmap \
|
||||
- ps4pdf fmtutil-sys texconfig-sys updmap-sys
|
||||
+ texdoc texdoctk texexec
|
||||
|
||||
PDFSCRIPTS = a2ping e2pall epstopdf
|
||||
|
||||
@@ -19,11 +16,9 @@ PERLWRAPPED = fdf2tan fdf2tex makempy te
|
||||
thumbpdf pdfcrop uniqleaf
|
||||
|
||||
manpgs = \
|
||||
- allcm allec allneeded dvi2fax dvired e2pall epstopdf fdf2tex fontinst \
|
||||
- kpsetool kpsewhere makempy mkocp mkofm ofm2opl opl2ofm otp2ocp outocp \
|
||||
- ovf2ovp ovp2ovf ps2frag pslatex rubibtex rumakeindex texconfig texdoc \
|
||||
- texdoctk texexec texfind texfont texshow texutil thumbpdf \
|
||||
- ttf2afm updmap
|
||||
+ fdf2tex \
|
||||
+ texdoc \
|
||||
+ texshow
|
||||
|
||||
INFOFILES= latex.info
|
||||
POOLFILES = pdfetex-pl.pool
|
||||
@@ -39,30 +34,18 @@ install-data:: $(INFOFILES)
|
||||
for p in $(manpgs); do \
|
||||
$(INSTALL_DATA) $(srcdir)/$$p.man $(man1dir)/$$p.$(manext); \
|
||||
done
|
||||
- $(INSTALL_DATA) $(srcdir)/fmtutil.man $(man1dir)/fmtutil.1
|
||||
- $(INSTALL_DATA) $(srcdir)/texlinks.man $(man1dir)/texlinks.1
|
||||
- $(INSTALL_DATA) $(srcdir)/fmtutil.cnf.5 $(man5dir)/fmtutil.cnf.5
|
||||
- cd $(man1dir); rm -f allec.$(manext) texhash.$(manext) \
|
||||
- lambda.$(manext) pdflatex.$(manext) kpsepath.$(manext) \
|
||||
- kpsexpand.$(manext) mf-nowin.$(manext) ctangle.$(manext) \
|
||||
+ cd $(man1dir); rm -f \
|
||||
+ lambda.$(manext) pdflatex.$(manext) \
|
||||
+ mf-nowin.$(manext) ctangle.$(manext) \
|
||||
cweave.$(manext) odvicopy.$(manext) \
|
||||
- odvitype.$(manext) texconfig-sys.$(manext) \
|
||||
- updmap-sys.$(manext) mktexfmt.$(manext) fmtutil-sys.$(manext)
|
||||
- ln -s allcm.$(manext) $(man1dir)/allec.$(manext)
|
||||
- ln -s mktexlsr.$(manext) $(man1dir)/texhash.$(manext)
|
||||
+ odvitype.$(manext)
|
||||
ln -s omega.$(manext) $(man1dir)/lambda.$(manext)
|
||||
ln -s pdfetex.$(manext) $(man1dir)/pdflatex.$(manext)
|
||||
- ln -s kpsetool.$(manext) $(man1dir)/kpsepath.$(manext)
|
||||
- ln -s kpsetool.$(manext) $(man1dir)/kpsexpand.$(manext)
|
||||
ln -s mf.$(manext) $(man1dir)/mf-nowin.$(manext)
|
||||
ln -s cweb.$(manext) $(man1dir)/ctangle.$(manext)
|
||||
ln -s cweb.$(manext) $(man1dir)/cweave.$(manext)
|
||||
ln -s dvicopy.$(manext) $(man1dir)/odvicopy.$(manext)
|
||||
ln -s dvitype.$(manext) $(man1dir)/odvitype.$(manext)
|
||||
- ln -s texconfig.$(manext) $(man1dir)/texconfig-sys.$(manext)
|
||||
- ln -s updmap.$(manext) $(man1dir)/updmap-sys.$(manext)
|
||||
- ln -s fmtutil.$(manext) $(man1dir)/mktexfmt.$(manext)
|
||||
- ln -s fmtutil.$(manext) $(man1dir)/fmtutil-sys.$(manext)
|
||||
test -r ./latex.info || cd $(srcdir) && for i in latex.info*; do \
|
||||
$(INSTALL_DATA) $$i $(infodir)/$$i; done
|
||||
if $(SHELL) -c 'install-info --version' >/dev/null 2>&1; then \
|
||||
@@ -74,14 +57,6 @@ install-data:: $(INFOFILES)
|
||||
for p in TETEXDOC.pdf TETEXDOC.ps TETEXDOC.dvi teTeX-FAQ; do \
|
||||
$(INSTALL_DATA) $(srcdir)/doc/$$p $(texmf)/doc/tetex; \
|
||||
done
|
||||
- $(SHELL) $(top_srcdir)/../mkinstalldirs $(texmf)/texconfig $(texmf)/texconfig/g $(texmf)/texconfig/v $(texmf)/texconfig/x
|
||||
- $(INSTALL_DATA) $(srcdir)/texmf/texconfig/g/generic $(texmf)/texconfig/g
|
||||
- $(INSTALL_DATA) $(srcdir)/texmf/texconfig/v/vt100 $(texmf)/texconfig/v
|
||||
- $(INSTALL_DATA) $(srcdir)/texmf/texconfig/x/xterm $(texmf)/texconfig/x
|
||||
- $(INSTALL_DATA) $(srcdir)/texmf/texconfig/README $(texmf)/texconfig
|
||||
- $(INSTALL_DATA) $(srcdir)/texmf/texconfig/generic $(texmf)/texconfig
|
||||
- $(INSTALL_SCRIPT) $(srcdir)/tcfmgr $(texmf)/texconfig/tcfmgr
|
||||
- $(INSTALL_DATA) $(srcdir)/tcfmgr.map $(texmf)/texconfig/tcfmgr.map
|
||||
|
||||
install-exec:
|
||||
-$(SHELL) $(srcdir)/../mkinstalldirs $(scriptdir)
|
||||
@@ -96,16 +71,10 @@ install-exec:
|
||||
else \
|
||||
true; \
|
||||
fi
|
||||
- cd $(scriptdir); rm -f allec kpsepath kpsexpand texhash; \
|
||||
- ln -s allcm allec; \
|
||||
- ln -s kpsetool kpsepath; \
|
||||
- ln -s kpsetool kpsexpand; \
|
||||
- ln -s mktexlsr texhash
|
||||
cd $(scriptdir); rm -f $(PERLWRAPPED); \
|
||||
for f in $(PERLWRAPPED); do \
|
||||
ln -s texexec $$f; \
|
||||
done
|
||||
- cd $(scriptdir); rm -f mktexfmt; ln -s fmtutil mktexfmt
|
||||
|
||||
ac_include ../make/clean.mk
|
||||
|
Loading…
Reference in a new issue