Use correct users for owning binaries and manual pages.
This commit is contained in:
parent
ddf91a9494
commit
7058bfac97
2 changed files with 26 additions and 34 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.2 1999/04/10 16:41:21 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.3 1999/04/10 17:22:43 tron Exp $
|
||||
|
||||
DISTNAME= sendmail.8.9.3
|
||||
PKGNAME= sendmail-8.9.3
|
||||
|
@ -14,7 +14,8 @@ DEPENDS+= db-2.7.3:../../databases/db
|
|||
LICENSE= no-profit
|
||||
|
||||
NO_CONFIGURE= yes
|
||||
MAKE_ENV+= MANOWN="${MANOWN}" MANGRP="${MANGRP}" MANMODE="${MANMODE}"
|
||||
MAKE_ENV+= BSD_BINOWN="${BINOWN}" BSD_BINGRP="${BINGRP}" \
|
||||
BSD_MANOWN="${MANOWN}" BSD_MANGRP="${MANGRP}"
|
||||
|
||||
MESSAGE_FILE= ${WRKDIR}/MESSAGE
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME}
|
||||
|
|
|
@ -1,33 +1,24 @@
|
|||
$NetBSD: patch-aa,v 1.2 1999/04/10 16:41:21 tron Exp $
|
||||
$NetBSD: patch-aa,v 1.3 1999/04/10 17:22:43 tron Exp $
|
||||
|
||||
--- src/Makefile.m4.orig Sun Jan 24 00:51:41 1999
|
||||
+++ src/Makefile.m4 Sat Apr 10 18:04:54 1999
|
||||
@@ -27,7 +27,7 @@
|
||||
MAPDEF= ifdef(`confMAPDEF', `confMAPDEF')
|
||||
|
||||
# environment definitions (e.g., -D_AIX3)
|
||||
-ENVDEF= ifdef(`confENVDEF', `confENVDEF')
|
||||
+ENVDEF= ifdef(`confENVDEF', `confENVDEF') -DTCPWRAPPERS
|
||||
|
||||
# see also conf.h for additional compilation flags
|
||||
|
||||
@@ -42,7 +42,7 @@
|
||||
|
||||
# libraries required on your system
|
||||
# delete -l44bsd if you are not running BIND 4.9.x
|
||||
-LIBS= ifdef(`confLIBS', `confLIBS')
|
||||
+LIBS= ifdef(`confLIBS', `confLIBS') -lwrap
|
||||
|
||||
# location of sendmail binary (usually /usr/sbin or /usr/lib)
|
||||
BINDIR= ${DESTDIR}ifdef(`confMBINDIR', `confMBINDIR', `/usr/sbin')
|
||||
@@ -87,10 +87,6 @@
|
||||
BINOWN= ifdef(`confSBINOWN', `confSBINOWN', `root')
|
||||
BINGRP= ifdef(`confSBINGRP', `confSBINGRP', `kmem')
|
||||
BINMODE=ifdef(`confSBINMODE', `confSBINMODE', `4555')
|
||||
-
|
||||
-MANOWN= ifdef(`confMANOWN', `confMANOWN', `bin')
|
||||
-MANGRP= ifdef(`confMANGRP', `confMANGRP', `bin')
|
||||
-MANMODE=ifdef(`confMANMODE', `confMANMODE', `444')
|
||||
|
||||
MANROOT=${DESTDIR}ifdef(`confMANROOT', `confMANROOT', `/usr/share/man/cat')
|
||||
MAN1= ${MANROOT}ifdef(`confMAN1', `confMAN1', `1')
|
||||
--- BuildTools/OS/NetBSD.orig Tue Dec 29 18:39:50 1998
|
||||
+++ BuildTools/OS/NetBSD Sat Apr 10 19:13:10 1999
|
||||
@@ -1,4 +1,18 @@
|
||||
# @(#)NetBSD 8.6 (Berkeley) 3/12/1998
|
||||
define(`confMAPDEF', `-DNEWDB -DNIS -DMAP_REGEX')
|
||||
-define(`confENVDEF', ` -DNETISO')
|
||||
+define(`confENVDEF', ` -DNETISO -I${PREFIX}/include/db2')
|
||||
define(`confDEPEND_TYPE', `CC-M')
|
||||
+define(`confLIBS', `-L${PREFIX}/lib -ldb2')
|
||||
+define(`confEBINDIR', `${PREFIX}/libexec/sendmail')
|
||||
+define(`confMBINDIR', `${PREFIX}/libexec/sendmail')
|
||||
+define(`confSBINDIR', `${PREFIX}/sbin')
|
||||
+define(`confUBINDIR', `${PREFIX}/bin')
|
||||
+define(`confHFDIR', `${PREFIX}/share/misc')
|
||||
+define(`confBINOWN', `${BSD_BINOWN}')
|
||||
+define(`confBINGRP', `${BSD_BINGRP}')
|
||||
+define(`confMANOWN', `${BSD_MANOWN}')
|
||||
+define(`confMANGRP', `${BSD_MANGRP}')
|
||||
+define(`confMANROOT', `${PREFIX}/man/cat')
|
||||
+define(`confMAN1EXT', `0')
|
||||
+define(`confMAN5EXT', `0')
|
||||
+define(`confMAN8EXT', `0')
|
||||
|
|
Loading…
Reference in a new issue