Pull in a fix from ASG CVS: increase maxoutbuf buffer size

This allows uploading of SIEVE scripts larger than 4kb if GSSAPI
authentification is used for cyrus-imapd.

link to the patch provided by Jukka Salmi in PR 26165

bump PKGREVISION to 1
This commit is contained in:
recht 2004-07-05 16:49:18 +00:00
parent 2c0cd73268
commit 70a0a95356
3 changed files with 17 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.28 2004/03/29 05:47:31 jlam Exp $
# $NetBSD: Makefile,v 1.29 2004/07/05 16:49:18 recht Exp $
.include "Makefile.common"
PKGREVISION= 1
SVR4_PKGNAME= csasl
COMMENT= Simple Authentication and Security Layer

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.16 2004/03/29 05:47:31 jlam Exp $
$NetBSD: distinfo,v 1.17 2004/07/05 16:49:18 recht Exp $
SHA1 (cyrus-sasl-2.1.18.tar.gz) = 74496a61a87edd710303d13f8df0534d6765f6ec
Size (cyrus-sasl-2.1.18.tar.gz) = 1522578 bytes
@ -14,3 +14,4 @@ SHA1 (patch-al) = f4a2c97d4894a4089b6960bf5a2542dfdec4df6e
SHA1 (patch-am) = f0bd15b4f55e5204936a25c558d4bd2b1d4816d5
SHA1 (patch-an) = d6ccabc24d16b63a1c1f4b4f2667b60c37aa88ec
SHA1 (patch-ao) = 727830d2f72d6a18a8f0f2959c76dee0c58c5b2c
SHA1 (patch-ap) = 87054f52d3a9874f6849994d593938db9b885088

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ap,v 1.1 2004/07/05 16:49:18 recht Exp $
--- plugins/gssapi.c.orig 2004-02-06 18:23:51.000000000 +0100
+++ plugins/gssapi.c 2004-07-05 18:41:39.000000000 +0200
@@ -1419,7 +1419,7 @@
if(oparams->mech_ssf) {
/* xxx probably too large */
- oparams->maxoutbuf -= 50;
+ oparams->maxoutbuf -= 256;
}
gss_release_buffer(&min_stat, output_token);