Fix build with ruby-1.9, based on a suggestion by taca@.

This commit is contained in:
wiz 2010-09-25 10:16:45 +00:00
parent 3277013464
commit 70ac317542
3 changed files with 31 additions and 1 deletions

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.2 2010/09/17 08:04:15 wiz Exp $
$NetBSD: distinfo,v 1.3 2010/09/25 10:16:45 wiz Exp $
SHA1 (mxcl-liblastfm-0.3.2-0-gc64ed83.tar.gz) = 6e43e01628ada589999dde8043bb99dd6e8eee56
RMD160 (mxcl-liblastfm-0.3.2-0-gc64ed83.tar.gz) = c3368084e6f6e4ce7471081491a9468a4a48c11f
Size (mxcl-liblastfm-0.3.2-0-gc64ed83.tar.gz) = 111666 bytes
SHA1 (patch-aa) = 2e25caf9c7e15f1c2c5a6b1d3e1ae3539710ac86
SHA1 (patch-ab) = f9d88de85576479c903ebd165df077050f35c70e

View file

@ -0,0 +1,14 @@
$NetBSD: patch-aa,v 1.1 2010/09/25 10:16:46 wiz Exp $
ruby-1.9 doesn't have "." in default search path.
--- admin/qpp.orig 2010-09-11 14:16:54.000000000 +0000
+++ admin/qpp
@@ -3,6 +3,7 @@
# RESOURCES under each argument to ARGV as directories
cwd=File.dirname __FILE__
+$:.push(".")
require 'find'
require "#{cwd}/findsrc"

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ab,v 1.1 2010/09/25 10:16:46 wiz Exp $
ruby-1.9 doesn't have "." in default search path.
--- admin/Makefile.rb.orig 2010-09-25 10:12:30.000000000 +0000
+++ admin/Makefile.rb
@@ -5,6 +5,7 @@
# class names in there which #include the file that contains the class
cwd = File.dirname( __FILE__ )
+$:.push(".")
require 'find'
require "#{cwd}/platform.rb"