Add casts for amd64, reported by Rhialto.

Fix typos in SUBST_MESSAGE*
Add missing x11.buildlink3.mk.
Remove two files from PLIST, because they are not built on my 3.99.18/i386
test system. Bump PKGREVISION.
This commit is contained in:
wiz 2006-04-28 23:16:28 +00:00
parent f975b511e9
commit 70adf8ecec
7 changed files with 72 additions and 17 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.34 2006/04/28 20:13:27 joerg Exp $
# $NetBSD: Makefile,v 1.35 2006/04/28 23:16:28 wiz Exp $
#
DISTNAME= vlc-${VLC_VER}
PKGREVISION= 12
PKGREVISION= 13
CATEGORIES= multimedia
MASTER_SITES= http://download.videolan.org/pub/videolan/vlc/${VLC_VER}/
EXTRACT_SUFX= .tar.bz2
@ -61,12 +61,11 @@ SUBST_FILES.oss+= modules/access/v4l/v4l.c
SUBST_FILES.oss+= modules/audio_output/oss.c
SUBST_FILES.oss+= modules/gui/pda/pda_interface.c
SUBST_FILES.oss+= modules/gui/pda/pda.glade
SUBST_FILES.oss+= modules/gui/wxwindows/v4l.cpp
SUBST_MESSAGE.oss= Fixing harcoded audio device.
SUBST_MESSAGE.oss= Fixing hardcoded audio device.
SUBST_STAGE.fnt= post-patch
SUBST_SED.fnt= -e "s,${ORIGFNT},${DEFAULT_FONT},"
SUBST_FILES.fnt= modules/misc/freetype.c
SUBST_MESSAGE.fnt= Fixing harcoded paths.
SUBST_MESSAGE.fnt= Fixing hardcoded paths.
SUBST_STAGE.libav= post-patch
SUBST_FILES.libav= configure
SUBST_SED.libav= -e "s,libavcodec/libavcodec.a,libavcodec.a,g"
@ -99,4 +98,5 @@ BUILDLINK_TRANSFORM.ffmpeg+= -e "s,include/ffmpeg,include/,g"
.include "../../mk/oss.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/x11.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST.common,v 1.3 2006/04/28 20:13:27 joerg Exp $
@comment $NetBSD: PLIST.common,v 1.4 2006/04/28 23:16:28 wiz Exp $
bin/vlc
bin/vlc-config
bin/wxvlc
@ -17,12 +17,10 @@ lib/vlc/access/libaccess_http_plugin.so
lib/vlc/access/libaccess_mms_plugin.so
lib/vlc/access/libaccess_tcp_plugin.so
lib/vlc/access/libaccess_udp_plugin.so
lib/vlc/access/libcddax_plugin.so
${DVDCSS}lib/vlc/access/libdvd_plugin.so
lib/vlc/access/libdvdplay_plugin.so
lib/vlc/access/libdvdread_plugin.so
lib/vlc/access/libslp_plugin.so
lib/vlc/access/libvcdx_plugin.so
lib/vlc/access_output/libaccess_output_dummy_plugin.so
lib/vlc/access_output/libaccess_output_file_plugin.so
lib/vlc/access_output/libaccess_output_http_plugin.so

View file

@ -1,7 +1,10 @@
$NetBSD: distinfo,v 1.6 2005/11/11 23:39:35 wiz Exp $
$NetBSD: distinfo,v 1.7 2006/04/28 23:16:28 wiz Exp $
SHA1 (vlc-0.7.2.tar.bz2) = 938eaea128af02451fcbf0305c84ce290c9d8c21
RMD160 (vlc-0.7.2.tar.bz2) = 05e35e0b9080581cfbc730212fc756cb46bd3257
Size (vlc-0.7.2.tar.bz2) = 4516835 bytes
SHA1 (patch-aa) = 21a4e5da2ca4f758be1be48e23f28a764a38f1d0
SHA1 (patch-aa) = 03e66c696c8d1491a91b17a1321144a844b94cf1
SHA1 (patch-ab) = 5f1cb287981d79533aedeb176c0219a815b8bf52
SHA1 (patch-ac) = aec258582e1d18ccb1efc3ce74e9f949046d61b1
SHA1 (patch-ad) = e12945776db476e48ce005b6d68f9931ddcbe020
SHA1 (patch-ae) = 1dcc0466a362fcdf51fbce8869cd1a48d35d3909

View file

@ -1,9 +1,8 @@
$NetBSD: patch-aa,v 1.2 2004/07/29 19:04:58 wiz Exp $
$NetBSD: patch-aa,v 1.3 2006/04/28 23:16:29 wiz Exp $
--- modules/misc/network/ipv4.c.orig Tue Jul 27 19:01:35 2004
+++ modules/misc/network/ipv4.c Tue Jul 27 19:02:52 2004
@@ -405,9 +405,13 @@
#if !defined( UNDER_CE ) && !defined( SYS_BEOS )
--- modules/misc/network/ipv4.c.orig 2004-05-16 17:44:52.000000000 +0000
+++ modules/misc/network/ipv4.c
@@ -406,7 +406,11 @@ static int OpenUDP( vlc_object_t * p_thi
if( IN_MULTICAST( ntohl(inet_addr(psz_server_addr) ) ) )
{
/* set the time-to-live */
@ -15,5 +14,3 @@ $NetBSD: patch-aa,v 1.2 2004/07/29 19:04:58 wiz Exp $
if( ttl < 1 )
{
ttl = config_GetInt( p_this, "ttl" );
}

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ac,v 1.1 2006/04/28 23:16:29 wiz Exp $
--- modules/gui/wxwindows/open.cpp.orig 2004-05-21 11:24:58.000000000 +0000
+++ modules/gui/wxwindows/open.cpp
@@ -382,7 +382,7 @@ OpenDialog::OpenDialog( intf_thread_t *_
wxU(_("Open:")) );
mrl_combo = new wxComboBox( panel, MRL_Event, wxT(""),
wxPoint(20,25), wxSize(120, -1),
- 0, NULL );
+ 0, (const wxString*)NULL );
mrl_combo->SetToolTip( wxU(_("You can use this field directly by typing "
"the full MRL you want to open.\n""Alternatively, the field will be "
"filled automatically when you use the controls below.")) );
@@ -563,7 +563,7 @@ wxPanel *OpenDialog::FilePanel( wxWindow
wxBoxSizer *file_sizer = new wxBoxSizer( wxHORIZONTAL );
file_combo = new wxComboBox( panel, FileName_Event, wxT(""),
- wxPoint(20,25), wxSize(200, -1), 0, NULL );
+ wxPoint(20,25), wxSize(200, -1), 0, (const wxString*)NULL );
wxButton *browse_button = new wxButton( panel, FileBrowse_Event,
wxU(_("Browse...")) );
file_sizer->Add( file_combo, 1, wxALL, 5 );

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ad,v 1.1 2006/04/28 23:16:29 wiz Exp $
--- modules/gui/wxwindows/streamout.cpp.orig 2004-05-16 11:42:29.000000000 +0000
+++ modules/gui/wxwindows/streamout.cpp
@@ -166,7 +166,7 @@ SoutDialog::SoutDialog( intf_thread_t *_
wxStaticText *mrl_label = new wxStaticText( panel, -1,
wxU(_("Destination Target:")));
mrl_combo = new wxComboBox( panel, MRL_Event, wxT(""),
- wxPoint(20,25), wxSize(120, -1), 0, NULL );
+ wxPoint(20,25), wxSize(120, -1), 0, (const wxString*)NULL );
mrl_combo->SetToolTip( wxU(_("You can use this field directly by typing "
"the full MRL you want to open.\n""Alternatively, the field will be "
"filled automatically when you use the controls below")) );
@@ -447,7 +447,7 @@ wxPanel *SoutDialog::AccessPanel( wxWind
subpanel_sizer = new wxFlexGridSizer( 3, 2, 20 );
label = new wxStaticText( access_subpanels[1], -1, wxU(_("Filename")) );
file_combo = new wxComboBox( access_subpanels[1], FileName_Event, wxT(""),
- wxPoint(20,25), wxSize(200, -1), 0, NULL );
+ wxPoint(20,25), wxSize(200, -1), 0, (const wxString*)NULL );
wxButton *browse_button = new wxButton( access_subpanels[1],
FileBrowse_Event, wxU(_("Browse...")) );
subpanel_sizer->Add( label, 0, wxALIGN_RIGHT | wxALIGN_CENTER_VERTICAL );

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1 2006/04/28 23:16:29 wiz Exp $
--- modules/gui/wxwindows/subtitles.cpp.orig 2004-03-05 19:25:18.000000000 +0000
+++ modules/gui/wxwindows/subtitles.cpp
@@ -85,7 +85,7 @@ SubsFileDialog::SubsFileDialog( intf_thr
char *psz_subsfile = config_GetPsz( p_intf, "sub-file" );
if( !psz_subsfile ) psz_subsfile = strdup("");
file_combo = new wxComboBox( panel, -1, wxL2U(psz_subsfile),
- wxPoint(20,25), wxSize(300, -1), 0, NULL );
+ wxPoint(20,25), wxSize(300, -1), 0, (const wxString *)NULL );
if( psz_subsfile ) free( psz_subsfile );
wxButton *browse_button = new wxButton( panel, FileBrowse_Event,
wxU(_("Browse...")) );