Add patch from Scott Presnell in PR 29701:

The package smartmontools version 5.32 uses wrong units for SCSI
timeout in os_netbsd.c.

Double checked by thorpej.

Bump PKGREVISION.
This commit is contained in:
wiz 2005-03-17 16:33:23 +00:00
parent db2d4be8ab
commit 70b8813025
3 changed files with 17 additions and 3 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.4 2005/01/02 20:29:16 jlam Exp $
# $NetBSD: Makefile,v 1.5 2005/03/17 16:33:23 wiz Exp $
DISTNAME= smartmontools-5.32
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=smartmontools/}

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.3 2005/02/24 13:40:57 agc Exp $
$NetBSD: distinfo,v 1.4 2005/03/17 16:33:23 wiz Exp $
SHA1 (smartmontools-5.32.tar.gz) = 2af09136578ea59565ad00b3638afe9700ed26a2
RMD160 (smartmontools-5.32.tar.gz) = 6692df8996bc3f6a1b52b10286d92b116874e1cd
Size (smartmontools-5.32.tar.gz) = 408224 bytes
SHA1 (patch-aa) = 2f22d9bd911ce825c1ca888cceb4535bba606671
SHA1 (patch-ab) = c82137592289bedbed7b1980de9dd8a3aa6c4d85

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2005/03/17 16:33:23 wiz Exp $
--- os_netbsd.c.orig 2004-04-20 06:53:26.000000000 +0200
+++ os_netbsd.c
@@ -381,7 +381,7 @@ do_scsi_cmnd_io(int fd, struct scsi_cmnd
sc.databuf = iop->dxferp;
sc.datalen = iop->dxfer_len;
sc.senselen = iop->max_sense_len;
- sc.timeout = iop->timeout == 0 ? 60000 : iop->timeout; /* XXX */
+ sc.timeout = iop->timeout == 0 ? 60000 : (iop->timeout * 1000); /* XXX */
sc.flags =
(iop->dxfer_dir == DXFER_NONE ? SCCMD_READ : /* XXX */
(iop->dxfer_dir == DXFER_FROM_DEVICE ? SCCMD_READ : SCCMD_WRITE));