Update to 0.6.0
While here, clean it up a bit: don't install to X11BASE buildlink'ify homepage moved archive is downloadable, remove NO_SRC_ON_FTP Changes between 0.5.2 and 0.6.0: - Possibility to invoke user-defined external commands from the context menu in the browser listbox, e.g. to program a timer for the selected programme in a scheduler like plan. - Dump of programme list or selected programme descriptions into a file in HTML format, from where they can be loaded by any WWW browser. This may be of interest for people who want to print out TV schedules onto dead trees. - New text search option Match full to allow exact title matches, e.g. a search for "heute" will no longer match on "heute journal" when full match is enabled. - Alphabetically sorted series list in the filter menu.
This commit is contained in:
parent
402cf3dc81
commit
70cc2b61c4
4 changed files with 42 additions and 37 deletions
|
@ -1,25 +1,19 @@
|
|||
# $NetBSD: Makefile,v 1.8 2001/06/15 19:49:21 magick Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2001/08/26 14:15:32 magick Exp $
|
||||
|
||||
DISTNAME= nxtvepg-0.5.2
|
||||
DISTNAME= nxtvepg-0.6.0
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://www.nefkom.net/tomzo/prj/nxtvepg/src/
|
||||
|
||||
MAINTAINER= magick@zhadum.de
|
||||
HOMEPAGE= http://nxtvepg.tripod.com/
|
||||
HOMEPAGE= http://www.nefkom.net/tomzo/prj/nxtvepg/
|
||||
COMMENT= NextView EPG decoder
|
||||
|
||||
DEPENDS+= tk>=8.3.2:../../x11/tk
|
||||
|
||||
ONLY_FOR_PLATFORM= NetBSD-1.4[Y-Z]-* NetBSD-1.4Z[A-Z]-* \
|
||||
NetBSD-1.5_ALPHA-* NetBSD-1.[5-9]*-*
|
||||
|
||||
NO_SRC_ON_FTP= Already in MASTER_SITE_LOCAL
|
||||
|
||||
USE_X11BASE= yes
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAKE_ENV+= X11PREFIX=${X11PREFIX}
|
||||
USE_X11= yes
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC}; \
|
||||
|
@ -27,4 +21,5 @@ pre-configure:
|
|||
${SED} -e "s|@PERL5@|${PERL5}|g" pod2help.pl.orig > pod2help.pl; \
|
||||
${CHMOD} +x ${WRKSRC}/pod2help.pl
|
||||
|
||||
.include "../../x11/tk/buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.6 2001/06/15 19:49:21 magick Exp $
|
||||
$NetBSD: distinfo,v 1.7 2001/08/26 14:15:32 magick Exp $
|
||||
|
||||
SHA1 (nxtvepg-0.5.2.tar.gz) = 0e20a6e6d92630ba15b4527ecfb1e3addeed993b
|
||||
Size (nxtvepg-0.5.2.tar.gz) = 337928 bytes
|
||||
SHA1 (patch-aa) = e7efa2a757405c82d35c36025564551e0e568af6
|
||||
SHA1 (patch-ab) = 057fd7fc5e08a198e4ea800bfcb1dadf03363ce0
|
||||
SHA1 (nxtvepg-0.6.0.tar.gz) = a10876b7c41d98d7bf1888838bcfe17b9a820a8b
|
||||
Size (nxtvepg-0.6.0.tar.gz) = 384485 bytes
|
||||
SHA1 (patch-aa) = c58883ef57bc1a6a72964aa8a35885c76d909c9b
|
||||
SHA1 (patch-ab) = 634cfd179fd1043e3272ce27836a9052b199d1f4
|
||||
SHA1 (patch-ac) = 2a72e3ea0abdf0ec8e1514c7067576448bc82cdc
|
||||
SHA1 (patch-ad) = bd176db9fedd6c21be8967a577af45956985113c
|
||||
SHA1 (patch-ae) = e73e5bd9b08f58d7301fa19237861cada6e9b6fe
|
||||
|
|
|
@ -1,54 +1,64 @@
|
|||
$NetBSD: patch-aa,v 1.4 2001/06/09 15:14:26 magick Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2001/08/26 14:15:32 magick Exp $
|
||||
|
||||
--- Makefile.orig Mon Jun 4 21:25:11 2001
|
||||
--- Makefile.orig Sat Aug 25 15:22:17 2001
|
||||
+++ Makefile
|
||||
@@ -32,33 +32,33 @@
|
||||
include Makefile.win32
|
||||
@@ -33,36 +33,41 @@
|
||||
else
|
||||
|
||||
-IROOT = /usr/local
|
||||
+IROOT = $(X11PREFIX)
|
||||
BINDIR = $(IROOT)/bin
|
||||
MANDIR = $(IROOT)/man/man1
|
||||
ROOT =
|
||||
-prefix = /usr/local
|
||||
+prefix = ${PREFIX}
|
||||
exec_prefix = ${prefix}
|
||||
bindir = $(ROOT)${exec_prefix}/bin
|
||||
mandir = $(ROOT)${prefix}/man/man1
|
||||
|
||||
# if you have perl set the path here, else just leave it alone
|
||||
-PERL = /usr/bin/perl
|
||||
+PERL = $(LOCALBASE)/bin/perl
|
||||
+PERL = ${LOCALBASE}/bin/perl
|
||||
|
||||
-LDLIBS = -ltk8.3 -ltcl8.3 -L/usr/X11R6/lib -lX11 -lXmu -lm -ldl
|
||||
+LDLIBS = -ltk83 -ltcl83 -L$(X11BASE)/lib -lX11 -lm -lXmu
|
||||
+#LDLIBS = -ltk8.3 -ltcl8.3 -L/usr/X11R6/lib -lX11 -lXmu -lm -ldl
|
||||
+LDLIBS = -ltk83 -ltcl83 -lX11 -lXmu -lm
|
||||
# use static libraries for debugging only
|
||||
#LDLIBS = dbglib/libtk8.3.a dbglib/libtcl8.3.a -lX11 -lm -ldl -L/usr/X11R6/lib
|
||||
|
||||
-INCS += -I. -I/usr/X11R6/include
|
||||
+INCS += -I. -I$(X11BASE)/include -I$(LOCALBASE)/include
|
||||
+#INCS += -I. -I/usr/X11R6/include
|
||||
+INCS += -I. -I${X11BASE}/include
|
||||
# path to Tcl/Tk headers, if not properly installed
|
||||
#INCS += -I/usr/local/tcl/tcl8.0/generic -I/usr/local/tcl/tk8.0/generic
|
||||
|
||||
# path to Tcl/Tk script library (Tk is usually in X11/lib/tk#.#)
|
||||
-DEFS += -DTK_LIBRARY_PATH=\"/usr/lib/tk8.3\"
|
||||
-DEFS += -DTCL_LIBRARY_PATH=\"/usr/lib/tcl8.3\"
|
||||
+-DEFS += -DTK_LIBRARY_PATH=\"/usr/lib/tk8.3\"
|
||||
+-DEFS += -DTCL_LIBRARY_PATH=\"/usr/lib/tcl8.3\"
|
||||
+DEFS += -DTK_LIBRARY_PATH=\"$(LOCALBASE)/lib/tk8.3\"
|
||||
+DEFS += -DTCL_LIBRARY_PATH=\"$(LOCALBASE)/lib/tcl8.3\"
|
||||
|
||||
# path to the directory where the provider database files are kept
|
||||
-DEFS += -DEPG_DB_DIR=\"/usr/tmp/nxtvdb\"
|
||||
+DEFS += -DEPG_DB_DIR=_PATH_TMP\"nxtvdb\"
|
||||
-DB_DIR = /usr/tmp/nxtvdb
|
||||
-DEFS += -DEPG_DB_DIR=\"$(DB_DIR)\"
|
||||
+#DB_DIR = /usr/tmp/nxtvdb
|
||||
+DB_DIR = _PATH_TMP\"nxtvdb\"
|
||||
+DEFS += -DEPG_DB_DIR=$(DB_DIR)
|
||||
INST_DB_DIR = $(ROOT)$(DB_DIR)
|
||||
|
||||
#WARN = -Wall -Wpointer-arith -Wnested-externs \
|
||||
# -Werror -Wstrict-prototypes -Wmissing-prototypes
|
||||
WARN = -Wall
|
||||
CC = gcc
|
||||
-CFLAGS = -pipe $(WARN) $(INCS) $(DEFS) -O2
|
||||
+CFLAGS += $(WARN) $(INCS) $(DEFS)
|
||||
+CFLAGS = -pipe $(WARN) $(INCS) $(DEFS)
|
||||
|
||||
# ----- don't change anything below ------------------------------------------
|
||||
|
||||
@@ -85,7 +85,6 @@
|
||||
test -d $(MANDIR) || mkdirhier $(MANDIR)
|
||||
install -c -m 0755 nxtvepg $(BINDIR)
|
||||
install -c -m 0644 nxtvepg.1 $(MANDIR)
|
||||
- rm -f $(MANDIR)/nxtvepg.1x
|
||||
@@ -91,7 +96,7 @@
|
||||
chmod 0777 $(INST_DB_DIR)
|
||||
install -c -m 0755 nxtvepg $(bindir)
|
||||
install -c -m 0644 nxtvepg.1 $(mandir)
|
||||
- rm -f $(mandir)/nxtvepg.1x
|
||||
+# rm -f $(mandir)/nxtvepg.1x
|
||||
|
||||
##%.o: %.c
|
||||
## $(CC) $(CFLAGS) -c *.c -o *.o
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-ab,v 1.2 2001/05/23 21:06:02 jlam Exp $
|
||||
$NetBSD: patch-ab,v 1.3 2001/08/26 14:15:32 magick Exp $
|
||||
|
||||
--- pod2help.pl.orig Sun Dec 31 00:08:28 2000
|
||||
+++ pod2help.pl Sun Feb 18 20:10:13 2001
|
||||
--- pod2help.pl.orig Sun Aug 26 10:07:03 2001
|
||||
+++ pod2help.pl
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/perl
|
||||
+#!@PERL5@
|
||||
|
|
Loading…
Reference in a new issue