Update gucharmap-2 patch more better:

* fixes memory leak.
 * made assertion free.

Bump PKGREVISION.
This commit is contained in:
obache 2010-06-27 08:05:31 +00:00
parent 42b74ffd5c
commit 7106502f85
3 changed files with 12 additions and 8 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.3 2010/06/13 22:44:50 wiz Exp $
# $NetBSD: Makefile,v 1.4 2010/06/27 08:05:31 obache Exp $
#
DISTNAME= scim-tomoe-0.6.0
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= inputmethod
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=tomoe/}

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.2 2010/05/28 09:31:35 obache Exp $
$NetBSD: distinfo,v 1.3 2010/06/27 08:05:31 obache Exp $
SHA1 (scim-tomoe-0.6.0.tar.gz) = 481ee2f8f9baa6105a349da36360aed06e432291
RMD160 (scim-tomoe-0.6.0.tar.gz) = c95059e7f594192c97b082aa61818060391a8591
Size (scim-tomoe-0.6.0.tar.gz) = 385126 bytes
SHA1 (patch-aa) = 0554574908f37adae9d8771dcadce2e038c5857a
SHA1 (patch-ab) = 1c598b251d218a9f1da7c089dd51780e97108d40
SHA1 (patch-ab) = 5448d662f687276b80831c6473ee8a5a1f35c5e3

View file

@ -1,18 +1,22 @@
$NetBSD: patch-ab,v 1.1 2010/05/28 09:31:35 obache Exp $
$NetBSD: patch-ab,v 1.2 2010/06/27 08:05:31 obache Exp $
support gucharmap-2
--- src/scim_tomoe_prefs_widget.cpp.orig 2007-05-07 07:49:15.000000000 +0000
+++ src/scim_tomoe_prefs_widget.cpp
@@ -472,9 +472,9 @@ apply_config (ScimTomoePrefsWidget *pref
@@ -472,9 +472,13 @@ apply_config (ScimTomoePrefsWidget *pref
String (SCIM_TOMOE_CONFIG_UNICODE_TABLE_FONT_DEFAULT));
if (font.length() > 0) {
- gucharmap_charmap_set_font (charmap, font.c_str ());
+ gucharmap_charmap_set_font_desc (charmap, pango_font_description_from_string(font.c_str ()));
+ PangoFontDescription *desc = pango_font_description_from_string(font.c_str ());
+ gucharmap_charmap_set_font_desc (charmap, desc);
+ pango_font_description_free (desc);
} else {
- gucharmap_charmap_set_font (charmap, NULL);
+ gucharmap_charmap_set_font_desc (charmap, pango_font_description_from_string(NULL));
+ PangoFontDescription *desc = pango_font_description_new ();
+ gucharmap_charmap_set_font_desc (charmap, desc);
+ pango_font_description_free (desc);
set_default_font (prefs, SCIM_TOMOE_CONFIG_CAND_FONT,
GTK_WIDGET (charmap));
}