update to gwave-20060606

Most of the previous pkgsrc patches have been incorporated upstream (yay!).

New in 20060606
- ??

New in 20051222
- full-height vertical scrollbar appears if the total height of all
panels becomes larger than the window.
- new panel type "jumbo" stays larger even when things get crowded
- most deprecated guile calls removed.  Guile 1.6 or later is now required.

New in 20050928
- ALPHA RELEASE: may crash.  do not rely on for production use.
- handling of multi-sweep datafiles
- vertical scrollbars on label/measure area in each wavepanel make handling
large numbers of waveforms easier.

New in 20031202
- Got docstring extraction from C source to .txt files in doc directory working again
- applied submitted patch that cleans up warnings from gcc3 about multiline text strings in C code

New in 20030917
- bugfixes to make the new print/plot stuff work better
- path to working gnu graph found by configure is passed to scheme code
This commit is contained in:
dmcmahill 2007-11-15 23:53:48 +00:00
parent 575c30291f
commit 712a4b2905
14 changed files with 28 additions and 675 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.30 2007/06/18 00:41:16 dmcmahill Exp $
# $NetBSD: Makefile,v 1.31 2007/11/15 23:53:48 dmcmahill Exp $
#
DISTNAME= gwave-20030804
PKGREVISION= 6
DISTNAME= gwave-20060606
CATEGORIES= cad
MASTER_SITES= http://www.cs.unc.edu/~tell/dist/
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/dist/ \
http://www.geda.seul.org/dist/
MAINTAINER= dmcmahill@NetBSD.org
HOMEPAGE= http://www.cs.unc.edu/~tell/gwave.html

View file

@ -1,8 +1,9 @@
@comment $NetBSD: PLIST,v 1.2 2003/09/12 20:47:12 dmcmahill Exp $
@comment $NetBSD: PLIST,v 1.3 2007/11/15 23:53:48 dmcmahill Exp $
bin/gwave
bin/gwave-exec
bin/gwaverepl
bin/sp2sp
bin/sweepsplit
man/man1/sp2sp.1
share/guile/app/gwave/cmds.scm
share/guile/app/gwave/dynlink.scm
@ -12,6 +13,7 @@ share/guile/app/gwave/export.scm
share/guile/app/gwave/extra-menus.scm
share/guile/app/gwave/globals.scm
share/guile/app/gwave/gtk-helpers.scm
share/guile/app/gwave/gwave-config.scm
share/guile/app/gwave/gwave-startup.scm
share/guile/app/gwave/minimal.scm
share/guile/app/gwave/std-args.scm

View file

@ -1,16 +1,6 @@
$NetBSD: distinfo,v 1.9 2007/01/23 02:49:23 dmcmahill Exp $
$NetBSD: distinfo,v 1.10 2007/11/15 23:53:48 dmcmahill Exp $
SHA1 (gwave-20030804.tar.gz) = 22983d0b6b646467eab584a6de0aef86d5148186
RMD160 (gwave-20030804.tar.gz) = fd772026b1e62b7ddb7fa24e83bc5cb7678dc86d
Size (gwave-20030804.tar.gz) = 437860 bytes
SHA1 (patch-aa) = ae837194a751eb25bbda4dee551d1d57ec696d24
SHA1 (patch-ab) = cedd28158b2a467c93536ddd5a39dec8dd7d7c64
SHA1 (patch-ac) = 7f535a13925577fa6a3acda2a1ab61eda4a2aad2
SHA1 (patch-ad) = 2378a782cb99a2aebed0e058a88b4343604f38e8
SHA1 (patch-ae) = a3e192f11a6bc8529a9c36f165f29d8944c9930c
SHA1 (patch-af) = 8c3a5811711e521df2835208f7f1d4f421579cd1
SHA1 (patch-ag) = b112064e3abdee36c66df027412580e18f90f686
SHA1 (patch-ah) = 1f66028878250d183d532c36a1602b44f2d6d476
SHA1 (patch-ai) = 4d785aa7dc9b5831b7f3c699cc61f7ecedb37374
SHA1 (patch-aj) = 9783b900e9bbdefef97616109cde1dcac9e45a7a
SHA1 (patch-ak) = 1fb4e1cfb7a9e687b7f76c6479f7857d0c0944c8
SHA1 (gwave-20060606.tar.gz) = e335822815ec7580b1e66ac253fe438ef439dfbe
RMD160 (gwave-20060606.tar.gz) = 67c6e9bb5a001352f627662bd6eb225a78d028e8
Size (gwave-20060606.tar.gz) = 490107 bytes
SHA1 (patch-aa) = 2125f457fccd9f57f700a46852393ae0688be71d

View file

@ -1,102 +1,19 @@
$NetBSD: patch-aa,v 1.4 2003/11/05 22:31:43 dmcmahill Exp $
$NetBSD: patch-aa,v 1.5 2007/11/15 23:53:48 dmcmahill Exp $
--- src/gwave.c.orig 2003-08-04 23:43:45.000000000 -0400
+++ src/gwave.c
@@ -74,30 +74,30 @@ GtkWidget *win_xlabel_left, *win_xlabel_
/* variables accessible from C and guile */
- fix __inline__ which sunpro doesn't like
--- src/scwm_guile.c.orig 2005-12-23 05:07:36.000000000 +0000
+++ src/scwm_guile.c
@@ -42,6 +42,12 @@
#include "dmalloc.h"
#endif
XSCM_VCELL_INIT(scm_gwave_version, "gwave-version-string", gh_str02scm(VERSION),
-"This variable is initialized to contain the version string for gwave, as
-set in configure.in.");
+"This variable is initialized to contain the version string for gwave, as"
+"set in configure.in.");
+#ifndef __GNUC__
+#ifndef __inline__
+#define __inline__
+#endif
+#endif
+
extern char *prog_name;
XSCM_VCELL_INIT(scm_gwave_datadir, "gwave-datadir", gh_str02scm(DATADIR),
-"This variable is initialized to contain the compiled-in pathname to
-the installed data directory, typicaly PREFIX/share, as set by configure.
-It is used by the startup code as a default location for finding gwave's
-guile modules.");
+"This variable is initialized to contain the compiled-in pathname to"
+"the installed data directory, typicaly PREFIX/share, as set by configure."
+"It is used by the startup code as a default location for finding gwave's"
+"guile modules.");
XSCM_VCELL_INIT(scm_gwave_bingwave, "gwave-bin-gwave-path", gh_str02scm(BINGWAVE),
-"This variable is initialized to contain the compiled-in pathname to
-the installed gwave executable, typicaly PREFIX/bin/gwave, as set by configure.
-It is used by the procedures that write out gwave configuration-restoring
-scripts so that when run from the command line command line, the scripts
-can use gwave as their interpreter.");
+"This variable is initialized to contain the compiled-in pathname to"
+"the installed gwave executable, typicaly PREFIX/bin/gwave, as set by configure."
+"It is used by the procedures that write out gwave configuration-restoring"
+"scripts so that when run from the command line command line, the scripts"
+"can use gwave as their interpreter.");
XSCM_VCELL(scm_gwave_debug, "gwave-debug",
-"This variable is set to #t very early in gwave's startup when the -x flag
-is passed on the command line. It enables debugging output to stdout
-in the startup code and in various modules.");
+"This variable is set to #t very early in gwave's startup when the -x flag"
+"is passed on the command line. It enables debugging output to stdout"
+"in the startup code and in various modules.");
XSCM_GLOBAL_VCELL(scm_gwave_tooltips, "gwave-tooltips",
-"This variable is a GtkTooltips object used for controlling all
-of the popup tooltips in the user interface.");
+"This variable is a GtkTooltips object used for controlling all"
+"of the popup tooltips in the user interface.");
/*
* usage -- prints the standard switch info, then exits.
@@ -124,28 +124,28 @@ static void usage(char *fmt, ...)
/* if we don't set up some colors, users without a gwave.gtkrc get black
* waves on black background
*/
-static const gchar *gwave_base_gtkrc = "
-style 'wavecolor0' { fg[NORMAL] = {1.0, 0.0, 0.0} }
-style 'wavecolor1' { fg[NORMAL] = {1.0, 1.0, 0.0} }
-style 'wavecolor2' { fg[NORMAL] = {0.0, 1.0, 0.0} }
-style 'wavecolor3' { fg[NORMAL] = {0.4, 0.5, 1.0} }
-style 'wavecolor4' { fg[NORMAL] = {0.0, 1.0, 1.0} }
-style 'wavecolor5' { fg[NORMAL] = {1.0, 0.0, 1.0} }
-widget '*wavecolor0' style 'wavecolor0'
-widget '*wavecolor1' style 'wavecolor1'
-widget '*wavecolor2' style 'wavecolor2'
-widget '*wavecolor3' style 'wavecolor3'
-widget '*wavecolor4' style 'wavecolor4'
-widget '*wavecolor5' style 'wavecolor5'
-style 'cursor0color' { fg[NORMAL] = {1.0, 1.0, 1.0} }
-style 'cursor1color' { fg[NORMAL] = {1.0, 1.0, 0.0} }
-style 'cursorDcolor' { fg[NORMAL] = {00, 1.0, 0.0} }
-widget '*cursor1color' style 'cursor1color'
-widget '*cursor0color' style 'cursor0color'
-widget '*cursorDcolor' style 'cursorDcolor'
-style 'wavebutton' { bg[NORMAL] = { 0.25, 0.25, 0.25 } }
-widget '*wavebutton' style 'wavebutton'
-";
+static const gchar *gwave_base_gtkrc = ""
+"style 'wavecolor0' { fg[NORMAL] = {1.0, 0.0, 0.0} }"
+"style 'wavecolor1' { fg[NORMAL] = {1.0, 1.0, 0.0} }"
+"style 'wavecolor2' { fg[NORMAL] = {0.0, 1.0, 0.0} }"
+"style 'wavecolor3' { fg[NORMAL] = {0.4, 0.5, 1.0} }"
+"style 'wavecolor4' { fg[NORMAL] = {0.0, 1.0, 1.0} }"
+"style 'wavecolor5' { fg[NORMAL] = {1.0, 0.0, 1.0} }"
+"widget '*wavecolor0' style 'wavecolor0'"
+"widget '*wavecolor1' style 'wavecolor1'"
+"widget '*wavecolor2' style 'wavecolor2'"
+"widget '*wavecolor3' style 'wavecolor3'"
+"widget '*wavecolor4' style 'wavecolor4'"
+"widget '*wavecolor5' style 'wavecolor5'"
+"style 'cursor0color' { fg[NORMAL] = {1.0, 1.0, 1.0} }"
+"style 'cursor1color' { fg[NORMAL] = {1.0, 1.0, 0.0} }"
+"style 'cursorDcolor' { fg[NORMAL] = {00, 1.0, 0.0} }"
+"widget '*cursor1color' style 'cursor1color'"
+"widget '*cursor0color' style 'cursor0color'"
+"widget '*cursorDcolor' style 'cursorDcolor'"
+"style 'wavebutton' { bg[NORMAL] = { 0.25, 0.25, 0.25 } }"
+"widget '*wavebutton' style 'wavebutton'"
+"";
int
main(int argc, char **argv)
XSCM_HOOK(error_hook, "error-hook", 5, (SCM a, SCM b, SCM c, SCM d, SCM e),

View file

@ -1,52 +0,0 @@
$NetBSD: patch-ab,v 1.3 2003/11/05 22:31:43 dmcmahill Exp $
--- src/cmd.c.orig 2003-02-12 22:54:17.000000000 -0500
+++ src/cmd.c
@@ -42,9 +42,9 @@
#include <measurebtn.h>
XSCM_HOOK(new_visiblewave_hook, "new-visiblewave-hook", 1, (SCM vw),
-"This hook is invoked with one VisibleWave argument, VW,
-when the VisibleWave is first created. The main purpose of this hook
-will be to create the button and menus attached to the VisibleWave.");
+"This hook is invoked with one VisibleWave argument, VW,"
+"when the VisibleWave is first created. The main purpose of this hook "
+"will be to create the button and menus attached to the VisibleWave.");
/* reset the x zoom scale of all panels */
gint cmd_zoom_absolute(double start, double end)
@@ -131,8 +131,8 @@ vw_wp_list_if_selected(gpointer p, gpoin
}
XSCM_DEFINE(delete_selected_waves_x, "delete-selected-waves!", 0, 0, 0, (),
- "Remove from panels any VisibleWaves that have been
-selected by clicking on their label-buttons.")
+ "Remove from panels any VisibleWaves that have been"
+"selected by clicking on their label-buttons.")
#define FUNC_NAME s_delete_selected_waves_x
{
int i;
@@ -612,9 +612,9 @@ XSCM_DEFINE(visiblewave_panel, "visiblew
#undef FUNC_NAME
XSCM_DEFINE(visiblewave_button, "visiblewave-button", 1, 0, 0, (SCM vw),
-"Given a VisibleWave VW, return the Gtk button associated with the
-wave. Since the button already has a label, all you can do is
-add events to the button.")
+"Given a VisibleWave VW, return the Gtk button associated with the"
+"wave. Since the button already has a label, all you can do is"
+"add events to the button.")
#define FUNC_NAME s_visiblewave_button
{
VisibleWave *cvw;
@@ -701,8 +701,8 @@ XSCM_DEFINE(set_visiblewave_color_x, "se
XSCM_DEFINE(set_visiblewave_measure_x, "set-visiblewave-measure!", 3, 0, 0,
(SCM vw, SCM n, SCM func),
- "Change the measurement box numbered N (0 or 1) of displayed waveform
- VW to display the result of the measurement function FUNC")
+ "Change the measurement box numbered N (0 or 1) of displayed waveform"
+ "VW to display the result of the measurement function FUNC")
#define FUNC_NAME s_set_visiblewave_measure_x
{
VisibleWave *cvw;

View file

@ -1,67 +0,0 @@
$NetBSD: patch-ac,v 1.1 2003/11/05 22:31:43 dmcmahill Exp $
--- src/wavewin.c.orig 2002-03-27 23:10:01.000000000 -0500
+++ src/wavewin.c
@@ -50,10 +50,10 @@
#define WAVEPANEL_JGE_HEIGHT 25
XSCM_HOOK(new_wavewin_hook,"new-wavewin-hook", 0, (),
-"This hook is invoked with no arguments when the main waveform
-window is first created.
-The main purpose of this hook is to allow creation of the
-contents of the menubar and toolbar.");
+"This hook is invoked with no arguments when the main waveform"
+"window is first created."
+"The main purpose of this hook is to allow creation of the"
+"contents of the menubar and toolbar.");
SCM wavepanel_mouse_binding[6];
@@ -99,8 +99,8 @@ GtkWidget *create_xlabel_hbox(WaveTable
/* global wtable: GtkTable widget for the main window. */
XSCM_DEFINE(wtable_start_xval, "wtable-start-xval", 0, 0, 0, (),
-"Return the X coordinate represented by the left edge of the
-displayed portion of the waveforms")
+"Return the X coordinate represented by the left edge of the"
+"displayed portion of the waveforms")
#define FUNC_NAME s_wtable_start_xval
{
return gh_double2scm(wtable->start_xval);
@@ -108,8 +108,8 @@ displayed portion of the waveforms")
#undef FUNC_NAME
XSCM_DEFINE(wtable_end_xval, "wtable-end-xval", 0, 0, 0, (),
-"Return the X coordinate represented by the right edge of the
-displayed portion of the waveforms")
+"Return the X coordinate represented by the right edge of the"
+"displayed portion of the waveforms")
#define FUNC_NAME s_wtable_end_xval
{
return gh_double2scm(wtable->end_xval);
@@ -271,8 +271,8 @@ XSCM_DEFINE(get_wavewin, "get-wavewin",
#undef FUNC_NAME
XSCM_DEFINE(get_wavewin_toolbar, "get-wavewin-toolbar", 0, 0, 0, (),
-"Return the GtkHBox object for horizontal box to contain
-function buttons or icons in the main waveform window")
+"Return the GtkHBox object for horizontal box to contain"
+"function buttons or icons in the main waveform window")
#define FUNC_NAME s_get_wavewin_toolbar
{
return sgtk_wrap_gtkobj(GTK_OBJECT(win_main_toolbar));
@@ -482,10 +482,10 @@ wavewin_delete_panel(WavePanel *dwp)
XSCM_DEFINE(wtable_insert_panel_x, "wtable-insert-panel!", 2, 1, 0,
(SCM wp, SCM minheight, SCM showlabels),
-"Add a new panel after the existing panel WP, or
-at the end if WP is #f.
-The new panel has minimum height MINHEIGHT and has visible y-labels
-unless SHOWLABELS is #f")
+"Add a new panel after the existing panel WP, or"
+"at the end if WP is #f."
+"The new panel has minimum height MINHEIGHT and has visible y-labels"
+"unless SHOWLABELS is #f")
#define FUNC_NAME s_wtable_insert_panel_x
{
WavePanel *cwp;

View file

@ -1,90 +0,0 @@
$NetBSD: patch-ad,v 1.1 2003/11/05 22:31:43 dmcmahill Exp $
--- src/wavelist.c.orig 2003-07-13 19:44:42.000000000 -0400
+++ src/wavelist.c
@@ -149,15 +149,15 @@ static gint wavelist_button_click(GtkWid
GdkEventButton *event, gpointer data);
XSCM_HOOK(new_wavefile_hook,"new-wavefile-hook", 1, (SCM DF),
-"This hook is invoked when a new waveform file is successfully loaded.
-It is called with the new GWDataFile, DF, as its only argument.");
+"This hook is invoked when a new waveform file is successfully loaded."
+"It is called with the new GWDataFile, DF, as its only argument.");
XSCM_HOOK(new_wavelist_hook,"new-wavelist-hook", 1, (SCM DF),
-"This hook is invoked when the variable list window for a
-GWDataFile is created. The GWDataFile object, DF, is passed as an
-argument. Note that variable-list windows can be created and
-destroyed many times during the life of a GWDataFile. One of the principle
-uses of this hook is creating the menus such for the variable-list window.");
+"This hook is invoked when the variable list window for a"
+"GWDataFile is created. The GWDataFile object, DF, is passed as an"
+"argument. Note that variable-list windows can be created and"
+"destroyed many times during the life of a GWDataFile. One of the principle"
+"uses of this hook is creating the menus such for the variable-list window.");
/*
* Load a waveform file, adding it to the list of files from which
@@ -208,11 +208,11 @@ load_wave_file(char *fname, char *ftype)
}
XSCM_DEFINE(load_wavefile_x, "load-wavefile!", 1, 1, 0, (SCM file, SCM filetype),
-"Load waveform data from FILE into memory, and make it available for
-display. If FILETYPE is specified, it indicates the format of the file
-and which wavefile reader to use, otherwise the format is inferred
-from the filename and file contents. Returns a GWDataFile object
-which can be used to refer to the loaded data.")
+"Load waveform data from FILE into memory, and make it available for"
+"display. If FILETYPE is specified, it indicates the format of the file"
+"and which wavefile reader to use, otherwise the format is inferred"
+"from the filename and file contents. Returns a GWDataFile object"
+"which can be used to refer to the loaded data.")
#define FUNC_NAME s_load_wavefile_x
{
char *fname, *ftype;
@@ -351,8 +351,8 @@ XSCM_DEFINE(reload_all_files_x, "reload-
XSCM_DEFINE(datafile_reload_x, "wavefile-reload!", 1, 0, 0,
(SCM obj),
-"Reread the data file for OBJ. Useful for updating the display
- after simulation has been rerun.")
+"Reread the data file for OBJ. Useful for updating the display"
+" after simulation has been rerun.")
#define FUNC_NAME s_datafile_reload_x
{
GWDataFile *wdata;
@@ -542,8 +542,8 @@ wavelist_button_click(GtkWidget *widget,
XSCM_DEFINE(wavefile_show_listwin_x, "wavefile-show-listwin!", 1, 0, 0,
(SCM obj),
-"Displays the scrolling list of the variables in OBJ, from which they
-can be dragged into a waveform display panel.")
+"Displays the scrolling list of the variables in OBJ, from which they"
+"can be dragged into a waveform display panel.")
#define FUNC_NAME s_wavefile_show_listwin_x
{
GWDataFile *wdata;
@@ -578,9 +578,9 @@ XSCM_DEFINE(wavefile_remove_listwin_x, "
XSCM_DEFINE(wavefile_file_name, "wavefile-file-name", 1, 0, 0,
(SCM obj),
-"Returns the filename from which the GWDataFile OBJ was loaded.
-If OBJ is invalid because the datafile has been deleted,
-#f is returned.")
+"Returns the filename from which the GWDataFile OBJ was loaded."
+"If OBJ is invalid because the datafile has been deleted,"
+"#f is returned.")
#define FUNC_NAME s_wavefile_file_name
{
GWDataFile *wdata;
@@ -608,8 +608,8 @@ XSCM_DEFINE(wavefile_tag, "wavefile-tag"
XSCM_DEFINE(wavefile_listwin_menubar, "wavefile-listwin-menubar", 1, 0, 0,
(SCM obj),
-"Returns the GTK Menubar for the variable-list window of the
- * GWDataFile OBJ, or #f if the window doesn't exist.")
+"Returns the GTK Menubar for the variable-list window of the"
+" * GWDataFile OBJ, or #f if the window doesn't exist.")
#define FUNC_NAME s_wavefile_listwin_menubar
{
GWDataFile *wdata;

View file

@ -1,71 +0,0 @@
$NetBSD: patch-ae,v 1.2 2007/01/23 02:49:23 dmcmahill Exp $
- fix multiline strings which newer gcc's don't like
- fix __inline__ which sunpro doesn't like
--- src/scwm_guile.c.orig 2002-03-27 23:07:03.000000000 -0500
+++ src/scwm_guile.c
@@ -42,15 +42,21 @@
#include "dmalloc.h"
#endif
+#ifndef __GNUC__
+#ifndef __inline__
+#define __inline__
+#endif
+#endif
+
extern char *prog_name;
XSCM_HOOK(error_hook, "error-hook", 5, (SCM a, SCM b, SCM c, SCM d, SCM e),
-"Called on all kinds of errors and exceptions.
-Whenever an error or other uncaught throw occurs on any callback,
-whether a hook, a mouse binding, a key binding, a menu entry, a file
-being processed, or anything else, error-hook will be invoked. Each
-procedure in the hook will be called with the throw arguments; these
-will generally include information about the nature of the error.");
+"Called on all kinds of errors and exceptions."
+"Whenever an error or other uncaught throw occurs on any callback,"
+"whether a hook, a mouse binding, a key binding, a menu entry, a file"
+"being processed, or anything else, error-hook will be invoked. Each"
+"procedure in the hook will be called with the throw arguments; these"
+"will generally include information about the nature of the error.");
struct scwm_body_apply_data {
SCM proc;
@@ -209,12 +215,12 @@ scwm_safe_call7 (SCM proc, SCM arg1, SCM
/* FIXDOC: We need a way to cross-reference concepts in docs. */
XSCM_CONCEPT("Hooks",
-"Hooks are used throughout gwave to provide a convenient mechanism for
-user callbacks on particular events. Fundamentally, a hook is just a
-variable that contains a list of procedures that are called in order
-when the relevant event occurs. However, several convenience macros
-are provided for manipulating hooks; see `add-hook!', `remove-hook!',
-`reset-hook!', and `run-hook'.");
+"Hooks are used throughout gwave to provide a convenient mechanism for"
+"user callbacks on particular events. Fundamentally, a hook is just a"
+"variable that contains a list of procedures that are called in order"
+"when the relevant event occurs. However, several convenience macros"
+"are provided for manipulating hooks; see `add-hook!', `remove-hook!',"
+"`reset-hook!', and `run-hook'.");
static SCM run_hook_proc;
@@ -395,11 +401,11 @@ scwm_handle_error (void *ARG_IGNORE(data
XSCM_DEFINE(safe_load, "safe-load", 1, 0, 0,
(SCM fname),
-"Load file FNAME while trapping and displaying errors.
-Each individual top-level-expression is evaluated separately and all
-errors are trapped and displayed. You should use this procedure if
-you need to make sure most of a file loads, even if it may contain
-errors.")
+"Load file FNAME while trapping and displaying errors."
+"Each individual top-level-expression is evaluated separately and all"
+"errors are trapped and displayed. You should use this procedure if"
+"you need to make sure most of a file loads, even if it may contain"
+"errors.")
#define FUNC_NAME s_safe_load
{
SCM_STACKITEM stack_item;

View file

@ -1,63 +0,0 @@
$NetBSD: patch-af,v 1.2 2005/12/06 18:25:55 joerg Exp $
--- src/event.c.orig 2002-03-28 01:35:21.000000000 -0500
+++ src/event.c
@@ -148,11 +148,11 @@ set_all_wp_cursors(int cnum)
*/
XSCM_DEFINE(select_range_x, "select-range-x", 1, 0, 0,
(SCM proc),
-"Prompt the user to select a range of the visible X axis using
-button 1 of the mouse.
-When finished, PROC is called with 3 arguments, the
-WavePanel where the range is located, and the
-begining and ending X pixel value of the selection.")
+"Prompt the user to select a range of the visible X axis using"
+"button 1 of the mouse. "
+"When finished, PROC is called with 3 arguments, the"
+"WavePanel where the range is located, and the"
+"begining and ending X pixel value of the selection.")
#define FUNC_NAME s_select_range_x
{
VALIDATE_ARG_PROC(1, proc);
@@ -168,11 +168,11 @@ begining and ending X pixel value of the
XSCM_DEFINE(select_range_y, "select-range-y", 1, 0, 0,
(SCM proc),
-"Prompt the user to select a range of the visible Y axis using
-button 1 of the mouse.
-When finished, PROC is called with 3 arguments, the
-WavePanel where the range is located, and the
-begining and ending Y pixel value of the selection.")
+"Prompt the user to select a range of the visible Y axis using"
+"button 1 of the mouse. "
+"When finished, PROC is called with 3 arguments, the"
+"WavePanel where the range is located, and the"
+"begining and ending Y pixel value of the selection.")
#define FUNC_NAME s_select_range_y
{
VALIDATE_ARG_PROC(1, proc);
@@ -188,11 +188,11 @@ begining and ending Y pixel value of the
XSCM_DEFINE(select_range_xy, "select-range-xy", 1, 0, 0,
(SCM proc),
-"Prompt the user to select a region of the
-visible XY plane using button 1 of the mouse.
-When finished, PROC is called with 5 arguments, the
-WavePanel where the range is located, and the
-begining and ending X and Y pixel values of the selection.")
+"Prompt the user to select a region of the "
+"visible XY plane using button 1 of the mouse. "
+"When finished, PROC is called with 5 arguments, the"
+"WavePanel where the range is located, and the"
+"begining and ending X and Y pixel values of the selection.")
#define FUNC_NAME s_select_range_xy
{
VALIDATE_ARG_PROC(1, proc);
@@ -449,6 +449,7 @@ button_release_handler(GtkWidget *widget
callback_srange();
break;
default:
+ break;
}
wtable->mstate = M_NONE;
wtable->button_down = -1;

View file

@ -1,26 +0,0 @@
$NetBSD: patch-ag,v 1.1 2003/11/05 22:31:43 dmcmahill Exp $
--- src/draw.c.orig 2003-08-02 19:51:13.000000000 -0400
+++ src/draw.c
@@ -503,8 +503,8 @@ double spice2val(char *s)
}
XSCM_DEFINE(spice_number, "spice->number", 1, 0, 0, (SCM str),
-"Given a string SSTR containing a representation of a number,
-possibly containing spice-style multiplier suffixes, return a real number.")
+"Given a string SSTR containing a representation of a number,"
+"possibly containing spice-style multiplier suffixes, return a real number.")
#define FUNC_NAME s_spice_number
{
double dval;
@@ -518,8 +518,8 @@ possibly containing spice-style multipli
#undef FUNC_NAME
XSCM_DEFINE(number_spice, "number->spice", 1, 0, 0, (SCM val),
- "Given a real number VAL, return a string representation
-in spice suffix syntax.")
+ "Given a real number VAL, return a string representation "
+"in spice suffix syntax.")
#define FUNC_NAME s_number_spice
{
double dval;

View file

@ -1,17 +0,0 @@
$NetBSD: patch-ah,v 1.1 2003/11/05 22:31:43 dmcmahill Exp $
--- src/gtkmisc.c.orig 2002-03-27 23:05:38.000000000 -0500
+++ src/gtkmisc.c
@@ -284,9 +284,9 @@ shape_create_icon_d (char **xpm_data
}
XSCM_DEFINE(gtk_tooltips_enabled_p, "gtk-tooltips-enabled?", 1, 0, 0, (SCM tt),
- "Return #t if the GtkTooltips object TT is enabled, otherwise
-return #f. See gtk-tooltips-enable in the guile-gtk documentation,
-or gtk_tooltips_enable in the Gtk+ documentation for GtkTooltips.")
+ "Return #t if the GtkTooltips object TT is enabled, otherwise"
+"return #f. See gtk-tooltips-enable in the guile-gtk documentation,"
+"or gtk_tooltips_enable in the Gtk+ documentation for GtkTooltips.")
#define FUNC_NAME s_gtk_tooltips_enabled_p
{
GtkTooltips *gtktt;

View file

@ -1,134 +0,0 @@
$NetBSD: patch-ai,v 1.1 2003/11/05 22:31:43 dmcmahill Exp $
--- src/wavepanel.c.orig 2003-02-12 22:48:53.000000000 -0500
+++ src/wavepanel.c
@@ -46,10 +46,10 @@
#define WAVEPANEL_MAX_REQHEIGHT 400
XSCM_HOOK(new_wavepanel_hook,"new-wavepanel-hook", 1, (SCM wp),
-"This hook is invoked with one WavePanel argument, WP, when the
-WavePanel is first created and added to the waveform window.
-The main purpose of this hook is to allow creation of
-popup menus and other event bindings for the wavepanel.");
+"This hook is invoked with one WavePanel argument, WP, when the"
+"WavePanel is first created and added to the waveform window."
+"The main purpose of this hook is to allow creation of "
+"popup menus and other event bindings for the wavepanel.");
SCM wavepanel_mouse_binding[6];
WavePanel *last_drop_wavepanel;
@@ -314,9 +314,9 @@ XSCM_DEFINE(wavepanel_y_zoom_x, "wavepan
XSCM_DEFINE(wavepanel_y_manual_p, "wavepanel-y-manual?", 1, 0, 0,
(SCM wavepanel),
-"If WAVEPANEL's y extents have been zoomed manually, return #t.
-Otherwise, return #f to indicate automatic y-zoom to show the minimum
-and maximum values of all dependent variables")
+"If WAVEPANEL's y extents have been zoomed manually, return #t."
+"Otherwise, return #f to indicate automatic y-zoom to show the minimum"
+"and maximum values of all dependent variables")
#define FUNC_NAME s_wavepanel_y_manual_p
{
WavePanel *wp;
@@ -333,10 +333,10 @@ and maximum values of all dependent vari
XSCM_DEFINE(set_wavepanel_ylabels_visible_x, "set-wavepanel-ylabels-visible!", 2, 0, 0,
(SCM wavepanel, SCM show),
-"If SHOW is #t, make the Y-axis labels on the left side of WAVEPANEL
-visible. If show is #f, hide the labels. Hiding the labels allows
-shrinking WAVEPANEL's height a little further. This is useful when you have
-a lot of panels, for example with digital circuits.")
+"If SHOW is #t, make the Y-axis labels on the left side of WAVEPANEL"
+"visible. If show is #f, hide the labels. Hiding the labels allows"
+"shrinking WAVEPANEL's height a little further. This is useful when you have"
+"a lot of panels, for example with digital circuits.")
#define FUNC_NAME s_set_wavepanel_ylabels_visible_x
{
WavePanel *wp;
@@ -357,8 +357,8 @@ a lot of panels, for example with digita
XSCM_DEFINE(set_wavepanel_ylogscale_x, "set-wavepanel-ylogscale!", 2, 0, 0,
(SCM wavepanel, SCM logscale),
-"If LOGSCALE is #t, The Y-axis of WAVEPANEL is set to have
-Logarithmic scaling. Otherwise, scaling is linear.")
+"If LOGSCALE is #t, The Y-axis of WAVEPANEL is set to have"
+"Logarithmic scaling. Otherwise, scaling is linear.")
#define FUNC_NAME s_set_wavepanel_ylogscale_x
{
WavePanel *wp;
@@ -423,8 +423,8 @@ XSCM_DEFINE(wavepanel_visiblewaves, "wav
*/
XSCM_DEFINE(wavepanel_bind_mouse, "wavepanel-bind-mouse", 2, 0, 0,
(SCM button, SCM proc),
-"binds a mouse BUTTON to the procedure PROC in all wavepanels.
-PROC is called with 1 argument, the wavepanel that the mouse was in.")
+"binds a mouse BUTTON to the procedure PROC in all wavepanels. "
+"PROC is called with 1 argument, the wavepanel that the mouse was in.")
#define FUNC_NAME s_wavepanel_bind_mouse
{
int bnum;
@@ -447,9 +447,9 @@ PROC is called with 1 argument, the wave
XSCM_DEFINE(wavepanel_x2val, "wavepanel-x2val", 2, 0, 0,
(SCM wavepanel, SCM xpixel),
-"Given an XPIXEL coordinate in WAVEPANEL,
-return the value of the independent variable at that position
-in the waveform.")
+"Given an XPIXEL coordinate in WAVEPANEL, "
+"return the value of the independent variable at that position"
+"in the waveform.")
#define FUNC_NAME s_wavepanel_x2val
{
WavePanel *wp;
@@ -464,9 +464,9 @@ in the waveform.")
XSCM_DEFINE(wavepanel_y2val, "wavepanel-y2val", 2, 0, 0,
(SCM wavepanel, SCM ypixel),
-"Given a YPIXEL screen-space coordinate in WAVEPANEL,
-return the value that the dependent variable would have
-at that position.")
+"Given a YPIXEL screen-space coordinate in WAVEPANEL, "
+"return the value that the dependent variable would have"
+"at that position.")
#define FUNC_NAME s_wavepanel_y2val
{
WavePanel *wp;
@@ -481,9 +481,9 @@ at that position.")
XSCM_DEFINE(wavepanel_disp_rect, "wavepanel-disp-rect", 1, 0, 0,
(SCM wavepanel),
-"Return a list containing coordinates of the space displayed
-currently displayed by the current zoom setting of WAVEPANEL.
-The list contains four elements, startX, startY, endX, endY")
+"Return a list containing coordinates of the space displayed "
+"currently displayed by the current zoom setting of WAVEPANEL. "
+"The list contains four elements, startX, startY, endX, endY")
#define FUNC_NAME s_wavepanel_disp_rect
{
WavePanel *wp;
@@ -499,9 +499,9 @@ The list contains four elements, startX,
XSCM_DEFINE(wavepanel_max_rect, "wavepanel-max-rect", 1, 0, 0,
(SCM wavepanel),
-"Return a list containing coordinates of the bounding box of all waveforms
-displayed in WAVEPANEL.
-The list contains four elements, minX, minY, maxX, maxY")
+"Return a list containing coordinates of the bounding box of all waveforms"
+"displayed in WAVEPANEL."
+"The list contains four elements, minX, minY, maxX, maxY")
#define FUNC_NAME s_wavepanel_max_rect
{
WavePanel *wp;
@@ -517,9 +517,9 @@ The list contains four elements, minX, m
XSCM_DEFINE(set_wavepanel_minheight_x, "set-wavepanel-minheight!", 2, 0, 0,
(SCM wavepanel, SCM height),
-"Set the minimum height of WAVEPANEL to HEIGHT pixels. Adding multiple
-VisibleWaves to the wavepanel can cause the actual height to increase
-beyond this minimum, but it will never be smaller.")
+"Set the minimum height of WAVEPANEL to HEIGHT pixels. Adding multiple"
+"VisibleWaves to the wavepanel can cause the actual height to increase"
+"beyond this minimum, but it will never be smaller.")
#define FUNC_NAME s_set_wavepanel_minheight_x
{
WavePanel *wp;

View file

@ -1,18 +0,0 @@
$NetBSD: patch-aj,v 1.1 2003/11/05 22:31:43 dmcmahill Exp $
--- src/Makefile.am.orig 2003-08-02 03:24:45.000000000 -0400
+++ src/Makefile.am
@@ -32,10 +32,10 @@ BUILT_SOURCES=init_scheme_string.c scm_i
# $(DOT_DOC_FILES)
init_scheme_string.c: $(top_srcdir)/scheme/minimal.scm
- echo "char *init_scheme_string = \"\\" > $@
- sed -e 's/;.*$$//g' -e 's/"/\\"/g' -e "s/'/\\\\'/g" -e 's/$$/\\n\\/' < $(top_srcdir)/scheme/minimal.scm >> $@
+ echo "char *init_scheme_string = " > $@
+ sed -e 's/;.*$$//g' -e 's/"/\\"/g' -e "s/'/\\\\'/g" -e 's/$$/\\n"/' -e 's/^/"/g' < $(top_srcdir)/scheme/minimal.scm >> $@
echo >> $@
- echo '";' >> $@
+ echo ';' >> $@
SUFFIXES = .x .doc

View file

@ -1,18 +0,0 @@
$NetBSD: patch-ak,v 1.1 2003/11/05 22:31:43 dmcmahill Exp $
--- src/Makefile.in.orig 2003-08-04 22:25:32.000000000 -0400
+++ src/Makefile.in
@@ -497,10 +497,10 @@ uninstall-info: uninstall-info-recursive
# $(DOT_DOC_FILES)
init_scheme_string.c: $(top_srcdir)/scheme/minimal.scm
- echo "char *init_scheme_string = \"\\" > $@
- sed -e 's/;.*$$//g' -e 's/"/\\"/g' -e "s/'/\\\\'/g" -e 's/$$/\\n\\/' < $(top_srcdir)/scheme/minimal.scm >> $@
+ echo "char *init_scheme_string = " > $@
+ sed -e 's/;.*$$//g' -e 's/"/\\"/g' -e "s/'/\\\\'/g" -e 's/$$/\\n"/' -e 's/^/"/g' < $(top_srcdir)/scheme/minimal.scm >> $@
echo >> $@
- echo '";' >> $@
+ echo ';' >> $@
.c.x:
./xguile-snarf $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< > $@ \