Fix build problem under NetBSD 1.6Y and above.

This commit is contained in:
tron 2004-01-04 11:48:44 +00:00
parent a6fc8bcee2
commit 714041931c
2 changed files with 36 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2004/01/03 23:21:44 tron Exp $
$NetBSD: distinfo,v 1.2 2004/01/04 11:48:44 tron Exp $
SHA1 (oidentd-2.0.7.tar.gz) = c973b436e6f8cab87b5e2f557e901722e27f1e79
Size (oidentd-2.0.7.tar.gz) = 196027 bytes
SHA1 (patch-aa) = b5c82f425fc9f5174dd4efb4c4d13bdf78486beb
SHA1 (patch-ab) = 264178c5cc79c744354ab228678cb41bdc27b198
SHA1 (patch-ac) = 20a1d998b98bfae08faf3578abd6fd186a921ee6

View file

@ -0,0 +1,34 @@
$NetBSD: patch-ac,v 1.1 2004/01/04 11:48:44 tron Exp $
--- src/kernel/netbsd.c.orig 2004-01-04 12:27:05.000000000 +0100
+++ src/kernel/netbsd.c 2004-01-04 12:46:17.000000000 +0100
@@ -162,7 +162,7 @@
if (tcbtablep == NULL)
return (NULL);
- kpcbp = tcbtablep->inpt_queue.cqh_first;
+ kpcbp = (struct inpcb *) tcbtablep->inpt_queue.cqh_first;
while (kpcbp != (struct inpcb *) ktcbtablep) {
if (getbuf((u_long) kpcbp, &pcb, sizeof(struct inpcb)) == -1)
break;
@@ -185,7 +185,7 @@
return (pcb.inp_socket);
}
- kpcbp = pcb.inp_queue.cqe_next;
+ kpcbp = (struct inpcb *) pcb.inp_queue.cqe_next;
}
return (NULL);
@@ -351,7 +351,11 @@
return (tcb6_temp.in6p_socket);
}
+#if defined(__NetBSD__) && __NetBSD_Version__ >= 106250000 /* 1.6Y */
+ tcb6_cur = tcb6_temp.in6p_queue.cqe_next;
+#else
tcb6_cur = tcb6_temp.in6p_next;
+#endif
if (getbuf((u_long) tcb6_cur, &tcb6_temp, sizeof(tcb6_temp)) == -1)
break;
} while ((u_long) tcb6_cur != kinfo->nl[N_TCB6].n_value);