update autoconf to 2.52. Some changes:
- Quadrigraphs This feature was present in autoconf 2.50 but was not documented. For example, `@<:@' is translated to `[' just before output. This is useful when writing strings that contain unbalanced quotes, or other hard-to-quote constructs. - m4_pattern_forbid, m4_pattern_allow - Using autoscan to maintain a configure.ac. - Fixed Fortran name-mangling and link tests on a number of systems, e.g. NetBSD; see AC_F77_DUMMY_MAIN, below. - cross-compilation $build defaults to `config.guess`, $host to $build, and then $target to $host. Cross-compilation is a global status of the package, it no longer depends upon the current language. Cross compilation is enabled iff the user specified `--host'. `configure' now fails if it can't run the executables it compiles, unless cross-compilation is enabled. - Cache file The cache file is disabled by default. The new options `--config-cache', `-C' set the cache to `config.cache'. ... and many others, esp. bugfixes. Check the docs!
This commit is contained in:
parent
32423096e3
commit
714d4ce9ce
7 changed files with 54 additions and 66 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.25 2001/02/16 14:38:17 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.26 2001/08/26 20:44:23 hubertf Exp $
|
||||
# FreeBSD Id: Makefile,v 1.12 1997/06/13 20:00:47 max Exp
|
||||
#
|
||||
|
||||
DISTNAME= autoconf-2.13
|
||||
DISTNAME= autoconf-2.52
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=autoconf/}
|
||||
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.3 2001/04/21 00:44:11 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.4 2001/08/26 20:44:23 hubertf Exp $
|
||||
|
||||
SHA1 (autoconf-2.13.tar.gz) = e4826c8bd85325067818f19b2b2ad2b625da66fc
|
||||
Size (autoconf-2.13.tar.gz) = 443844 bytes
|
||||
SHA1 (patch-aa) = f31397e3feda41b4493905f03d20b0db354bb3b4
|
||||
SHA1 (patch-ab) = 27fd826a2e9be84cab8b050c6314343fe062a726
|
||||
SHA1 (patch-ac) = 3a2ba2e7505e7f1476c17142839c1890cba2e4d4
|
||||
SHA1 (patch-ad) = 640b838fed5e04586e940a5dad543903e4f8be9a
|
||||
SHA1 (autoconf-2.52.tar.gz) = 6f7baa3a924a348df3a231817dacf659a3ecdf6b
|
||||
Size (autoconf-2.52.tar.gz) = 846656 bytes
|
||||
SHA1 (patch-aa) = 94b9f41da21b752ba14d87936a48df3e6f7cdee0
|
||||
SHA1 (patch-ac) = d26fad78439179d8754cf21ba7efc2a1a3c73fe5
|
||||
SHA1 (patch-ad) = 57ccb006e7468dc9e13031d15d82aae6bb1b88d0
|
||||
|
|
|
@ -1,25 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.3 1999/01/06 16:30:46 frueauf Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2001/08/26 20:44:24 hubertf Exp $
|
||||
|
||||
--- Makefile.in-orig Tue Jan 5 14:27:16 1999
|
||||
+++ Makefile.in Wed Jan 6 17:10:56 1999
|
||||
@@ -141,7 +141,7 @@
|
||||
--- doc/make-stds.texi.orig Tue Jul 17 18:34:55 2001
|
||||
+++ doc/make-stds.texi
|
||||
@@ -811,7 +811,7 @@
|
||||
@end smallexample
|
||||
|
||||
install: all $(M4FILES) acconfig.h installdirs install-info
|
||||
for p in $(ASCRIPTS); do \
|
||||
- $(INSTALL_PROGRAM) $$p $(bindir)/`echo $$p|sed '$(transform)'`; \
|
||||
+ $(INSTALL) $$p $(bindir)/`echo $$p|sed '$(transform)'`; \
|
||||
done
|
||||
for i in $(M4FROZEN); do \
|
||||
$(INSTALL_DATA) $$i $(acdatadir)/$$i; \
|
||||
@@ -150,9 +150,9 @@
|
||||
$(INSTALL_DATA) $(srcdir)/$$i $(acdatadir)/$$i; \
|
||||
done
|
||||
-if test -f autoscan; then \
|
||||
- $(INSTALL_PROGRAM) autoscan $(bindir)/`echo autoscan|sed '$(transform)'`; \
|
||||
+ $(INSTALL) autoscan $(bindir)/`echo autoscan|sed '$(transform)'`; \
|
||||
for i in acfunctions acheaders acidentifiers acprograms \
|
||||
- acmakevars; do \
|
||||
+ acmakevars config.guess config.sub; do \
|
||||
$(INSTALL_DATA) $(srcdir)/$$i $(acdatadir)/$$i; \
|
||||
done; \
|
||||
else :; fi
|
||||
@noindent
|
||||
-or, if you wish to support @env{DESTDIR},
|
||||
+or, if you wish to support DESTDIR,
|
||||
|
||||
@smallexample
|
||||
# Make sure all installation directories (e.g. $(bindir))
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 1999/01/06 16:30:46 frueauf Exp $
|
||||
|
||||
--- autoconf.texi-orig Tue Jan 5 14:28:37 1999
|
||||
+++ autoconf.texi Wed Jan 6 16:36:16 1999
|
||||
@@ -4,6 +4,7 @@
|
||||
@settitle Autoconf
|
||||
@c For double-sided printing, uncomment:
|
||||
@c @setchapternewpage odd
|
||||
+@dircategory Programming & development tools
|
||||
@c %**end of header
|
||||
|
||||
@set EDITION 2.13
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: patch-ac,v 1.3 1999/01/06 16:30:46 frueauf Exp $
|
||||
$NetBSD: patch-ac,v 1.4 2001/08/26 20:44:24 hubertf Exp $
|
||||
|
||||
--- standards.texi-orig Tue Jan 5 14:29:22 1999
|
||||
+++ standards.texi Wed Jan 6 16:39:21 1999
|
||||
--- doc/standards.texi.orig Tue Jul 17 18:34:55 2001
|
||||
+++ doc/standards.texi
|
||||
@@ -4,6 +4,7 @@
|
||||
@settitle GNU Coding Standards
|
||||
@c This date is automagically updated when you save this file:
|
||||
@set lastupdate August 26, 1998
|
||||
@set lastupdate March 23, 2001
|
||||
+@dircategory Programming & development tools
|
||||
@c %**end of header
|
||||
|
||||
|
|
|
@ -1,12 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.2 1999/12/28 04:56:52 wiz Exp $
|
||||
--- configure.BAK Wed Sep 8 17:36:21 1999
|
||||
+++ configure Wed Sep 8 17:36:27 1999
|
||||
@@ -583,7 +583,7 @@
|
||||
done
|
||||
test -n "$M4" || M4="m4"
|
||||
$NetBSD: patch-ad,v 1.3 2001/08/26 20:44:24 hubertf Exp $
|
||||
|
||||
--- configure.orig Wed Jul 18 15:41:05 2001
|
||||
+++ configure
|
||||
@@ -1215,7 +1215,7 @@
|
||||
# a AC-SUBST inside AC-PROG-GNU-M4. Grmph!
|
||||
|
||||
# `autoconf' and `ifnames' use AWK. And we need decent RE support.
|
||||
-for ac_prog in mawk gawk nawk awk
|
||||
+for ac_prog in gawk nawk awk mawk
|
||||
+for ac_prog in gawk mawk nawk awk
|
||||
do
|
||||
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
||||
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
||||
set dummy $ac_prog; ac_word=$2
|
||||
|
|
|
@ -1,29 +1,41 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 1999/02/11 19:17:29 tv Exp $
|
||||
@comment $NetBSD: PLIST,v 1.8 2001/08/26 20:44:24 hubertf Exp $
|
||||
bin/autoconf
|
||||
bin/autoheader
|
||||
bin/autoreconf
|
||||
bin/autoscan
|
||||
bin/autoupdate
|
||||
bin/ifnames
|
||||
@unexec install-info --delete %D/info/autoconf.info %D/info/dir
|
||||
@unexec install-info --delete %D/info/standards.info %D/info/dir
|
||||
@unexec install-info --delete --info-dir=%D/info %D/info/autoconf.info
|
||||
info/autoconf.info
|
||||
@exec install-info --info-dir=%D/info %D/info/autoconf.info
|
||||
@unexec install-info --delete --info-dir=%D/info %D/info/standards.info
|
||||
info/standards.info
|
||||
@exec install-info %D/info/autoconf.info %D/info/dir
|
||||
@exec install-info %D/info/standards.info %D/info/dir
|
||||
share/autoconf/acconfig.h
|
||||
@exec install-info --info-dir=%D/info %D/info/standards.info
|
||||
man/man1/autoconf.1
|
||||
man/man1/autoheader.1
|
||||
man/man1/autoreconf.1
|
||||
man/man1/autoscan.1
|
||||
man/man1/autoupdate.1
|
||||
man/man1/config.guess.1
|
||||
man/man1/config.sub.1
|
||||
man/man1/ifnames.1
|
||||
share/autoconf/INSTALL
|
||||
share/autoconf/acfunctions
|
||||
share/autoconf/acfunctions.m4
|
||||
share/autoconf/acgeneral.m4
|
||||
share/autoconf/acheaders
|
||||
share/autoconf/acheaders.m4
|
||||
share/autoconf/acidentifiers
|
||||
share/autoconf/aclang.m4
|
||||
share/autoconf/aclibraries
|
||||
share/autoconf/acmakevars
|
||||
share/autoconf/acoldnames.m4
|
||||
share/autoconf/acprograms
|
||||
share/autoconf/acspecific.m4
|
||||
share/autoconf/actypes.m4
|
||||
share/autoconf/acversion.m4
|
||||
share/autoconf/autoconf.m4
|
||||
share/autoconf/autoconf.m4f
|
||||
share/autoconf/autoheader.m4
|
||||
share/autoconf/autoheader.m4f
|
||||
share/autoconf/config.guess
|
||||
share/autoconf/config.sub
|
||||
share/autoconf/m4sh.m4
|
||||
share/autoconf/m4sugar.m4
|
||||
@dirrm share/autoconf
|
||||
|
|
Loading…
Reference in a new issue